Am 20.05.2022 bekommt das Forum ein neues Update. Ab ca. 12:00 ist das Forum nicht mehr erreichbar und wird spätestens am 21.05. wieder online sein. Alle bis dahin erstellten Daten bleiben natürlich erhalten.

Vielen Dank für euer Verständnis. Bei Rückfragen: webmaster@linux-club.de (Christian)

apche und passwortzugriff eine verständnis frage

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
mycroft
Member
Member
Beiträge: 65
Registriert: 15. Dez 2004, 08:10

apche und passwortzugriff eine verständnis frage

Beitrag von mycroft »

moin an alle :-)
ich hätte mal eine grundsätzliche verständniss frage.
ich habe auf einem rechner suse10.0 (standard installation) apache2 installiert.
funktioniert alles prima web-seiten aus dem internen und externen lan erreichbar.
alles supi. so nun zu meiner frage.
ich habe zwei benuter geniert, nennen wir sie mal user1 und user2.
dann habe ich in der default-server.conf zwei neue aliase verzeichnisse angelegt.
nennen wir sie mal home und daten. das verzeichnis daten liegt innerhalb von home.
aber nicht in einem benutzer verzeichnis.
dann habe ich home so eingeschränkt, dass nur user1 auf home zugriff hat. es wird ein
"require user user1". für das verzeichnis daten habe ich angegeben "require valid-user"
damit auch user1 und 2 auf das verzeichnis daten zugreifen können.
aber user2 nur auf /home/Daten zugreifen kann und nicht auf home. soweit funktioniert das auch.
aber und jetzt kommt es. ich habe von einem winxp rechner das ganze getestet. die passwörter werde
abgefragt, aber nur das erstmal, wenn ich erneut auf den server zugreife, erhalte ich zugriff auf
beide verzeichnisse. es wird kein passwort mehr abgefragt. ich kann da es nun vorkommen kann, dass
sowohl user1 als auch user2 an dem selben winxp rechner mit dem selben account arbeiten, nämlich user1
ist dies etwas problematisch. wenn ich daten es ie lösche (cookies/cache/verlauf) werdn die passwörter
erneut abgefragt. ich vermute ich kann an der apache konfiguration nicht ändern, damit dieser "fehler"
nicht auftritt, oder? ich vermute eher ich muß/sollte auf dem winxp rechner ein zweites benutzerkonto
user2 anlegen. oder gibt es alternativen, dass die passwortabfrage bei jedem zugriff erfolgt?
danke schonmal für eure hilfe
grüße
tom
beleg
Member
Member
Beiträge: 220
Registriert: 26. Jul 2004, 10:18
Wohnort: Oldenburg
Kontaktdaten:

Beitrag von beleg »

Naja, dafür gibt es ja die Möglichkeit für verschiedene Nutzer an einem Rechner verschieden Nutzerkonten einzurichten. Wenn bei jedem Zugriff auf ein Verzeichnis wieder das Passwort abgefragt werden würde, dann müsstest Du bei jedem Dateiaufruf innerhalb des Verzeichnis wieder Dein Passwort eingeben. Das wäre glaube ich sehr umständlich. Im übrigen, denke ich ist es wohl auch problematisch, wen Du einem Benutzer des XP-Rechners zwar den Zugang zu einem Verzeichnis auf dem Webserver verweigerst, ihm aber im Gegenzug Zugriff auf die Dateien des anderen Nutzers (der in das Verzeichnis auf dem Webserver darf) gewährst. Diese "Sicherheits"-logik entzieht sich ein wenig meinem Verständnis.
Antworten