Am 20.05.2022 bekommt das Forum ein neues Update. Ab ca. 12:00 ist das Forum nicht mehr erreichbar und wird spätestens am 21.05. wieder online sein. Alle bis dahin erstellten Daten bleiben natürlich erhalten.

Vielen Dank für euer Verständnis. Bei Rückfragen: webmaster@linux-club.de (Christian)

Wake on LAN nicht verfügbar obwohl hersteller angibt

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
zepho
Newbie
Newbie
Beiträge: 5
Registriert: 2. Mär 2006, 20:21

Wake on LAN nicht verfügbar obwohl hersteller angibt

Beitrag von zepho »

Erst mal Hey zusammen,

also ich will meinen pc via WOl anschalten und mit ssh runterfahren, also hab ich mir ein Mainboard besorgt, das onboard LAN hat und Wake on lan unterstützt (siehe http://www.asrock.com/product/K7S41GX.htm)
Bios is aktuell, aber im BIOS stehen keine, wirklich keine optionen um wol ein oder auszustellen (Ernsthaft, hab etwa 5x intensiv danach gesucht).

Wenn ich den pc jetz runterfahre und mal kurz den netzstecker rausziehe und wieder rein steck, dann fährt der pc hoch, allerdings nur, wenn der netzwerkstecker drinnen steckt (hat wohl was mit dem router zu tun)

wenn ich im linux als admin reingehe und dann ethtool aufrufe, kommt folgendes:
  • Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Current message level: 0x000000c5 (197)
    Link detected: yes
eigentlich sollte doch da dann wol: enabled oder so was stehen, oder?

also ich bin mit meinem latein am ende, jemand ne idee?
Luggi
Newbie
Newbie
Beiträge: 5
Registriert: 24. Jan 2006, 00:17

Beitrag von Luggi »

Hallo,
Bios is aktuell, aber im BIOS stehen keine, wirklich keine optionen um wol ein oder auszustellen (Ernsthaft, hab etwa 5x intensiv danach gesucht).
hast Du es im BIOS Setup schon mal mit der Option
"Power Setup Menu" -> "PCI Devices Power On"
versucht? (Es gibt auch eine Option "Ring-In Power On", die steht aber vermutlich für WOR.)
wenn ich im linux als admin reingehe und dann ethtool aufrufe, kommt folgendes:
...
eigentlich sollte doch da dann wol: enabled oder so was stehen, oder?
Dem Datenblatt von Asrock kann ich den Typ der Netzwerkkarte nicht entnehmen, aber ethtool zeigt bei meiner 3c905C auch kein WOL an, funktioniert aber trotzdem. WOL wird bei dieser Karte beim Laden des Moduls über eine Option aktiviert, s. modinfo <modulname>.

Gruß,
Luggi
Antworten