Am 20.05.2022 bekommt das Forum ein neues Update. Ab ca. 12:00 ist das Forum nicht mehr erreichbar und wird spätestens am 21.05. wieder online sein. Alle bis dahin erstellten Daten bleiben natürlich erhalten.

Vielen Dank für euer Verständnis. Bei Rückfragen: webmaster@linux-club.de (Christian)

[gelöst] - WARNING: The "printer admin" option is

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Benutzeravatar
riedernet
Newbie
Newbie
Beiträge: 12
Registriert: 17. Nov 2005, 08:53

[gelöst] - WARNING: The "printer admin" option is

Beitrag von riedernet »

Hallo,

da ich noch nicht viel Erfahrung mit Linux habe, habe ich mir mit Hilfe von einigen Büchern einen Printserver gebastelt. Dazu verwende ich folgende smb.conf:

[global]
workgroup = TESTLINUX
netbios name = TUXPRINT
security = user
printcap name = cups
load printers = Yes
printing = cups
domain logons = No
domain master = No
guest ok = Yes
guest account = nobody
printer admin = @ntadmin, root

[printers]

comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = Yes
guest ok = Yes
create mask = 0600
use client driver = No
read only = Yes
admin users = @ntadmin, root

[print$]
comment = Drucker Treiber
path = /var/lib/samba/drivers
write list = @ntadmin, root
browseable = No
guest ok = Yes
read only = Yes

wenn ich die Datei mit testparm überprüfe erscheint immer die Fehlermeldung: WARINING: The "printer admin" option is deprecated

Was kann ich dagegen tun bzw. wie kann ich einen Printer Admin einrichten, der auch akzeptiert wird?

gruß Fabian

edit Mod.: auf gelöst gesetzt 6.3.06
Benutzeravatar
riedernet
Newbie
Newbie
Beiträge: 12
Registriert: 17. Nov 2005, 08:53

Beitrag von riedernet »

Weiss denn keiner woran das liegt oder habe ich einen so blöden Fehler gemacht das hier keiner eine Antowort schreiben will?
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

Laut der Manpage von smb.conf ist diese Option am Sterben und wird in Zukunft herausfallen. Im Moment funktioniert sie aber noch und deshalb kannst Du den Hinweis einfach ignorieren. Näheres siehe 'man smb.conf'.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
Benutzeravatar
riedernet
Newbie
Newbie
Beiträge: 12
Registriert: 17. Nov 2005, 08:53

Beitrag von riedernet »

Danke für die Hilfe.

Hab allerdings noch eine Frage:

Wo finde ich die "man smb.conf" ?
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16685
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois »

riedernet hat geschrieben:
Wo finde ich die "man smb.conf" ?
Einfach in der Konsole eingeben. :wink:
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

Oder komfortabler im konqueror: 'man:smb.conf'.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
Benutzeravatar
riedernet
Newbie
Newbie
Beiträge: 12
Registriert: 17. Nov 2005, 08:53

Beitrag von riedernet »

Nochmals vielen Dank für eure Hilfe!
Gesperrt