Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

T-Sinus 111 data schmiert ständig ab

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
okraits
Newbie
Newbie
Beiträge: 5
Registriert: 14. Apr 2004, 19:55

T-Sinus 111 data schmiert ständig ab

Beitrag von okraits »

Hallo zusammen,

erstmal die Fakten:

T-Sinus 111 data USB-Wlan-Adapter
Suse 9.0 Pro
Kernel 2.4.21.99 (der mitgelieferte)
Treiber: linux-wlan-ng-0.2.1-pre20 (der aktuellste)

Der Treiber ließ sich einwandfrei kompilieren, das prism2_usb-Modul wird geladen und die Verbindung zum AP aufgebaut.

Nur hält die Verbindung dann immer ne Weile (variiert zwischen 5 min und 8 h), dann bricht sie zusammen. Dann ist der USB-Adapter nicht mehr ansprechbar und es hilft nur noch ein Neustart.

Mich wundert ziemlich, daß der Adapter grundsätzlich funktioniert, aber dann immer nach unterschiedlicher Zeit abschmiert.

Für Tips wäre ich sehr dankbar!
Benutzeravatar
punto31
Newbie
Newbie
Beiträge: 16
Registriert: 9. Mär 2004, 09:59
Wohnort: NRW
Kontaktdaten:

Beitrag von punto31 »

hatte den sinus 111 auch hab ich bei ebay reingestellt weil das ding voll müll war....
tstrutz
Newbie
Newbie
Beiträge: 32
Registriert: 14. Mär 2004, 17:16

Beitrag von tstrutz »

Hallo,

der Sinus 111 data ist ganz im Gegenteil ein relativ problemlos unter Linux zu nutzender Adapter.
Wenn es unter Linux Probleme gibt sind die Logdateien immer der erste Anlaufpunkt. So pauschal ist eine Ferndiagnose nicht möglich.

Zu beachten ist auch, daß der Telekom-Router (Sinus 111) anfänglich eine sehr instabile Firmware hatte, und sich gerne aufhing. Neue Firmware über Telekom. Mit dem Absturz (oder was auch immer) des Sinus 111 data hat das natürlich nichts zu tun.

Also mehr Infos
Grüße
Tobias
okraits
Newbie
Newbie
Beiträge: 5
Registriert: 14. Apr 2004, 19:55

Beitrag von okraits »

Grundsätzlich funktioniert er ja, nur halt nicht dauerhaft. Und die Ausfälle sind zeitlich und auch kausal absolut nicht nachvollziehbar. Die Logs bringen da leider auch keine neuen Erkenntnisse. Ich denke aber, daß das eher ein USB-Problem ist. Ich hab mir jetzt eine Netgear MA 311 zugelegt und wenn ich die einwandfrei zum Laufen bekomme, verkauf ich den T-Sinus. Mit PCI bin ich einfach auf der sicheren Seite.
Gast

Beitrag von Gast »

Hallo,

natürlich kann andere Hardware eine Lösung darstellen.
Aber es ist eben bestimmt nicht richtig, daß der Sinus 111 data grundsätzlich nicht stabil läuft. Meine System läuft absolut problemlos.

Das die Logs keinen Hinweis geben ist eher ungewöhnlich. Vorausgesetzt das dein System korrekt aufgesetzt ist, geben diverse Logdateien natürlich auch Aufschluß über eventuelle Hardwareprobleme.

Die Zeiten, als USB unter Linux Probleme bereitet hat sind lange vorbei.

Grüße
Tobias
tstrutz
Newbie
Newbie
Beiträge: 32
Registriert: 14. Mär 2004, 17:16

Beitrag von tstrutz »

:-) login
okraits
Newbie
Newbie
Beiträge: 5
Registriert: 14. Apr 2004, 19:55

Beitrag von okraits »

Hallo,

das sollte natürlich keine Verallgemeinerung sein. Der T-Sinus 111 data kann durchaus in anderen System einwandfrei laufen. Nur halt in meinem speziellen Fall leider nicht. Im Systemlog stand:

Apr 5 12:16:05 AMD_XP_2600 kernel: hfa384x_usbin_ctlx: Could not match IN URB(0x8001,0) to CTLX - ignored
Apr 5 12:16:05 AMD_XP_2600 last message repeated 2 times
Apr 5 12:16:07 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_TIMEOUT
Apr 5 12:16:07 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5
Apr 5 12:16:08 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_TIMEOUT
Apr 5 12:16:08 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5
Apr 5 12:16:09 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_TIMEOUT
Apr 5 12:16:09 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5
Apr 5 12:16:10 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_TIMEOUT
Apr 5 12:16:10 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5
Apr 5 12:16:13 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_TIMEOUT
Apr 5 12:16:13 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5
Apr 5 12:16:14 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_TIMEOUT
Apr 5 12:16:14 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5
Apr 5 12:16:14 AMD_XP_2600 kernel: NETDEV WATCHDOG: wlan0: transmit timed out
Apr 5 12:16:14 AMD_XP_2600 kernel: wlan0 rx pipe reset complete.
Apr 5 12:16:14 AMD_XP_2600 kernel: wlan0 tx pipe reset complete.
Apr 5 12:16:16 AMD_XP_2600 kernel: hfa384x_dorrid: ctlx failure=REQ_FAILED
Apr 5 12:16:16 AMD_XP_2600 kernel: prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-5

Das sagt mir halt leider aufgrund meiner begrenzten Linux-Kenntnisse nichts. Nur hatte ich das Gefühl, daß es vielleicht mit meinem nForce-Chipsatz und USB zu tun hat. Normalerweise bin ich wirklich niemand, der bei nem Hardwareproblem sofort sagt "Wegwerfen und was anderes kaufen", aber ich hab mehrere Tage in die Lösung des Problems investiert, verschiedene Möglichkeiten durchprobiert und es war leider nicht von Erfolg gekrönt. Deshalb mein Wechsel zur "sicheren" Variante mit PCI und einer bewährten Karte.

Gruß

Oliver
Antworten