Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Mac OS X und NFS

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
fishy
Newbie
Newbie
Beiträge: 8
Registriert: 14. Apr 2004, 00:26

Mac OS X und NFS

Beitrag von fishy »

Hi Leute,

Ich hab ein Problem und zwar hab ich auf meinem PC SuSE 9 installiert und als NFS-Server eingerichtet. Wenn ich mich jetzt mit meinem Mac anmelden will sagt der mir immer folgendes : "Die Anmeldung beim Server ist fehlgeschlagen, da der Name oder das Passwort ungültig war."
Hab auf beiden Rechnern den gleichen User angelegt mit gleichem Passwort.

wenn ich auf meinem PC im Verzeichnis /var/log die Datei messages anschau sagt mir die folgendes : "nfsd: request from insecure port xxxxxx"

Kann mir da jemand helfen was ich wie und wo einstellen muß ?

Danke schon mal im voraus.

Grüße vom fishy

Ach ja wenn ich die firewall einschalte geht nix mehr nicht einmal samba den ich vorübergehend aktiviert hab.
khl

osx

Beitrag von khl »

hallo
habe seit kurzem einen g4 powerbook und bin auf ein aehnliches problem gestossen. nachdem ich die server adresse eingegeben habe und verbinden druecke bekomme ich die meldung

"die anmeldung beim server ist fehlgeschlagen, da der name oder das kennwort ungueltig war.

mir ist klar das dies ein linux forum ist, aber vieliecht ist jemand auf ein aehnliches problem gestossen

danke
k
fishy
Newbie
Newbie
Beiträge: 8
Registriert: 14. Apr 2004, 00:26

Beitrag von fishy »

so hab es jetzt hinbekommen.

man muß in der datei exports als option insecure angeben, da wo man auch angibt ro oder rw und dies natürlich mit einem komma trennen.

gruß fishy
maceis
Newbie
Newbie
Beiträge: 3
Registriert: 7. Jun 2004, 15:02

Beitrag von maceis »

hallo zusammen,

ich habe auch ein Problem mit NFS und Mac OS X (10.3.4).
portmap, mountd und nfsd habe ich gestartet.

mit showmount -e erhalte ich eine korrekte Ausgabe.
Wenn ich aber mit mount -t nfs localhost:/freigabe darau zugreifen möchte kommt der berüchtigte "NFS Portmap: RPC: Program not registered".

Dabei bin ich mir sicher, dass es genau mit diesen Einstellungen schon mal funktioniert hat (vor Monaten, also mit einer anderen Unterversion).
Im /var/log/systemlog werden keine Einträge gemacht.
tim.tim
Newbie
Newbie
Beiträge: 4
Registriert: 8. Jan 2005, 10:02

Beitrag von tim.tim »

Das mit dem "insecure" hat mir auch geholfen.
Ein weiterer Parameter "async" bringt die Performance
dann in den erträglichen Bereich ....
Gruss, Tim
Antworten