Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

PPTP + MPPE Problem

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Spunky
Newbie
Newbie
Beiträge: 14
Registriert: 6. Apr 2004, 02:48
Kontaktdaten:

PPTP + MPPE Problem

Beitrag von Spunky »

Hallo zusammen,

Ich habe mich vor einiger Zeit mit PPTP auseinander gesetzt um einen Linux VPN - Server für Windows - Clients einzurichten. Nach einigen anlaufschwierigkeiten habe ich das ganze unter Suse 9.0 auch perfekt zum laufen gebracht!

Jetzt habe ich einen Root-Server gemietet, der allerdings Suse 8.1 installiert hat. Kurz gesagt es läuft nicht!

Ich habe PPTP unter Yast installiert und danach auf meine Anforderungen konfiguriert. Wenn ich jetzt versuche PPTP zu starten, bekomme ich zwei Fehlermeldungen

1. PPTP benötige den Dienst "route"

2. can't locate ppp-mppe ...... usw.

Ich habe darauf hin im Runlevel-Editor unter Suse 9.0 nach geschaut dort existiert auch kein Dienst route. Ich finde auch kein passendes Paket auf den CDs. Wieso mekert Suse 8.1 jetzt an dieser stelle und warum kommt es ohne ppp-mppe unterstüzung ?

Muss ich zwangsläufig den Kernel neu compilieren oder gibt es irgendwoher passende Pakete ?

Vielen Dank im voraus
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Mit 8.1 hab ich es auch noch nicht versucht.
Aber wenn dein Kernel noch nicht MPPE unterstützt, könnte es durchaus sein,
dass du dir einen neuen bauen musst. Aber zu erst würde ich es allein mit den Modulen versuchen (also nur die Module nachziehen)

Schau auch mal hier rein:
http://www.linux-club.de/viewtopic.php? ... =pptp+mppe
http://www.linux-club.de/viewtopic.php? ... =pptp+mppe

greez
PEBKAC = Problem Exists Between Keyboard And Chair
Gast

Beitrag von Gast »

Mit den Modulen hatte ich es bereits vorher probiert! Das brachte aber keine abhilfe das hat nur dazu geführt das es jetzt Fehlermeldungen hagelt wenn ich versuche

modprobe ppp-compress-18

aufzurufen. Auch weiss ich nicht wieso er wegen dem Route mekert! Muss das auch beim Kernel mitkompiliert werden ?

Wo finde ich eine genaue Anleitung wie man den kernel kompiliert und was muss ich dabei genau beachten das ich diese Fehler nicht habe und so wie bei Suse 9.0 keine fehlenden Pakete oder Dienste entstehen !
Ich habe sowas nämlich vorher noch nicht gemacht !
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Schau doch mal nach, ob es (wie bei SuSE9) "/sbin/route" gibt.

Wie man einen neuen Kernel kompiliert steht im SuSE Admin Handbuch
und auch einiges hier in der "Kernel"-Rubrik. Aber ich wäre da vorsichtig,
falls du keinen physikalischen Zugang zu dem Server hast!


btw: Brauchst du wirklich PPTP oder würde es vielleicht auch ein SSH-Tunnel tun?
PEBKAC = Problem Exists Between Keyboard And Chair
Spunky
Newbie
Newbie
Beiträge: 14
Registriert: 6. Apr 2004, 02:48
Kontaktdaten:

Beitrag von Spunky »

Also ich brauche PPTP, weil ich über Samba eine Windowsnetzwerkfreigabe haben will.

Der Root-Server ist mit einem Seriellen Port an einer SSH-Console verbunden, d.h. ich kann schon beim Hochfahren in Lilo etc. eingreifen sowie den vollen startvorgang kontrollieren da ich nur in der Console nicht im Server selber hänge.

Den Befehl route , sowie "/sbin/route" gibt es trotzdem mekert Yast route sei nicht als Dienst aktiviert!
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Schlag mich nicht, aber soweit ich mich erinnere, gab es früher auch mal
einen Service "/etc/{init.d}/route" der die routes initialisiert hat.
Sonst steh ich bei dieser Fehlermeldung jedenfalls auch auf dem Schlauch!
PEBKAC = Problem Exists Between Keyboard And Chair
Spunky
Newbie
Newbie
Beiträge: 14
Registriert: 6. Apr 2004, 02:48
Kontaktdaten:

Beitrag von Spunky »

Diese Datei existiert bei mir weder unter 9.0 noch unter 8.1

Ich habe daraufhin mal /etc/init.d/pptpd mit einander verglichen. Trotz gleicher pptpd version hat die version unter 8.1 noch den zusatz route unter "Requiered-Start" ich habe diese jetzt mal entfernt da es diesen Dienst nicht mehr zu geben scheint!

Jetzt ist nur noch die Frage wie ich den ppp-mppe support vernüpftig integriert kriege! Auch die ppp- Version ist bei beiden Versionen identisch! Suse 8.1 benutzt Kernel 2.4.25

Suse 9.0 benutzt 2.4.21-166athlon auf menem eigenen System. Ich glaube ich werde es noch mal mit dem kernel Patch versuchen so ist es auch in yast bei 9.0 für den pptp - client beschrieben! Allerdings steht da was von einem package ich habe aber außer für Redhat kein fertige ppp-mppe.rpm gefunden oder kann ich das bei gleicher Kernel version evtl. auch verwenden ?
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Angeblich soll ja der SuSE-pppd mppe bereits unterstützen.
Da ich aber auf jeden Fall auch mppe-128 nutzen wollte,
hab ich mir die Sourcen gezogen und mir einen pppd selbst
gebaut. Der funktioniert jetzt problemlos.

Ob man das Redhat-rpm nutzen kann, musst du testen.
Allerdings hängt es nicht nur von dem Kernel sondern
auch von den Pfaden zu anderen Konfigdateien und Libraries ab.
PEBKAC = Problem Exists Between Keyboard And Chair
Spunky
Newbie
Newbie
Beiträge: 14
Registriert: 6. Apr 2004, 02:48
Kontaktdaten:

Beitrag von Spunky »

Könntest du mir vielleicht ne Anleitung schreiben wie du das genau gemacht hast ? Und welche Pakete du verwendet hast etc.

Ich bin bisher nach den Tutorial in diesem Forum vorgegangen so wie es für ppp 2.4.2 mit mppe + mppc unterstüzung beschrieben war! Es enstehen auch keine Fehlermeldungen und es scheint alles probelmlos zu klappen modprobe ppp-compress-18 scheitert aber trotzdem mit der Fehlermeldung can't locate module!

Ich wäre dir sehr dankbar :D
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Du beziehst dich auf diesen Eintrag in der /etc/modules.conf:
"alias ppp-compress-18 ppp_mppe_mppc" ??

Sorry, aber es gibt ja auch kein Modul, das "ppp-compress-18" heißt.

Was passiert, wenn du pptp startest und dann eine VPN-Verbindung aufbaust.
Was wird dann in /var/log/messages gelogged??
PEBKAC = Problem Exists Between Keyboard And Chair
Gast

Beitrag von Gast »

ich will pptpd als Dienst starten, damit sich andere Leute per VPN in meinem Server einwählen können und genau da hackt es schon , ich kriege den Dienst nicht gestartet, weil dr beim starten

modprobe ppp-compress-18 testet und da das nicht geht, wird der Dienst auch nicht gestartet!
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Ich kann nur wiederholen, dass es auch bei mir auch kein Modul "ppp-compress-18" gibt. :?

Das Skript "/etc/init.d/pptpd" läd nur das Modul "ppp_mppe_mppc".

Code: Alles auswählen

# lsmod
Module                  Size  Used by    Not tainted
ppp_mppe_mppc          21832   0  (unused)
ppp_generic            20424   0  [ppp_mppe_mppc]
slhc                    5152   0  [ppp_generic]
Schau doch nochmal in das Start-Skript, vielleicht musst du es etwas anpassen:

Code: Alles auswählen

# vi /etc/init.d/pptpd
...
PPTPD_BIN=/usr/sbin/pptpd
test -x $PPTPD_BIN || exit 5
...
    start)
        echo -n "Starting MS VPN server pptpd"
        #if modprobe ppp_mppe ; then
        if modprobe ppp_mppe_mppc ; then
                startproc $PPTPD_BIN
                rc_status -v
        else
                rc_failed 3
        fi
        ;;
...
in meiner /etc/modules.conf steht das:

Code: Alles auswählen

if `kernelversion` == "2.2"
alias ppp0                ppp
alias ppp1                ppp
alias tty-ldisc-3         ppp
else
alias ppp0                ppp_generic
alias ppp1                ppp_generic
alias tty-ldisc-3         ppp_async
endif

alias plip0 plip
alias plip1 plip

# Tunnel interfaces
alias sit0 ipv6
alias gre0 ip_gre
alias ipip0 ipip

#alias ppp-compress-18 ppp_mppe
alias ppp-compress-18 ppp_mppe_mppc
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate




Vergleich doch nochmal die Dateien, vielleicht siehst du Unterschiede/Auffälligkeiten.


greez
PEBKAC = Problem Exists Between Keyboard And Chair
Gast

Beitrag von Gast »

hm.. ok habe die ändern gemacht... hilf aber nix ! wenn ich z..b modprobe ppp_mppe_mppc versuche.... erhalte ich den gleichen fehler can't locate modul! Ich glaube das bei mir bereits was beim patchen des kernels schief läuft bzw. ich was falsch mache.

Könntest du deswegen ne kleine Anleitung schreiben welche module du instaliert hast und was du am Kernel eingestellt hast etc.

Ich habe mich an diesen Beitrag hier gehalten http://www.linux-club.de/viewtopic.php?p=22204#22204

Wie gesagt es treten keine fehler auf aber funktionieren tut es trotzdem nicht, weil ich glaube das ich irgendwas beim patchen des kernels falsch mache!
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Im Grunde bist du ja schon ziemlich weit!

Im Kernel hab ich nur das PPP-MPPE-Modul aktivert.
"CONFIG_PPP_MPPE=m"

Setz mal den Befehl ab:
"find /lib/modules -name "ppp_mppe_mppc.o"

und:
"uname -r"

Was erhälst du?
PEBKAC = Problem Exists Between Keyboard And Chair
Spunky
Newbie
Newbie
Beiträge: 14
Registriert: 6. Apr 2004, 02:48
Kontaktdaten:

Beitrag von Spunky »

Bei "find /lib/modules -name "ppp_mppe_mppc.o"
Passiert nichts. Scheint also zu klappen!

bei uname - r erhalte ich "2.4.25"
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Nein genau da stimmt es nicht, denn es müsste etwa so aussehen:

Code: Alles auswählen

# find /lib/modules -name "ppp_mppe_mppc.o"
/lib/modules/2.4.21-99-default/kernel/drivers/net/ppp_mppe_mppc.o
/lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o
Als du den PPP-Daemon übersetzt hast, wirst du evtl "make install"
vergessen haben.
PEBKAC = Problem Exists Between Keyboard And Chair
Spunky
Newbie
Newbie
Beiträge: 14
Registriert: 6. Apr 2004, 02:48
Kontaktdaten:

Beitrag von Spunky »

also bei mit steht jetzt

/lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o

wenn ich # find /lib/modules -name "ppp_mppe_mppc.o" eingebe!


# modprobe ppp_mppe_mppc
/lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o: unresolved symbol ppp_register_compressor_Rsmp_9682e733
/lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o: unresolved symbol ppp_unregister_compressor_Rsmp_a1b928df
/lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o: insmod /lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o failed
/lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o: insmod ppp_mppe_mppc failed




erzeugt diesen schönen Fehler ! Deb hatte ich vor ein paar Tagen schon mal!
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Hattest du schon "depmod" abgesetzt?

Wenn ja, dann musst du vielleicht doch nochmal den Kernel-Patch einspielen:

Code: Alles auswählen

# cd /usr/src
# patch -p0 < linux-2.4.25-mppe-mppc-0.98.patch
# cd linux
# make menuconfig
... mppe als modul aktivieren
... kernel übersetzen, installieren
... module übersetzten, installieren
dann mal weiterschaun.
PEBKAC = Problem Exists Between Keyboard And Chair
Gast

Beitrag von Gast »

Hm... ok jetzt mal für dumme...

Nach dem ich mit make menuconfig mppe als Modul aktiviert habe

und die kernel konfiguration gespeichert habe folgt dann

"make dep"

dann "make modules" und "make modules_install"

Ich bekomme aber schon beim "make modules_install" am ende
folgende Meldung:

depmod: *** Unresolved symbols in /lib/modules/2.4.25/kernel/drivers/net/ppp_mppe_mppc.o
depmod: ppp_register_compressor_Rsmp_9682e733
depmod: ppp_unregister_compressor_Rsmp_a1b928df


Was mache ich bei depmod falsch und was ist das überhaupt ?
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

"depmod" soll die Abhängigkeiten zwischen den Modulen herstellen.

Aber diese Fehlermeldung, die du da bekommst kenne ich auch nicht.

Vielleicht musst du auch das ganze Programm durchziehen:
- make dep
- make clean
- make bzImage
- make modules
- make modules_install

Falls du das "make clean" nicht abgesetzt hast, werden nur die neuen,
hinzugekommen Module übersetzt und die alten, bei denen sich in Bezug
auf mppe auch was ändern muss, nicht :?

*drück die daumen*
PEBKAC = Problem Exists Between Keyboard And Chair
Antworten