Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Windowsprofile auf Linux abspeichern

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
katen
Newbie
Newbie
Beiträge: 22
Registriert: 27. Mär 2004, 16:39

Windowsprofile auf Linux abspeichern

Beitrag von katen »

Hallo,
ich suche nur nach Stichwörter. Natürlich keine Anleitung.

Wer kann mir sagen, wie/womit ich die Profile von XP auf den Linuxserver installieren kann. Damit sich im Schulungsraum jeder Benutzer von jede Rechner aus anmelden kann und seine eigene Oberfläche sieht.
Welche Server müssen installiert werden?

In meinem Bekantenkreis zeigte sich, dass keine Firma diese dynamische Benutzung der Arbeitsplätze nutzt.

Danke für eure Mühe in voraus.

Karsten
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Hi,

du solltest den Linux-Rechner als SAMBA-PDC aufsetzen.
Hilfreich dabei wird dir zum einen das SAMBA-Subforum sein und das/die Videos von cybermailer.
http://www.linux-club.de/viewtopic.php?t=1137
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai »

Such Dir die Samba3.02 rpms für Suse, installier die und schau Dir die mitgelieferte Doku an!
/usr/share/doc/packages/samba3/

IM oben genannten Ordner findest Du z.B. einen Ordner html, der enthält die meissten Informationen, die Du brauchst.
Benutzeravatar
katen
Newbie
Newbie
Beiträge: 22
Registriert: 27. Mär 2004, 16:39

Ein Stück weiter. Danke

Beitrag von katen »

Danke für die Info von euch.
Ich habe den PDC über Samba aufgesetzt. Er läuft gut.
Mir ist immer noch nicht klar (ich habe recherchiert) wie ich die Profile nur auf den Server ablege.
Klartext: 5 XP melden sich am PDC an. Jeder Mitarbeiter soll sich an jedem Rechner anmelden können und dort seine eigenes Profil (Desktop usw.) sehen.

Danke für weitere Infos.

Grüße
Karsten
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Du hast Linux als PDC eingerichtet, hast die User auf dem Linux angelegt und Samba bekannt gemacht?
Hast in der smb.conf einen LW-Buchstaben für das Home angegeben?
Und die User melden sich an den Clients an der Domäne an?
Dann sollte es funzen.

PS: Die Client müssen natürlich auch in die Domäne aufgenommen worden sein :wink:
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
katen
Newbie
Newbie
Beiträge: 22
Registriert: 27. Mär 2004, 16:39

ER will, aber er aknn nicht so recht!

Beitrag von katen »

zuerst Dank für die Tipps. :-)
Hi,
Habe alles so eingerichtet. Und siehe?! Es funktioniert.... halb.
Mein Benurtzer kann auf dem Server zugreifen. Das Laufwerk z erscheint.
Zwei weitere Benutzer konnten sich an der Domain nicht anmelden (Die Domain steht nicht zur Verfügung). Starte ich lokal, dann kann ich über Samba die Ordner in der Netzwerkumgebung sehen.
Wenn ich ein Ordner auf dem Desktop anlege wird der auch bei der Abmeldung auf dem Server gespeichert. Lösche ich den Ordner. Erscheint er nach dem Neustart wieder. Das Desktop-Hintergrundbild wird auch nicht mitgesichert.
Nach mehrmaligen Test konnte sich der erste Benutzer auch nicht mehr über die Domain anmelden. Nur lokal und wieder Samba_file-Server.

Das ist der Stand der Dinge.

Danke für eure Mühe.
Karsten
Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai »

Funktioniert die Namensauflösung?

Wenn Du in einem Windowsnetzwerk sicher gehen willst, daß etwas funktioniert, solltest Du den Servern immer 15min Zeit geben. Wenn es mehrere Server sind, die in unterschiedlichen Subnetzen liegen, kann es sogar sein, daß es eine Dreiviertelstunde dauert, bis der letzte Browsermaster die Namensauflösung richtig verstanden hat.

Grundsätzlich.
Teste zuerst Ping, wenn das geht, überprüfe, ob die XP Clients alle als Rechneraccounts zur Verfügung stehen. Schau Dir die Logfiles an, wenn etwas schiefgeht.

Du kannst auch das loglevel der deamons einstellen, daß Du mehr Output erhälst.

Hast Du die Registry gepatchd? Sind die Clients neu installiert, oder ist eventuell die Registry schon zerschossen? Hatte letztens ein neu installiertes XP ans Inet gehängt, um Virenscanner und Firewall downzuloaden, bin aber gar nicht so weit gekommen :) noch keine 5 minuten im Netz und der erste Lovesan/E hatte mich :)


Es kann sein, daß Du hier im Sambateil des Forums mehr Antworten bekommst. Da haben einige mehr Ahnung davon als ich.
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)
Benutzeravatar
katen
Newbie
Newbie
Beiträge: 22
Registriert: 27. Mär 2004, 16:39

Ostern ist vorbei, jetzt kommt die Linuxzeit.

Beitrag von katen »

Hallo.
Habe alles gemacht, sogar die Rechner neu aufgesetzt.

Jetzt bekomme ich bei der Anmeldung von XP eine Info, das das servergespeicherte Profil nicht gefunden wird (auch das lokale Profil) und ich werde nur als Gast angemeldet.
Ich will lokal auch kein Profil anlegen. Ich verstehe auch das Linux keins hat. Aber wo kommt es den her?
Es sollte bei ersten Anmeldung von einem neuen XP-Benutzer auf dem Server gespeichert werden. DENKE ICH MIR.

Danke für die Hilfe
Benutzeravatar
katen
Newbie
Newbie
Beiträge: 22
Registriert: 27. Mär 2004, 16:39

Jetzt klappt es.

Beitrag von katen »

Hi,

jetzt klappt es....fast.
DANK eurer Tipps kann der Benutzer sich anmelden und sein Profil wird geladen. Super soweit. Ich habe in der smb %U hinter path setzt.
Es zeigt sich nur noch ein Problem:
Client wird angemeldet. Erstelle ein Ordner (leer) auf dem Desktop, Melde Client ab und wieder an. Dann kann ich den Ordner löschen. Erste ich einen weiteren Ordner, dann kann ich diesen nach dem Ab- und Anmelden nicht mehr löschen (lokal unter Windows ja, nach der Neuanmeldung ist er wieder da, da der ordner ja noch im Profil ist).

Danke für eure Mühe
Karsten


[global]

wins support = Yes

[homes]
path = /home/%U
read only = No
Benutzeravatar
katen
Newbie
Newbie
Beiträge: 22
Registriert: 27. Mär 2004, 16:39

Problem selbst gelöst.

Beitrag von katen »

Hi,

ich habe die Lösung gefunden und will sie nicht nur für mich behalten.

In Windows XP qpedit.msc ausführen; Computerkonfiguration;Administrative Vorlagen; System; Benutzerprofile; Besitzrechte von Ordnern servergespeicherten Profile nicht prüfen
muss aktiviert werden.

Danach klappt es:
Dieses Lösung soll auch anderen Helfen.

Grüße
Karsten
Larifari
Newbie
Newbie
Beiträge: 6
Registriert: 3. Aug 2004, 00:23
Wohnort: Aschaffenburg

Beitrag von Larifari »

@katen
du meintest sicher den group policy editor
der wird naemlich mit gpedit.msc aufgerufen
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4383
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 »

Moin, Moin,

mal 'ne ganz dumme Frage von mir dazu: Diese Authentifizierung und das zur Verfügung stellen von Homedirectorys sowie der policys müßte sich doch auch über ldap regeln lassen? Das Activ Directory von Microsoft arbeitet doch auch mit diesem Protokoll, von daher müßte man das Ganze doch auch über openldap machen können. Oder hab ich jetzt den Einsatzzweck von ldap verkehrt verstanden oder gar Stolpersteine bei heterogenen Netzwerken übersehen?
Benutzeravatar
ThomasF
Hacker
Hacker
Beiträge: 578
Registriert: 1. Mai 2004, 12:37
Wohnort: Köln

Beitrag von ThomasF »

Hi,

nein Du hast das schon richtig verstanden mit Ldap, zumindest für die Benutzer-Authentifizierung.

Schau doch einfach mal in den Samba-Bereich dieses Forums ;-)

Grundsätzlich aber hast Du recht, Samba kann die Passwörter sowie die Pfade zu den Scripten und Profilen und das Homelaufwerk in Ldap speichern.

Für die Einrichtung gibt es auch jede Menge gute Doku.

Gruß

ThomasF
Antworten