Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix status=dead

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Postfix status=dead

Beitrag von linuxbaby »

Hallo
ich bin dabei einene mailserver aufzusetzen aber es hakt leider schon bei
dem start von postfix. distri ist suse 9.0

Code: Alles auswählen

rcpostfix status dead
beim systemstart wird der service gestartet

Code: Alles auswählen

Starting Postfix ... done
wenn ich aber nun in yast im runlevel-editor schaue steht da

Code: Alles auswählen

postfix          NEIN                 3            5
wenn ich dort also in yast den status abfrage kommt folgende meldung

Code: Alles auswählen

/etc/init.d/postfix status gab 1 (Programm ist abgestürzt und pid-Datei /var/run ist vorhanden) zurück:
Checking for service Postfix: ..dead
telnet localhost ist übrings auch nicht mehr möglich.
zb

Code: Alles auswählen

telnet localhost 25
Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
ich habe keine ahnung wie ich das zum laufen kriege.
würde mich freuen wenn ihr mir helfen könnt.
mfg
linuxbaby
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Logfile prüfen

Beitrag von basman »

was sagt /var/log/mail? Darin müssten Mecker-Zeilen stehen, in denen Postfix sagt, warum er nicht will.

Provozieren kannst Du das ganze von Hand per

Code: Alles auswählen

/etc/init.d/postfix start
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

hi
das bringt

Code: Alles auswählen

tuxi:~ # /etc/init.d/postfix start
Starting mail service (Postfix)                     done

und in der var/log/mail steht

Code: Alles auswählen

Mar 28 15:56:41 tuxi postfix/postfix-script: starting the Postfix mail system
Mar 28 15:56:41 tuxi postfix/master[1717]: fatal: parameter inet_interfaces: no local interface found for 80.137.224.17
Mar 28 15:57:42 tuxi postfix/postqueue[2276]: fatal: Cannot flush mail queue - mail system is down
Mar 28 16:02:18 tuxi postfix/postfix-script: starting the Postfix mail system
Mar 28 16:02:18 tuxi postfix/master[3368]: fatal: parameter inet_interfaces: no local interface found for 80.137.224.17
Mar 28 16:03:19 tuxi postfix/postqueue[3501]: fatal: Cannot flush mail queue - mail system is down
Mar 28 16:33:29 tuxi postfix/postfix-script: fatal: usage: postfix start (or stop, reload, abort, flush, or check)
Mar 28 16:47:22 tuxi postfix/postfix-script: starting the Postfix mail system
Mar 28 16:47:22 tuxi postfix/master[3764]: fatal: parameter inet_interfaces: no local interface found for 80.137.224.17
Mar 28 16:48:22 tuxi postfix/postqueue[3888]: fatal: Cannot flush mail queue - mail system is down
unter inet_interfaces steht bei mir in der main.cf

Code: Alles auswählen

inet_interfaces = $myhostname, localhost 
myhostname = xxx.serveftp.net
ich weiß nicht mehr weiter was ich mir vorstellen könnte ist das localhost irgendwie nicht richtig erkannt wird weil telnet localhost brint auch ein
connection refused....
mfg
linuxbaby
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

kann ja nicht gehen wenn postfix down ist......
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Beitrag von basman »

Kommentiere die interface-Zeile in der main.cf aus. Dann nimmt Postfix alle aktiven Interfaces. Dein Server steht hinter einer NAT-Firewall in einer DMZ und hat gar kein Interface mit der public IP? - Dann ist das die Lösung.
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

hi
also ich habe jetzt in der main.cf
proxy_interfaces = 192.168.1.100 -> router gesetzt
aber es funtz net ich kann nach 18 h mittlerweile
auch nicht mehr richtig klar denken ;)
im moment bin ich soweit das der cyrus imap wohl läuft
nur postfix und sendmail zicken rum :(
tail /var/log/mail

Code: Alles auswählen

Mar 29 23:44:15 tuxi postfix/lmtp[17600]: CADD1142454C: to=<mrnice@tibet.serveftp.net>, orig_to=<root>, relay=none, delay=0, status=deferred (connect to /var/lib/imap/socket/lmtp[/var/lib/imap/socket/lmtp]: Permission denied)
Mar 29 23:45:07 tuxi postfix/smtpd[17621]: fatal: open database :/etc/postfix/client-access.db: No such file or directory
Mar 29 23:45:08 tuxi postfix/master[16462]: warning: process /usr/lib/postfix/smtpd pid 17621 exit status 1
Mar 29 23:45:08 tuxi postfix/master[16462]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Mar 29 23:46:08 tuxi postfix/smtpd[17622]: fatal: open database :/etc/postfix/client-access.db: No such file or directory
Mar 29 23:46:09 tuxi postfix/master[16462]: warning: process /usr/lib/postfix/smtpd pid 17622 exit status 1
Mar 29 23:46:09 tuxi postfix/master[16462]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Mar 29 23:47:09 tuxi postfix/smtpd[17625]: fatal: open database :/etc/postfix/client-access.db: No such file or directory
Mar 29 23:47:10 tuxi postfix/master[16462]: warning: process /usr/lib/postfix/smtpd pid 17625 exit status 1
Mar 29 23:47:10 tuxi postfix/master[16462]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
und ein fetchmail -a -v

Code: Alles auswählen

tuxi:/etc/postfix # fetchmail -a -v
fetchmail: es wurden keine Mailserver spezifiziert.
könnte mir da jmd auf die sprünge helfen hier auch nochmal
postconf -n

Code: Alles auswählen

alias_maps = hash:/etc/aliases
body_checks = regexp:/etc/postfix/body_checks
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
default_transport = smtp
disable_dns_lookups = yes
header_checks = regexp:/etc/postfix/header_checks
inet_interfaces = all
mail_owner = postfix
mailbox_transport = lmtp:unix:/var/lib/imap/socket/lmtp
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain $mydomain
mydomain = serveftp.net
myhostname = tibet.serveftp.net
mynetworks = 192.168.1.0/24, 127.0.0.1/8
mynetworks_style = subnet
myorigin = $myhostname
newaliases_path = /usr/bin/newaliases
parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,permit_mx_backup_networks,qmqpd_authorized_clients,relay_domians,smtpd_acess_maps
proxy_interfaces = 192.168.1.100
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost = [smtp.merknix.de]
sample_directory = /etc/postfix/samples
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtpd_banner = $myhostname ESMTP
smtpd_recipient_restrictions = check_sender_access hash:/etc/postfix/sender-access      check_client_access hash::/etc/postfix/client-access
unknown_local_recipient_reject_code = 450
kann es sein das irgendwie die smtp authorizierung fehlt? und wenn ja wie muss ich das vorgehen.....vielen dank für eure hilfe
gn8
linuxbaby
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Beitrag von basman »

Stelle sicher, dass /var/lib/imap/socket/lmtp vom Benutzer postfix lesbar ist.
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

welche rechte darf den der benutzer postfix haben?

[edit]
steht ja da löl, bin noch nicht ganz wach , moin........
[/edit]
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

das müsste doch lesbar sein

Code: Alles auswählen

srwxrwxrwx    1 root     root            0 2004-03-29 23:20 lmtp
also das kann's ja nicht sein.....

[edit]
oder doch :confused:

Code: Alles auswählen

ar 30 14:02:21 tuxi postfix/lmtp[20897]: 2A1FD142454E: to=<mrnice@tibet.serveftp.net>, orig_to=<root>, relay=none, delay=282, status=deferred (connect to /var/lib/imap/socket/lmtp[/var/lib/imap/socket/lmtp]: Permission denied)
[edit]
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Beitrag von basman »

Du musst auch alle Ueber-Verzeichnisse ueberpruefen!
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

wie sollte es denn genau aussehen, kannst mir das mal
aufzeigen bitte
fetchmail läuft war ein syntaxfehler in der fetchmailrc
ein problem ws zu tage beim abholen kommt ist das
fetchmail die mails nicht local in die cyrus-imap verzeichnisse
zustellen kann

Code: Alles auswählen

1 Nachricht für xxxx bei pop3.xxx.de (2711 Oktetts).
fetchmail: POP3> LIST
fetchmail: POP3< +OK
fetchmail: POP3< 1 2711
fetchmail: POP3< .
fetchmail: POP3> RETR 1
fetchmail: POP3< +OK 2711 octets
Nachricht xxxx@xxx.xxx.de:1 von 1 wird gelesen (2711 Oktetts)
fetchmail: SMTP< 220 xxx.serveftp.net ESMTP
fetchmail: SMTP> EHLO localhost
fetchmail: SMTP< 220 xxx.serveftp.net ESMTP
fetchmail: SMTP> HELO localhost
fetchmail: SMTP< 250 xxx.serveftp.net
fetchmail: SMTP> MAIL FROM:<Jenny.xxx@de.xxx.com>
fetchmail: SMTP< 250 Ok
fetchmail: SMTP> RCPT TO:<lin@localhost>
fetchmail: Protokollfehler im SMTP-Lauscher
 nicht geflusht
fetchmail: POP3> QUIT
i don't know... :(

gruß
linuxbaby
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Beitrag von basman »

Die Datei /var/lib/imap/socket/lmtp selbst ist offensichtlich lesbar.

Wenn jedoch auch nur eines der darüberliegenden Verzeichnisse für den user
postfix kein x-Bit gesetzt hat ("ausführbar" im Konqueror), kann der user postfix die Datei nicht lesen.

Du musst also diese Überprüfung durchführen:

Code: Alles auswählen

ls -ld /var /var/lib /var/lib/imap /var/lib/imap/socket
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

Code: Alles auswählen

tuxi:/etc # ls -ld /var /var/lib /var/lib/imap /var/lib/imap/socket
drwxr-xr-x   15 root     root     4096 2004-03-31 14:57 /var
drwxr-xr-x   28 root     root     4096 2004-03-26 07:39 /var/lib
drwxr-x---   13 cyrus    mail     4096 2004-03-31 20:19 /var/lib/imap
drwxr-x---    2 cyrus    mail      88 2004-03-31 14:49 /var/lib/imap/socket
das ist doch so korrekt....
und das kommt wenn ich die mails per fetchmail abhole

Code: Alles auswählen

Nachricht xxx@pop3.web.de:20 von 22 wird gelesen (39530 Oktetts)
fetchmail: SMTP> MAIL FROM:<newsletter@franchise-net.de> BODY=8BITMIME SIZE=39530
fetchmail: SMTP< 250 Ok
fetchmail: SMTP> RCPT TO:<mrnice@localhost>
fetchmail: SMTP< 250 Ok
fetchmail: SMTP> DATA
fetchmail: SMTP< 354 End data with <CR><LF>.<CR><LF>
#***********************.*************************.***************************************.***************************fetchmail: SMTP>. (EOM)
fetchmail: SMTP< 250 Ok: queued as A04EF14257E4
 nicht geflusht
fetchmail: POP3> RETR 21
fetchmail: POP3< +OK Nachricht folgt/message follow
wo bleiben denn die mails? hält postfix die in der queue? und wie lange?
mfg
linuxbaby
Zuletzt geändert von linuxbaby am 31. Mär 2004, 21:31, insgesamt 2-mal geändert.
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

user "postfix" nicht in Gruppe "mail"

Beitrag von basman »

Meiner bescheidenen Meinung nach ist das nicht korrekt. Ich gehe davon aus, dass postfix nicht zur Gruppe Mail gehört. Also fällt der user postfix in Sachen Dateirechte unter "others". Und bei den letzten beiden Verzeichnissen kommt er somit nicht rein.

Abhilfe schafft hier:

Code: Alles auswählen

chmod o+x /var/...imap /var/.../socket
(... entsprechend ergänzen)

Ob ich mich irre und postfix bei Dir ausnahmsweise in der Gruppe mail ist, kann es so festgestellt werden:

Code: Alles auswählen

id postfix
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

stimmt natürlich sorry :)
also das funzt jetzt auch ich komme der sache langsam näher
ich kann jetzt unter evolution meine mails sehen :)
nun kommt aber immer noch das problem das ich
nichts versenden kann :(
die fehlermeldung in evolution sieht so aus

Code: Alles auswählen

Fehler bei folgendem Vorgangs:
RCPT TO <xxx@xxx.de> fehlgeschlagen: Transaktion fehlgeschlagen
und intern kommt dies

Code: Alles auswählen

Fehler bei folgendem Vorgangs:
RCPT TO <maria@tibet.serveftp.net> fehlgeschlagen: Angeforderte E-Mail-Aktion nicht ausgeführt: Postfach nicht verfügbar
ich habe aber doch unter imap postfächer angelegt

Code: Alles auswählen

user.kalle (\HasChildren)               user.maria (\HasChildren)
user.kalle.Ausgang (\HasNoChildren)     user.maria.Ausgang (\HasNoChildren)
user.kalle.Eingang (\HasNoChildren)     user.maria.Eingang (\HasNoChildren)
user.kalle.Entwuerfe (\HasNoChildren)   user.maria.Entwuerfe (\HasNoChildren)
user.kalle.Gesendet (\HasNoChildren)    user.maria.Gesendet (\HasNoChildren)
user.lin (\HasChildren)                 user.mrnice (\HasChildren)
user.lin.Ausgang (\HasNoChildren)       user.mrnice.Ausgang (\HasNoChildren)
user.lin.Eingang (\HasNoChildren)       user.mrnice.Eingang (\HasNoChildren)
user.lin.Entwuerfe (\HasNoChildren)     user.mrnice.Entwuerfe (\HasNoChildren)
user.lin.Gesendet (\HasNoChildren)      user.mrnice.Gesendet (\HasNoChildren)
noch ne frage was bedeutet das nicht geflusht

Code: Alles auswählen

Nachricht xxx@pxxxde:1 von 17 wird gelesen (3956 Oktetts) ... nicht geflusht
und warum bekommen die user die nur einen imap account haben keine mails empfangen, ich habe doch mit saslpasswd2 username und
passwörter vergeben sollte doch so funzen

Code: Alles auswählen

SMTP-Fehler: 450 <maria@localhost>: User unknown in local recipient table
wäre nett wenn du mich noch ein wenig unterstützt auf meinen weg zum eingenem mailserver ;)
schönen abend noch
linuxbaby
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Beitrag von basman »

Not flushed (fetchmail)
Nicht geflushed: kommt das von fetchmail? Dann fehlt eine entsprechende Option im fetchmail-Konfigfile oder Du hast eine zuviel drinnen. Siehe man fetchmail, Stichwort: --nokeep und --flush

Hinweis:Der man-Befehl verwendet intern den Befehl "less". Da dieser wiederum viele Kommandos vom Hacker-Editor vi unterstützt, kann man mit "/" in einer man-page nach Begriffen suchen.

Postfix weigert sich "user unknown"
Ich habe so ein Setup noch nie mit virtuellen Mailboxen betrieben (das heisst: der user "maria" existiert nicht in der /etc/passwd, ist also kein Systemuser).
Die Meldung leuchtet mir jedoch ein. Denn sasl und die Passwörter beeinflussen nur von wem postfix Mails zur Weiterleitung annimmt. Es hat jedoch keinerlei Bedeutung für die Zustellung von Mails an lokale User.

Zwei Lösungen erahne ich:
  1. Postfix dazu überreden, die virtuellen user anzuerkennen. Vielleicht ist die Datei /usr/share/doc/packages/postfix/samples/sample-smtpd.cf ein Hinweis. Stichwort: "REJECTING MAIL FOR UNKNOWN LOCAL USERS"
  2. Die Benutzer als System-user anlegen. Dann solltest Du imapd jedoch gleich so konfigurieren, dass er keine virtuellen Mailboxen nimmt, sondern die Systemuser-Homeverzeichnisse.
Dir auch einen schönen Abend.
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

punkt 1 ok rtfm ich weiß ;)
punkt 2 das wollte ich ja gerade nicht das die user einen
benutzeraccount auf der maschine haben...
für heute langt's mir, morgen geht's weiter :)
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

guten morgen
ich kann mittlerweile mails intern wie extern versenden, aber wenn ich
eine mail mit meiner "virtuellen" adresse extern versende
also z.B. gerd@victim.de dann kommt diese mail auch an.
wenn der empfänger jedoch auf "antworten" klickt, dann
verschwindet diese mail im nirvana. woran kann es liegen
an der canonical-table?

mfg
linuxbaby
Benutzeravatar
basman
Member
Member
Beiträge: 217
Registriert: 4. Jan 2004, 01:08

Beitrag von basman »

Irgendwelche Spuren in den Logfiles? /var/log/mail /var/log/messages
Benutzeravatar
linuxbaby
Newbie
Newbie
Beiträge: 47
Registriert: 13. Feb 2004, 13:03
Wohnort: /bin/bash

Beitrag von linuxbaby »

nein in den logs ist nichts zuerkennen die mail
wird ja ordnungsgemäß zugestellt...nur wenn
der empfänger auf antworten klickt verschwindet
die mail im nirvana, das wird wohl am relayhost
liegen der wohl keine weiterleitung unterstützt
bzw. sie nicht aktiviert ist....
Gesperrt