Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Erreiche Webmin / Apache übers Inet nicht

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
n00b
Newbie
Newbie
Beiträge: 13
Registriert: 27. Feb 2004, 18:54

Erreiche Webmin / Apache übers Inet nicht

Beitrag von n00b »

Hi,
habe da nen unschönes Problem mit meiner Firewall2 und zwar erreiche ich vom Internet aus keinen Dienst wie Apache / Webmin obwohl die Ports bei FW_SERVICES_EXT_TCP / UDP freigeschaltet sind, desweiteren kann ich meinen LinuxRouter noch nicht mal mehr vom Inet aus anpingen,
(über dyndnsnamen) hier mal meine /etc/rc.config.d/firewall2.rc.config :

FW_DEV_EXT="ppp0"
FW_DEV_INT="eth0"
FW_DEV_DMZ=""
FW_ROUTE="yes"
FW_MASQUERADE="yes"
FW_MASQ_DEV="$FW_DEV_EXT"
FW_MASQ_NETS=192.168.1.0/24"
FW_PROTECT_FROM_INTERNAL="no"
FW_AUTOPROTECT_SERVICES="yes"
FW_SERVICES_EXT_TCP=""
FW_SERVICES_EXT_UDP=""
FW_SERVICES_EXT_IP=""
FW_SERVICES_DMZ_TCP="80 10000"
FW_SERVICES_DMZ_UDP="80 10000"
FW_SERVICES_DMZ_IP=""
FW_SERVICES_INT_TCP="53"
FW_SERVICES_INT_UDP="53"
FW_SERVICES_INT_IP=""
FW_TRUSTED_NETS=""
FW_ALLOW_INCOMING_HIGHPORTS_TCP="yes"
FW_ALLOW_INCOMING_HIGHPORTS_UDP="dns"
FW_SERVICE_AUTODETECT="yes"
FW_SERVICE_DNS="no"
FW_SERVICE_DHCLIENT="no"
FW_SERVICE_DHCPD="no"
FW_SERVICE_SQUID="no"
FW_SERVICE_SAMBA="no"
FW_FORWARD=""
FW_FORWARD_MASQ=""
FW_REDIRECT=""
FW_LOG_DROP_CRIT="yes"
FW_LOG_DROP_ALL="no"
FW_LOG_ACCEPT_CRIT="yes"
FW_LOG_ACCEPT_ALL="no"
FW_KERNEL_SECURITY="yes"
FW_STOP_KEEP_ROUTING_STATE="yes"
FW_ALLOW_PING_FW="yes"
FW_ALLOW_PING_DMZ="no"
FW_ALLOW_PING_EXT="no"

# END of rc.firewall


# #
#-------------------------------------------------------------------------#
# #
# EXPERT OPTIONS - all others please don't change these! #
# #
#-------------------------------------------------------------------------#
# #
FW_ALLOW_FW_TRACEROUTE="yes"
FW_ALLOW_FW_SOURCEQUENCH="no"
FW_ALLOW_FW_BROADCAST="no"
FW_IGNORE_FW_BROADCAST="yes"
FW_ALLOW_CLASS_ROUTING="yes"

hoffe einer weiß woran das liegt :cry:
Benutzeravatar
Bomber8475
Member
Member
Beiträge: 119
Registriert: 25. Nov 2003, 00:32

Re: Erreiche Webmin / Apache übers Inet nicht

Beitrag von Bomber8475 »

n00b hat geschrieben:......FW_SERVICES_EXT_TCP / UDP.........

.
.
FW_SERVICES_EXT_TCP=""
FW_SERVICES_EXT_UDP=""
FW_SERVICES_DMZ_TCP="80 10000"
FW_SERVICES_DMZ_UDP="80 10000"
.
.
Du hast die in dmz_tcp freigegeben, nicht wie geschrieben in ext_tcp. Außerdem brauchst Du den Port 80 nicht als UDP.

Ich hab den http in ext_tcp frei und hab kein Problem darauf zu connecten, von außerhalb als auch von innerhalb des LANs über meinen DYNDNS Account. Damits von innerhalb klappt muß man noch ein iptables Befehl hinzufügen, natürlich den IP-Bereich anpassen:

Code: Alles auswählen

iptables -I INPUT 1 -s 192.168.0.0/24 -j ACCEPT


So geht hier alles wunderbar
Mein Fli4L-Router
irc.freenode.net ... /join #linux-club.de
using --> http://www.ubuntulinux.org/
Antworten