Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kleines WLAN - NG Tutorial Versuch 2 :)

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
helge000
Newbie
Newbie
Beiträge: 24
Registriert: 1. Mär 2004, 14:00
Wohnort: Leipzig

Kleines WLAN - NG Tutorial Versuch 2 :)

Beitrag von helge000 »

:oops: Leider hat es beim ersten Versch sicht so ganz mit dem HTML geklappt :) hier dann also die NUR TEXT Fassung. Bei Gelegenheit: Kann mir mal jemand erklähren, wie ich HTML Quelltext hier in diese Box bekomme ?? :?:

Hallo Zusammen,

ich dachte mir, DaBomb schon mal etwas vorzugreifen und mich mal selber an einem kleinen Tutorial für die wlan-ng Treiber zu versuchen. Erst einmal etwas Grundsätzliches:

Die Treiber gibt es als WLAN (bis 2Mbs) und WLAN NG (bis 11Mbs). Ich gehe hier nur auf die NG's ein, da ja keiner heutzutage noch ein 2Mbs - Netz aufbauen wird.Auch mir ist es nicht gelungen, WEP einzuschalten. Es gibt wohl Leute, die das geschafft haben, aber mir ist bis jetzt keiner bekannt :). Mein Router hat eine Zugriffsliste; die habe ich eingeschaltet. So ist zwar der Datenstrom an sich nicht verschlüsselt, doch es kann auch niemand andres auf meinen Router zugreifen. Ich gehe davon aus, dass ein vorhandenes WLAN unter Windows funktioniert. Es ist mir in diesem Rahmen nicht möglich, auch auf Hardware – Probleme einzugehen.
Ich beschreibe hier vor allem die Konfiguration meines Systems (USB Stick, DSL Router, Suse 9.0). Es sollte jedoch ananlog auf anderen Systemen genau so funktionieren.


VORAUSSETZUNGEN
1.Einen WLAN Adapter mit einem Intersil Prism2/2.5/3 Chipsatz !!! Man kann unter http://www.linux-wlan.org/docs/wlan_adapters.html.gz herausfinden, welcher Cipsatz auf der Karte verbaut ist. Wenn man keinen Prism Chipsatz hat, kann man hier gleich aufhören, weiterzulesen.
2.Funktionierendes Netzwerk unter Windows
3.Router (am besten noch unter Windows) so einstellen, dass WEP deaktiviert ist. Bitte der Einfachheit halber auch eine ESSID verwenden, die keine Leerzeichen enthält und kurz ist (z. B. „WLAN“).
4.Nun die neuesten WLAN – NG Treiber von ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/ runterladen. Aktuell sind dies die pre20 vom 20.02. Natürlich sollte man die an eine Stelle speichern, die auch unter Linux gemountet ist.
5.Jetzt dieses Turorial kopieren und als Test zu den NG – Treibern legen

INSTALLATION
1.Linux booten.
2.Als root anmelden.
3.Die Kernel – Sources mit YaST installieren, falls nicht schon geschehen.
4.Mit tar jxvf linux-wlan-ng-* das Paket entpacken.
5.In das neu erstellte Verzeichnis wechseln (im Fall von pre20 linux-wlan-ng-0.2.1-pre20 )
6.make config ausführen. Hier ist es wichtig, den richtigen Adapter auszuwählen. Alle anderen Fragen einfach mit 'Enter' beantworten.
7.make all eingeben und die Daumen drücken. Wenn es hier zu Fehlern kommt, kann ich leider nicht weiterhelfen!
8.make install . Geschafft! Die Treiber sind installert!

KONFIGURATION

Dies ist der Teil, der mich am längsten aufgehalten hat. Es gibt nämlich so einige Sachen zu beachten. Wenn hier mehr steht als wirklich notwendig ist, so ist es dem Umstand zuschulden, dass ich selbst sehr lange probieren musste, bis das ganze funktionert. Man muss so einige Dinge wissen:
Netzwerktyp (Verwaltet, AdHoc usw.)
- Router IP (die sollte man immer auswendig kennen)
- DHCP des Routers an oder aus
- DNS Server des Providers (bekommt man zum Beispiel in der Statusanzeige des Routers)

Die grundlegende Konfiguration könnte sehr einfach sein, nur leider unterstützt wlan-ng keine Konfiguration über iwconfig. So müssen dann ein paar Config – Dateien geändert werden.

1. In der Datei /etc/wlan/wlan.conf sollte folgender Test stehen:
SSID_wlan0="deineSSID"
ENABLE_wlan0=y

2. Die Datei /etc/wlan/wlancfg-DEFAULT zu wlancfg-deineSSID kopierten. Hier habe ich alle Einträge, die nur entfernt mit WEP etwas zu tun hatten, auf FALSE gesetzt (zB. „werdot11ExcludeUnencrypted=false“ ). Auserdem sollte hier der Netzwerktyp eingestellt werden. Bei mir – und bei den meisten Anderen - sollte das Infrastucture (zu deutsch auch „Verwaltet“) sein ( IS_ADHOC=n ). Wer noch ein bisschen mit WEP herumprobieren will, kann sich dieser Datei später zuwenden.

3. Nun YaST starten. Unter Yast2 Module / Netzwerkgeräte / Netzwerkkarte ist die richtige Netzwerkkarte einzustellen. Falls man ein USB oder PCMCIA Adapter besitzt, sollte das hier eingestellt werden. Unter Gerät steht dann „wlan-usb“ bzw. „wlan-pcmcia“ . So weiß der Kernel, dass er ein Hotplug – Interface ansprechen muss.

3. Bei Rechnername und Nameserver den Rechnernamen eintragen und GANZ WICHTIG unter Nameserver die DNS des Providers eintragen! Unter Windows konnte man dort die IP des Routers angeben. Das funktioniert unter Linux nicht.

4. Unter Routing die IP des Routers eintragen.

5. Unter Hardwaredetails / Einstellungen für Funkverbindungen nochmals deineESSID eintragen.

6. Beenden der Netzwerkkonfiguration

7a. In Yast2 Firewall unter YaSt2 Module / Sicherheit und Benutzer öffnen. Ich hatte das Problem, dass ich den Router und IP's im Internet zwar fleißig anpingen konnte, durch die fehlende Firewall allerdings kein Routing für Browser ect. Stattfand.

7b. Als externe Schnittstelle ppp0 einstellen. (Ich gehe mal davon aus, das im WLAN DSL verwendet wird). Als interne Schnittstelle wlan0 angeben. Alle anderen Optionen so lassen. YaST2 beenden.

8. NEUSTART

9. Beim booten F2 drücken, um die Ausgaben zu sehen.

Wenn alles klappt, sollte es ungefähr so aussehen:

Starting Firewall Initialization (phase 1 of 3) done
Setting up network interfaces:
lo done
wlan-usb hotplug
Starting hotplugging services [ ieee1394 net pci usb .............................................. ] done
Starting Firewall Initialization (phase 2 of 3) done
Starting Firewall Initialization (phase 3 of 3) done

Falls es zu Problemen kommt, steht unter der Initialisierung „wlan0 : no such a device“
Es empfiehlt sich dann, zunächt als su mit iwconfig nachzusehen, ob es wlan0 gibt (da stehen dann die Werte für Signalstärke und die MAC Adresse drin).
Wenn nicht, bitte mit lsmod nachshen, ob die wlan treiber geladen sind. Wenn nicht, bitte im README der NG Treiber nachlesen, wie sie zu laden sind.
Wenn alles geht, nur der Browser bei „Auflösen von hostname“ hängenbleibt und man sonst in die Konfiguration des Routers kommt bzw. man ihn anpingen kann, dann sind die DNS falsch angegeben. Bitte hier mal unter Punkt 7a / /b der Konfiguration nachsehen.


Also jetzt kann ich Euch nur noch viel Spaß bei bei der Installation Eurer wlan-ng Treiber wünschen!
Ich übernehme selbstverständlich keinerlei Gewähr für dieses Tutorial ! Falschaussagen sind nicht absichtlich und Berichtigungen bitte gleich hier posten!

Viele Grüße
tstrutz
Newbie
Newbie
Beiträge: 32
Registriert: 14. Mär 2004, 17:16

Beitrag von tstrutz »

Hallo,
ein paar kleine Anmerkungen.

WEP wird so wie im mitgelieferten Readme eingestellt. Oft ist es besser den Schlüssel direkt in die /etc/wlan/wlan-deineESSID einzutragen, und nicht jedesmal ausrechnen zu lassen. (kann viele Probleme beheben - siehe Google).

Voraussetzungen:
Prism2-Chipsatz reicht NICHT, passende Firmware ist wichtig. (Siehe viele Probleme mit DLink - die haben oft einen Prism2-Chipsatz, oder Teile davon, und können trotzdem nicht mit dem wlan-ng-Treiber).
> Funktionierendes Netzwerk unter Windows
wird natürlich nicht gebraucht, WEP ist als Standardeinstellung immer aus, usw.
INSTALLATION :
Allgemeine Empfehlung : NUR make install als root ausführen, den gesamten Teil davor als normaler user (nicht nur für diese Geschichte hier)

sonst ein feines Tutorial, ohne Yast geht es im übrigen schneller und macht mehr Spass :) und man lernt die Konsole kennen.

Grüße
Tobias
Benutzeravatar
helge000
Newbie
Newbie
Beiträge: 24
Registriert: 1. Mär 2004, 14:00
Wohnort: Leipzig

Beitrag von helge000 »

Ich habe in meinem Tutorial etwas vergessen:

MAN MUSS UNBEDINGT DIE KERNEL SOURCES INSTALLIEREN.

Am besten mit vom Kontrollzenrum aus, Yast2-Module, Software - Software inst. oder löschen.

Dann ber der Paketauswahl die Kernelquellen auswählen und installierten!
HaRTWIG

Beitrag von HaRTWIG »

Ich versteh das mit dem einstellen von AD-Hoc nicht.
Ich muss doch verwaltet dann anstellen, oder?
XontaX
Newbie
Newbie
Beiträge: 2
Registriert: 18. Sep 2004, 13:19
Kontaktdaten:

Beitrag von XontaX »

Also erstmal vielen dank für dieses feine Tutorial.
Bei mir hat alles funktioniert, bis es zum Neustart kam^^
Also erstmal:
Starting Firewall Initialization (phase 1 of 3) done
Setting up network interfaces:
lo done
wlan-usb hotplug
Starting hotplugging services [ ieee1394 net pci usb .............................................. ] done
Starting Firewall Initialization (phase 2 of 3) done <-- Bis hierhin hat alles Funktioniert
Warning: Wlan0 not activetet (yet?) 2x leicht unterschiedlicher Text aber beide male die Aussage das Wlan0 noch nicht Aktiviert ist.

Starting Firewall Initialization (phase 3 of 3) done


Wie Aktiviere ich Wlan0?

Gruß XontaX


/edit Apropos wo finde ich diese beidem: ifconfig & iwconfig, bei mir heißt es immer das er den Befehl nicht kennt? *Bekenne mich als absoluter Anfänger^^*
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4317
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Beitrag von framp »

XontaX hat geschrieben: Apropos wo finde ich diese beidem: ifconfig & iwconfig, bei mir heißt es immer das er den Befehl nicht kennt? *Bekenne mich als absoluter Anfänger^^*
Die sind nur verfuegbar wenn Du als root angemeldet bist. Also:

Code: Alles auswählen

su - 
{rootpw}
und dann ifconfig oder iwconfig eingeben
XontaX
Newbie
Newbie
Beiträge: 2
Registriert: 18. Sep 2004, 13:19
Kontaktdaten:

Beitrag von XontaX »

OKay ich glaub ich weiß solangsam woran es leigt.
IM /etc Ordner gibt es nicht wie angenommen einen Ordner der USB oder so heißt sondern nur einen der PCMIA heißt, sprich mein fehler liegt ganz am anfang bei der auswahl des richtigen Chipsatzes.
Dort steht ja nach jeder Auswahl [y]: bzw [n] ich habe mir gedacht das, dasss die Standarts sind und habe hinter die, die ich nicht installieren wollte ein N gesetzt und dann enter gedrückt und hinter den, den ich Installieren wollte ein Y. Ich schätze mal das ist falsch.
Was muß ich eingeben um zum Auswählen?

Gruß XontaX
TerryB
Newbie
Newbie
Beiträge: 3
Registriert: 11. Okt 2004, 19:46

Beitrag von TerryB »

Hi,

vielen Dank für dein tolles Tutorial. Ich kann inzwischen meinen Router anpingen. Nur kann ich bislang nur mit IP-Adressen arbeiten. DNS funktioniert noch nicht bei mir.
Dein folgendes Zitat trifft genau mein Problem.
Wenn alles geht, nur der Browser bei „Auflösen von hostname“ hängenbleibt und man sonst in die Konfiguration des Routers kommt bzw. man ihn anpingen kann, dann sind die DNS falsch angegeben. Bitte hier mal unter Punkt 7a / /b der Konfiguration nachsehen.
Jetzt eine blöde Frage. Ich habe die IP-Adresse des DNS-Servers meines Providers herausgefunden. Ich weiß aber nicht, was ich unter Domain in dem YaST-Bildschirm angeben soll. Irgendwie klappt es nicht.

Vielen Dank schonmal

TerryB
Wolfgang
Hacker
Hacker
Beiträge: 271
Registriert: 26. Mai 2004, 22:05
Wohnort: Köln
Kontaktdaten:

Beitrag von Wolfgang »

Wie wärs mit gar nix?
TerryB
Newbie
Newbie
Beiträge: 3
Registriert: 11. Okt 2004, 19:46

Beitrag von TerryB »

Hi, klappt leider nicht. Das Problem scheint aber doch tiefgreifender zu sein als nur DNS. Denn ich habe gerade mal probiert den DNS-Server mit seiner IP anzupingen. Und schon das scheitert.
Woran könnte das liegen?
Ich komme mit meinem Wireless USB Adapter zu meinem HW-Router. Aber zu diesem HW-Router eben nur mit IP.

Hoffentlich könnt ihr mir weiterhelfen.

Vielen Dank schonmal

TerryB
Wolfgang
Hacker
Hacker
Beiträge: 271
Registriert: 26. Mai 2004, 22:05
Wohnort: Köln
Kontaktdaten:

Beitrag von Wolfgang »

Ich komme (wie jeder andere auch) auch nur mit IP zu meinem Router.
Hast Du die IP des Routers als Gateway eingegeben?
TerryB
Newbie
Newbie
Beiträge: 3
Registriert: 11. Okt 2004, 19:46

Beitrag von TerryB »

Ja, ich denke schon.
Ich habe folgenden Befehl eingegeben:

Code: Alles auswählen

route add -net default gw 192.168.178.1
192.168.178.1 ist die Adresse meines HW-Routers.

Gruß

TerryB
stremppis
Newbie
Newbie
Beiträge: 1
Registriert: 6. Jan 2005, 20:58

Beitrag von stremppis »

Ich habe den ng-Treiber installiert wie beschrieben.
Musste noch im Verzeichnis /etc resolv.conf anlegen und editieren.
Beim Booten kommt jetzt die Nachricht nach, daß das wlan0 Interface noch nicht installiert sei.??
Ich kann den Router nicht anpingen.
Kann mir da irgendjemand weiterhelfen?
:x
Antworten