Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kleines Tutorial für WLAN-NG

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
helge000
Newbie
Newbie
Beiträge: 24
Registriert: 1. Mär 2004, 14:00
Wohnort: Leipzig

Beitrag von helge000 »

Hallo Zusammen,

ich dachte mir, DaBomb schon mal etwas vorzugreifen und mich mal selber an einem kleinen Tutorial für die wlan-ng Treiber zu versuchen. Erst einmal etwas Grundsätzliches:

Die Treiber gibt es als WLAN (bis 2Mbs) und WLAN NG (bis 11Mbs). Ich gehe hier nur auf die NG's ein, da ja keiner heutzutage noch ein 2Mbs - Netz aufbauen wird.Auch mir ist es nicht gelungen, WEP einzuschalten. Es gibt wohl Leute, die das geschafft haben, aber mir ist bis jetzt keiner bekannt :). Mein Router hat eine Zugriffsliste; die habe ich eingeschaltet. So ist zwar der Datenstrom an sich nicht verschlüsselt, doch es kann auch niemand andres auf meinen Router zugreifen. Ich gehe davon aus, dass ein vorhandenes WLAN unter Windows funktioniert. Es ist mir in diesem Rahmen nicht möglich, auch auf Hardware – Probleme einzugehen.
Ich beschreibe hier vor allem die Konfiguration meines Systems (USB Stick, DSL Router, Suse 9.0). Es sollte jedoch ananlog auf anderen Systemen genau so funktionieren.


VORAUSSETZUNGEN
1.Einen WLAN Adapter mit einem Intersil Prism2/2.5/3 Chipsatz !!! Man kann unter http://www.linux-wlan.org/docs/wlan_adapters.html.gz herausfinden, welcher Cipsatz auf der Karte verbaut ist. Wenn man keinen Prism Chipsatz hat, kann man hier gleich aufhören, weiterzulesen.
2.Funktionierendes Netzwerk unter Windows
3.Router (am besten noch unter Windows) so einstellen, dass WEP deaktiviert ist. Bitte der Einfachheit halber auch eine ESSID verwenden, die keine Leerzeichen enthält und kurz ist (z. B. „WLAN“).
4.Nun die neuesten WLAN – NG Treiber von ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/ runterladen. Aktuell sind dies die pre20 vom 20.02. Natürlich sollte man die an eine Stelle speichern, die auch unter Linux gemountet ist.
5.Jetzt dieses Turorial kopieren und als Test zu den NG – Treibern legen

INSTALLATION
1.Linux booten.
2.Als root anmelden.
3.Die Kernel – Sources mit YaST installieren, falls nicht schon geschehen.
4.Mit tar jxvf linux-wlan-ng-* das Paket entpacken.
5.In das neu erstellte Verzeichnis wechseln (im Fall von pre20 linux-wlan-ng-0.2.1-pre20 )
6.make config ausführen. Hier ist es wichtig, den richtigen Adapter auszuwählen. Alle anderen Fragen einfach mit 'Enter' beantworten.
7.make all eingeben und die Daumen drücken. Wenn es hier zu Fehlern kommt, kann ich leider nicht weiterhelfen!
8.make install . Geschafft! Die Treiber sind installert!

KONFIGURATION

Dies ist der Teil, der mich am längsten aufgehalten hat. Es gibt nämlich so einige Sachen zu beachten. Wenn hier mehr steht als wirklich notwendig ist, so ist es dem Umstand zuschulden, dass ich selbst sehr lange probieren musste, bis das ganze funktionert. Man muss so einige Dinge wissen:
Netzwerktyp (Verwaltet, AdHoc usw.)
- Router IP (die sollte man immer auswendig kennen)
- DHCP des Routers an oder aus
- DNS Server des Providers (bekommt man zum Beispiel in der Statusanzeige des Routers)

Die grundlegende Konfiguration könnte sehr einfach sein, nur leider unterstützt wlan-ng keine Konfiguration über iwconfig. So müssen dann ein paar Config – Dateien geändert werden.

1. In der Datei /etc/wlan/wlan.conf sollte folgender Test stehen:
SSID_wlan0="deineSSID"
ENABLE_wlan0=y

2. Die Datei /etc/wlan/wlancfg-DEFAULT zu wlancfg-deineSSID kopierten. Hier habe ich alle Einträge, die nur entfernt mit WEP etwas zu tun hatten, auf FALSE gesetzt (zB. „werdot11ExcludeUnencrypted=false“ ). Auserdem sollte hier der Netzwerktyp eingestellt werden. Bei mir – und bei den meisten Anderen - sollte das Infrastucture (zu deutsch auch „Verwaltet“) sein ( IS_ADHOC=n ). Wer noch ein bisschen mit WEP herumprobieren will, kann sich dieser Datei später zuwenden.

3. Nun YaST starten. Unter Yast2 Module / Netzwerkgeräte / Netzwerkkarte ist die richtige Netzwerkkarte einzustellen. Falls man ein USB oder PCMCIA Adapter besitzt, sollte das hier eingestellt werden. Unter Gerät steht dann „wlan-usb“ bzw. „wlan-pcmcia“ . So weiß der Kernel, dass er ein Hotplug – Interface ansprechen muss.

3. Bei Rechnername und Nameserver den Rechnernamen eintragen und GANZ WICHTIG unter Nameserver die DNS des Providers eintragen! Unter Windows konnte man dort die IP des Routers angeben. Das funktioniert unter Linux nicht.

4. Unter Routing die IP des Routers eintragen.

5. Unter Hardwaredetails / Einstellungen für Funkverbindungen nochmals deineESSID eintragen.

6. Beenden der Netzwerkkonfiguration

7a. In Yast2 Firewall unter YaSt2 Module / Sicherheit und Benutzer öffnen. Ich hatte das Problem, dass ich den Router und IP's im Internet zwar fleißig anpingen konnte, durch die fehlende Firewall allerdings kein Routing für Browser ect. Stattfand.

7b. Als externe Schnittstelle ppp0 einstellen. (Ich gehe mal davon aus, das im WLAN DSL verwendet wird). Als interne Schnittstelle wlan0 angeben. Alle anderen Optionen so lassen. YaST2 beenden.

8. NEUSTART

9. Beim booten F2 drücken, um die Ausgaben zu sehen.

Wenn alles klappt, sollte es ungefähr so aussehen:

Starting Firewall Initialization (phase 1 of 3) done
Setting up network interfaces:
lo done
wlan-usb hotplug
Starting hotplugging services [ ieee1394 net pci usb .............................................. ] done
Starting Firewall Initialization (phase 2 of 3) done
Starting Firewall Initialization (phase 3 of 3) done

Falls es zu Problemen kommt, steht unter der Initialisierung „wlan0 : no such a device“
Es empfiehlt sich dann, zunächt als su mit iwconfig nachzusehen, ob es wlan0 gibt (da stehen dann die Werte für Signalstärke und die MAC Adresse drin).
Wenn nicht, bitte mit lsmod nachshen, ob die wlan treiber geladen sind. Wenn nicht, bitte im README der NG Treiber nachlesen, wie sie zu laden sind.
Wenn alles geht, nur der Browser bei „Auflösen von hostname“ hängenbleibt und man sonst in die Konfiguration des Routers kommt bzw. man ihn anpingen kann, dann sind die DNS falsch angegeben. Bitte hier mal unter Punkt 7a / 7b der Konfiguration nachsehen.


Also jetzt kann ich Euch nur noch viel Spaß bei bei der Installation Eurer wlan-ng Treiber wünschen!
Ich übernehme selbstverständlich keinerlei Gewähr für dieses Tutorial ! Falschaussagen sind nicht absichtlich und Berichtigungen bitte gleich hier posten!

Viele Grüße
Spacy73

WEP einschalten

Beitrag von Spacy73 »

hallo allerseits,

wollte nur mal eben (m)eine möglichkeit posten, wie das mit wep funktioniert.
da ich grundsätzlich nie YaST, DrakeConfig o.ä. verwende, und sämtliche
Auto-Configs wie hotplug oder resmgr abgeschalten habe, ist eine
direkte verwendung von newbies so nicht möglich und sinnvoll.
ach-ja die wep108 ist mal eben frei geändert, die ip's sind noch einzusetzten
und das skript geht hier von einem usb-stick aus.

1. ergänzen von /etc/init.d/boot.local (als root):

# wlan
modprobe prism2_usb prism2_doreset=0
wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
sleep 2
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11PrivacyInvoked=true
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKeyID=0
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKey0=01:02:03:04:05:06:07:08:09:0a:0b:0c:0d 1> /dev/null
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11ExcludeUnencrypted=true
wlanctl-ng wlan0 lnxreq_autojoin ssid=die-SSID authtype=sharedkey
ifconfig wlan0 die-lokale-ip
route add default gw die-router-ip
sleep 2
wlanctl-ng wlan0 lnxreq_commsquality

2. ergänzen vo /etc/resolv.conf (als root):

nameserver provider-ns-ip
Benutzeravatar
nbkr
Guru
Guru
Beiträge: 2857
Registriert: 10. Jul 2004, 15:47

Beitrag von nbkr »

Hallo,

vielen Dank euch beiden für diese Anleitung. Endlich geht mein Desktoprechner mit Debian Sarge auch über WLAN (inklusive WEP) ins Netz.

Eine Frage hätte ich da aber noch. Wie kann ich die einmal aktivierte WLAN Karte wieder abschalten? Ein

Code: Alles auswählen

ifdown wlan0
bringt nur die Fehlermeldung:

Code: Alles auswählen

interface wlan0 not configured
mit "ifconfig" bekomme ich wlan0 jedoch angezeigt und die Verbindung klappt auch einwandfrei. Bei der Installation habe ich das Netzwerk unkonfiguriert gelassen, weil ich die WLan Karte ja dort noch nicht einrichten konnte und ich die eingebaute Netzwerkkarte nicht brauchte. Könnte es evtl. daran liegen und wenn ja wie löse ich das Problem?

Bin dankbar für jeden Vorschlag.
Kann gar nicht sein, ich bin gefürchtet Wald aus, Wald ein.
Antworten