Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Directory Index beim Apache

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
apietsch
Newbie
Newbie
Beiträge: 5
Registriert: 8. Mär 2004, 21:58

[gelöst] Directory Index beim Apache

Beitrag von apietsch »

Hallo,
ich habe da mal ne Frage, vielleicht kann mir ja jemand helfen.

Ich möchte gerne auf dem apache Webserver das indexieren der Verzeichnisse sperren.
Wenn also jemand auf "www.beispiel.de/verzeichnis" geht, soll er nicht den Inhalt aufgelistet bekommen.
Aber geht er auf "www.beispiel.de/test" soll dort ein index der enthaltenen Dateien angezeigt werden.

Habe schon versucht mit einer .htaccess zu arbeiten. Greift aber irgendwie nicht ( AllowOverride Options habe ich beachtet )

Also, für Hilfe und Tips bin ich sehr dankbar.
Viele Grüße
Alexander
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Wo hast du AllOverride ALL angegeben?

Sollte in der httpd.conf im <Directory DocumentRoot> o. <Location /> stehen und nicht in .htaccess

Dann Kannst du in jedem Verzeichnis in der .htaccess Options [+-]Indexes setzen

Achtung: kann auch sein, dass AccessFileName gesetzt ist. Dies weist Apache an eine andere Datei als .htaccess zu verwenden
apietsch
Newbie
Newbie
Beiträge: 5
Registriert: 8. Mär 2004, 21:58

Beitrag von apietsch »

Hallo,
danke für die schnelle Antwort.
also ich heb in der httpd.conf eingetragen
<Directory />
Options FollowSymLinks
AllowOverride Options
# AllowOverride None
</Directory>


AccessFileName .htaccess

Und in der .htaccess steht :
Options +Indexes +MultiViews

Wie stell ich denn das Indexing generell ab?

Gruß
Alex
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Mit
<Directory />
Options FollowSymLinks -Indexes
AllowOverride Options
# AllowOverride None
</Directory>
Gast

Beitrag von Gast »

aahhh .. danke .. funktioniert :-)
Antworten