Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] DVD unter Linux

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
caesar
Newbie
Newbie
Beiträge: 1
Registriert: 24. Feb 2004, 15:23

[solved] DVD unter Linux

Beitrag von caesar »

Hallo,

ich nutze seit einiger Zeit SuSE Linux. Nun möchte ich natürlich auch meine DVDs weiter anschauen können. Dazu fehlt mir aber das nötige "xine" Codec. Wo kann ich das am Besten runterladen? Bisher war ich nämlich ziemlich erfolglos!

Vielen Dank im Vorraus...
ICQ: 109386217
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

hi! schau mal unter:
http://packman.links2linux.de/?action=124

da braust du:
libxine
libxine-dvd
..und die pakete, die unten aufgeführt sind

dazu kaffeine (is bei suse dabei..)
:wink:
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

Ich kann zwar mittlerweile DVDs mit Xine (kaffeine) abspielen, allerdings läuft das extremst stockend - ist daher so gut wie gar nicht brauchbar.

Läßt sich das irgendwie beheben? Wenn ja, wie?
Snubnose
Hacker
Hacker
Beiträge: 410
Registriert: 18. Feb 2004, 19:19
Wohnort: Schwabenland

Beitrag von Snubnose »

was für nen Rechner / Graka hast du ?
hast du alles von Packman installiert ?
ich mag kaffeine nicht - ich nehm immer xine-ui - aber eigentlich sollte das keinen Unterschied machen ?
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

Snubnose hat geschrieben:was für nen Rechner / Graka hast du ?
1.4 GHz Pentium, Nvidia GForce2
hast du alles von Packman installiert ?
Mit Ausnahme der libdvdcss natürlich.
ich mag kaffeine nicht - ich nehm immer xine-ui
Ich konnte xine-ui nicht installieren. Es fehlte ein Paket (libslang-utf8.so.1).
aber eigentlich sollte das keinen Unterschied machen ?
Eigentlich nicht, da das ja nur grafische Frontends für Xine sind. Alle anderen Videoformate laufen zudem einwandfrei.
Gast

Beitrag von Gast »

mach mal in der konsole:

Code: Alles auswählen

xine-check
ich schätz du hast DMA nicht aktiviert:

Code: Alles auswählen

hdparm -d 1 /dev/hdc
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

m-pax hat geschrieben:mach mal in der konsole:

Code: Alles auswählen

xine-check
Den Befehl kennt er nicht...
ich schätz du hast DMA nicht aktiviert:

Code: Alles auswählen

hdparm -d 1 /dev/hdc
Das bewirkt zumindest keine Veränderung. DVD läuft, aber stockt alle paar Sekunden.
Gast

Beitrag von Gast »

Hallo!

DMA kann man auch per Yast ganz einfach aktivieren!
Im Yast unter Hardware das "Feld" IDE DMA Modus anklicken und beim DVD-Laufwerk DMA Modus an (standard) einstellen, dann sollten die DVDs auch laufen!(Jedoch wird Yast wahrscheinlich auch nix anderes machen als der Konsolenbefehl aber nen Verusch ists Wert :) )

Gruss
Stefan
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

Moin Stefan!

Na, glaubt man's? Das funktioniert! :-) Danke!

Tim
PS. Die Frage ist, warum der Konsolenbefehl das nicht geschafft hat... aber ich vermute mal ganz stark, daß ich schlichtweg den falschen Pfad zum DVD-Laufwerk angegeben hatte...
Zuletzt geändert von Timemaster am 8. Mai 2004, 22:32, insgesamt 1-mal geändert.
Benutzeravatar
spunti
Hacker
Hacker
Beiträge: 598
Registriert: 6. Mai 2004, 10:49

k(r)ampf

Beitrag von spunti »

Man, ich bin vielleicht gefrustet. Hab jetzt einen stundenlangen Download- und Installationsmarathon hinter mir und es funktioniert trotzdem nicht.
Eigentlich hatte ich mir ja den "vollständigen" Mplayer und den "vollständigen" Xine für Suse9.0 gesichert, aber das Zeug läßt sich jetzt beides nicht mehr unter Suse9.1 installieren. Es werden Abhängigkeiten angezeigt, die er nicht auflösen kann und bei rpm-seek sind die Dinger auch nicht in der Version dabei. Ich glaube, alles, was der sucht, ist bei Suse9.1 nur in einer neueren Version dabei, aber das scheint die Abhängigkeiten nicht zu beeindrucken.

Also hab ich mir den ganzen Xine-Kram runtergeladen und mit meinem alten DeCSS erfolgreich installiert, aber ich kann xine nicht starten. Also "xine" als Befehl kennt der nicht und das Kaffeine meckert immer noch rum von wegen DVD geht nicht wegen fehlendem Codec.

Jetzt werde ich einen Tag (morgen?) noch mal von vorn probieren und wie hier woanders steht, erst das xine und das kaffeine löschen, dann noch mal meinen kram rauf und das kaffeine von suse rauf, aber ich hasse mich jetzt schon dafür, daß ich das morgen noch mal probiere. denn innerlich weiß ich, daß es wieder nichts wird. es ist so sehr nervenaufreibend, daß man sich insgeheim wünscht, nie linux entdeckt zu haben. dann würde man sich in ruhe eine strategie gegen die ganzen viren einfallen lassen und hätte sonst keine probleme. linux ist ein k(r)ampf!
Snubnose
Hacker
Hacker
Beiträge: 410
Registriert: 18. Feb 2004, 19:19
Wohnort: Schwabenland

Beitrag von Snubnose »

wegen der xine-ui...
wenn du suse 9.1 hast misst du slang per yast installieren
wenn nicht:
pass bei packman auf dass du die Pakete für suse 9.0 und nicht für 9.1 runterlädst
Klaus99

Mplayer

Beitrag von Klaus99 »

Wer SuSE 9.1 hat und einfach nur seine DVD's angucken will, der kann sich einfach den MPlayer von hier herunterladen:
http://mitglied.lycos.de/ronnypriv/

Klaus
Antworten