Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

5.1 Sound geht, nur nicht bei Playern.

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
me-SuSE
Newbie
Newbie
Beiträge: 11
Registriert: 21. Jan 2005, 15:29

5.1 Sound geht, nur nicht bei Playern.

Beitrag von me-SuSE »

Guten Abend,

Mein Problem ist folgendes:

Ich habe die Soundkarte Terratec 5.1 Fun mit dem cmipci Chipsatz. Bei jedem erdenklichen Player bekomme ich nur 4.0 Sound hin. Hab schon gezweifelt ob die Karte überhaupt hier auf Linux geht soweit...
Naja weiter gehts:

speaker-test -Dplug:surround51 -c6

Als ich das eingab, bemerkte ich, dass ALLE speaker gehen, auch center und bass, ohne probleme.

meine frage, wie zwinge oder von mir aus auch vergewaltige ich XMMS dazu, auch den center und bass beim mp3 genuss zu benutzen um meine ohren wieder zu schonen?

Meine Daten:

cmipci Chipsatz
SuSE 9.3 Pro
Neuste alsa devs
Neuster XMMS

Eigentlich ist mein System via apt-get immer auf dem neusten Stand :)
me-SuSE
Newbie
Newbie
Beiträge: 11
Registriert: 21. Jan 2005, 15:29

Beitrag von me-SuSE »

Also es ist noch dazu zu sagen, dass es ja bei manchen Soundkarten unter Windows auch das Problem gibt, aber da kann man dann im Treiber (Creative) einstellen, dass CMMS 3D aktiviert wird, damit der STereo Sound auf alle Boxen verteilt wird, allerdings finde ich eine solche option nicht und Google hat mich ins Nirvana geschickt mit CMMS unter Linux.
Benutzeravatar
stulle
Hacker
Hacker
Beiträge: 284
Registriert: 23. Mai 2005, 22:49
Wohnort: Hildesheim

Beitrag von stulle »

Du schreibst das es funktioniert, nur bei Musik-Playern nicht.
Bei welchen Programmen geht es denn?
Und was für Musikprogramme nutzt du ausser Xmms?
me-SuSE
Newbie
Newbie
Beiträge: 11
Registriert: 21. Jan 2005, 15:29

Beitrag von me-SuSE »

also bei diesem test funktioniert ist, bei dem lautsprechertest. ansonsten ob spiele player oder sonstwas, es geht nicht
Benutzeravatar
stulle
Hacker
Hacker
Beiträge: 284
Registriert: 23. Mai 2005, 22:49
Wohnort: Hildesheim

Beitrag von stulle »

Wie bitte?
Schreib deutsch man!
casper100
Newbie
Newbie
Beiträge: 1
Registriert: 23. Okt 2005, 21:05
Kontaktdaten:

Beitrag von casper100 »

Moin !

zuerst mal ein - Hallo - an den ganzen linux-club ! Bild

Hab heute von SuSE 9.3 auf 10.0 upgedatet, und wieder hab ich das Problem das ich bei MP3s keine LFE ( Subwoofer ) Ausgabe habe.

Unter SuSE 9.3 hab das mit folgender asound.conf gelöst, bei 10.0 funktioniert das aber nicht.

Code: Alles auswählen

pcm.ch51dup {
type route
slave.pcm surround51
slave.channels 6
ttable.0.0 1
ttable.1.1 1
ttable.0.2 1
ttable.1.3 1
ttable.0.4 0.5
ttable.1.4 0.5
ttable.0.5 0.5
ttable.1.5 0.5
}

pcm.!default
{
type plug
slave.pcm ch51dup
Die Nvidia-Treiber wollte ich auch schon install., da bekomme ich aber nur eine Fehlermeldung.


Code: Alles auswählen

nforce-installer log file '/var/log/nvidia-nforce-installer.log'
creation time: Sun Oct 23 20:12:41 2005

option status:
  license pre-accepted      : false
  expert                    : false
  uninstall                 : false
  driver info               : false
  no precompiled interface  : false
  no ncurses color          : false
  no questions              : false
  silent                    : false
  Installer install prefix  : /usr
  kernel source path        : (not specified)
  net kernel install path   : (not specified)
  audio kernel install path : (not specified)
  proc mount point          : /proc
  ui                        : (not specified)
  tmpdir                    : /tmp

Using: nvidia-installer ncurses user interface
-> Found package NVIDIA audio driver for Linux-x86
-> Found package NVIDIA network driver for Linux-x86
-> Please select packages for installation:
   Selections:
   NVIDIA audio driver for Linux-x86 (1.0-6)
   NVIDIA network driver for Linux-x86 (1.0-12)
-> Starting install of NVIDIA audio driver for Linux-x86
-> Checking for loaded module nvsound
-> Checking for loaded module nvaudio
-> License accepted.
-> Skipping check for conflicting rpms.
-> /proc/version is Linux version 2.6.13-15-default (geeko@buildhost) (gcc
   version 4.0.2 20050901 (prerelease) (SUSE Linux)) #1 Tue Sep 13 14:56:15 UTC
   2005
-> No precompiled kernel interface was found to match your kernel; this means
   that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.6.13-15-default/source'
-> Kernel output path: '/lib/modules/2.6.13-15-default/build'
-> Performing cc_version_check with CC="cc".
-> gcc-version-check failed:
   
   ./nvsound/main/conftest.sh: line 9: cc: command not found
   Could not compile gcc-version-check.c
   
   If you know what you are doing and want to ignore the gcc version check, sel
   ect "No" to continue installation.  Otherwise, select "Yes" to abort install
   ation, set the CC environment variable to the name of the compiler used to c
   ompile your kernel, and restart installation.  Abort now? (Answer: Yes)
ERROR: Installation of the audio driver has failed.  Please see the file
       '/var/log/nvidia-nforce-installer.log' for details.  You may find
       suggestions on  fixing installation problems in the README available on
       the Linux driver download page at www.nvidia.com.
-> Starting install of NVIDIA network driver for Linux-x86
-> Checking for loaded module nvnet
-> Checking for loaded module forcedeth
-> Trying to remove loaded module forcedeth
-> License accepted.
-> Skipping check for conflicting rpms.
-> /proc/version is Linux version 2.6.13-15-default (geeko@buildhost) (gcc
   version 4.0.2 20050901 (prerelease) (SUSE Linux)) #1 Tue Sep 13 14:56:15 UTC
   2005
-> No precompiled kernel interface was found to match your kernel; this means
   that the installer will need to compile a new kernel interface.
-> Using the kernel source path '/lib/modules/2.6.13-15-default/source' as
   specified by the '--kernel-source-path' commandline option.
-> Kernel source path: '/lib/modules/2.6.13-15-default/source'
-> Using the kernel output path '/lib/modules/2.6.13-15-default/build' as
   specified by the '--kernel-output-path' commandline option.
-> Kernel output path: '/lib/modules/2.6.13-15-default/build'
-> Performing cc_version_check with CC="cc".
-> gcc-version-check failed:
   
   ./nvnet/conftest.sh: line 9: cc: command not found
   Could not compile gcc-version-check.c
   
   If you know what you are doing and want to ignore the gcc version check, sel
   ect "No" to continue installation.  Otherwise, select "Yes" to abort install
   ation, set the CC environment variable to the name of the compiler used to c
   ompile your kernel, and restart installation.  Abort now? (Answer: Yes)
Och männe, ich will doch nur wieder ordentlichen Klang haben !

Achso, hier noch meine Hardware :

Code: Alles auswählen

##########################
#Kernelrelease+Distributionsinformation#
##########################
Linux linux 2.6.13-15-default #1 Tue Sep 13 14:56:15 UTC 2005 i686 athlon i386 GNU/Linux
#######################
#Liste der geladenen Kernelmodule#
#######################
Module                  Size  Used by
pppoe                  13760  2 
pppox                   3336  1 pppoe
ppp_generic            28052  6 pppoe,pppox
slhc                    7296  1 ppp_generic
ipt_pkttype             1664  1 
ipt_LOG                 6912  7 
ipt_limit               2304  7 
nvidia               3695884  12 
speedstep_lib           4228  0 
freq_table              4612  0 
nfsd                  223072  5 
exportfs                5632  1 nfsd
snd_pcm_oss            59168  0 
snd_mixer_oss          18944  1 snd_pcm_oss
snd_seq                51984  0 
snd_seq_device          8588  1 snd_seq
button                  7056  0 
battery                10244  0 
ac                      5252  0 
sg                     35744  0 
sd_mod                 18576  0 
ip6t_REJECT             5504  3 
ipt_REJECT              5632  3 
ipt_state               1920  12 
iptable_mangle          2688  0 
iptable_nat            22228  0 
iptable_filter          2816  1 
af_packet              21384  4 
ip6table_mangle         2304  0 
edd                     9824  0 
ip_conntrack           42168  2 ipt_state,iptable_nat
ip_tables              19456  8 ipt_pkttype,ipt_LOG,ipt_limit,ipt_REJECT,ipt_state,iptable_mangle,iptable_nat,iptable_filter
ip6table_filter         2688  1 
ip6_tables             18176  3 ip6t_REJECT,ip6table_mangle,ip6table_filter
ipv6                  242752  11 ip6t_REJECT
usbhid                 43616  0 
usb_storage            72512  0 
generic                 4484  0 [permanent]
tda9887                13072  0 
tuner                  35112  0 
via_rhine              22276  0 
mii                     5504  1 via_rhine
sata_nv                 9348  0 
libata                 48516  1 sata_nv
scsi_mod              131304  4 sg,sd_mod,usb_storage,libata
saa7134               109908  0 
video_buf              20868  1 saa7134
v4l2_common             5760  1 saa7134
v4l1_compat            13060  1 saa7134
ir_common               8196  1 saa7134
videodev                9088  1 saa7134
ohci1394               32820  0 
ieee1394               97208  1 ohci1394
ehci_hcd               32136  0 
shpchp                 88676  0 
pci_hotplug            26164  1 shpchp
ohci_hcd               20228  0 
usbcore               112640  5 usbhid,usb_storage,ehci_hcd,ohci_hcd
forcedeth              17920  0 
nvidia_agp              7580  1 
agpgart                33096  2 nvidia,nvidia_agp
i2c_nforce2             6784  0 
i2c_core               20368  4 tda9887,tuner,saa7134,i2c_nforce2
parport_pc             38980  1 
lp                     11460  0 
parport                33864  2 parport_pc,lp
snd_dummy               9152  1 
snd_intel8x0           33408  2 
snd_ac97_codec         90876  1 snd_intel8x0
snd_ac97_bus            2432  1 snd_ac97_codec
snd_pcm                93064  4 snd_pcm_oss,snd_dummy,snd_intel8x0,snd_ac97_codec
snd_timer              24452  2 snd_seq,snd_pcm
snd                    60420  15 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_dummy,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore               9184  2 saa7134,snd
snd_page_alloc         10632  2 snd_intel8x0,snd_pcm
nls_cp437               5760  1 
vfat                   12800  1 
fat                    49692  1 vfat
nls_utf8                2048  5 
ntfs                  182288  4 
dm_mod                 54972  0 
reiserfs              250480  1 
ide_cd                 39684  0 
cdrom                  36896  1 ide_cd
fan                     4996  0 
thermal                14472  0 
processor              24252  1 thermal
amd74xx                13980  0 [permanent]
ide_disk               17152  9 
ide_core              122380  5 usb_storage,generic,ide_cd,amd74xx,ide_disk
#################
#ALSA-Releaseinformation#
#################
alsa-1.0.9-23
######################
#Artsd geladen und laufend?        #
'Wenn nein, dann steht hier nichts.#
######################
######################
#ESD geladen und laufend?          #
'Wenn nein, dann steht hier nichts.#
######################
 7882 pts/1    R+     0:00 grep esd
######
#Fertig!#
######
Vllt. hat ja jemand eine Idee.

Danke schonmal !
Antworten