Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Groupware Installation

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
DJ
Newbie
Newbie
Beiträge: 2
Registriert: 2. Sep 2003, 21:42

Groupware Installation

Beitrag von DJ »

Groupware Installation

Installation einer Groupware Software auf einen Linux Suse 8.2 Pro. Betriebssystem
Als Basis für die Groupware Installation kann auf jeden fall eine LAMP Installation erfolgen.
Das heißt man installiert (L) Linux, (A) Apache, (M) MySql und (P) PHP wie das funktioniert haben schon etliche User im Net beschrieben z.B. hier
http://www.ibiblio.org/mdw/linuxfocus/D ... e270.shtml
Wenn man Outlook verwenden möchte sollte man auf der Windowseite den MySql ODBC-Treiber installieren.

Hat man erst einmal LAMP installiert ist es bist zur Groupware nicht mehr weit
Hier stehlt sich nur noch die frage was gibt es den so an OpenSource, schauen wir mal.
Da haben wir OpenGroupware von Skyrix und Kroupware von Kolab und PHProjekt
Super ich habe meine Wahl getroffen und lade mir OpenGroupware aus den Netz


OpenGroupware Installation:

Ok, LAMP funktioniert. So suchen wir ein HowTo ah ja hier haben wir unter
http://www.thievingmagpie.de/ogosuse82.html.
So jetzt habe ich lt. Anleitung alles Installiert und es funktioniert nicht.
Nach langer suche stelle ich fest das ich unbedingt eine Suse 8.2 Version
brauche und ich habe hier noch Suse 8.1 installiert.

TIP: Im PC-Welt-Heft für diesen Monat ist die Suse 8.2 Version auf CD enthalten.

Nachdem ich dann LAMP auf der Basis von Suse 8.2 Installiert hatte, konnte
ich die Groupware starten. Schnell den Browser aufrufen und „http://localhost/OpenGroupware/“ eingegeben wie Sie sehen Sehen sich nichts.
Außer eine Fehlermeldung das die Verbindung zum Localhost unterbrochen wurde.
Das war ein Ding, nachdem musste ich richtig lange suchen. Bis ich meine Fehler,
b.z.w. Verständnis Probleme meinerseits, beseitigen konnte.
Im Installation Script auf der Seite 8 unter Punkt 3. habe ich folgendes eingegeben

„OGO_ARGS=“-WOPort 20000 –WOHttpAllowHost localhost.localdomain – OGOMinimumActiveSessionCount 0“

ich habe einfach an der stelle locahost.localdomain meine hostname.Domain eingetragen
das sah dann so aus.

„OGO_ARGS=“-WOPort 20000 –WOHttpAllowHost linux.local– OGOMinimumActiveSessionCount 0“

so läuft das nicht! das ganze sollte so aussehen.

„OGO_ARGS=“-WOPort 20000 –WOHttpAllowHost localhost linux.local – OGOMinimumActiveSessionCount 0“

Ja man hat es nicht immer leicht :-)

Jetzt funktioniert das ganze auch einwandfrei.
Auch der Zugriff aus der Windowswelt war ohne Probleme möglich.

Jetzt noch schnell schauen wie funktioniert die Syncronisation zu Outlook?
Hier gibt es ein Tool ZideStore was leider nicht OpenSource ist. L
Hm das habe ich aber anders verstanden lt. Div. Berichte die ich gelesen habe.
Na ja was sollst ich habe ja noch zwei weiter Softwareprodukte zur Auswahl


Kroupware (Kolab):

Kolab sieht interessant aus konnte aber nicht feststellen wie das mit der Outlook
Sync. Laufen soll.
So wo saugt man sich die Software am besten hier http://www.kroupware.org/
Habe mir dann das Installation HowTo besorgt und konnte irgendwie keinen Anfang finden. Das war wohl nichts.


Phprojekt:

So die letzte Möglichkeit?
Schaun wir uns mal die Seite an http://www.phprojekt.de/
Hier bekommt man alle Infos die man braucht kann sich die Dokumentation, Software und
Addons saugen super.
Die Software entpackt und in das „Apache2 - Dokumentenverzeichnis“ unter ein neu erstelltes Verzeichnis mit den Namen „phprojekt“ abgelegt.
Jetzt noch die volle Berechtigung für das Verzeichnis einstellen und den Browser
öffnen folgende Zeile eingeben „http://localhost/phprojekt/env_test.php“ jau das
Läuft, das ist jetzt erstmal der test. den sollte man auf jedenfall durchführen.
Wenn alle Testpunkt funktioniert kann das Phprokekt Installiert werden mit „http://localhost/phprojekt/setup.sh „ jetzt nur noch den Anweisung folgen und fertig.

Das lobe ich mir als verwöhnter Windows User eine Installation die relativ
einfach und unkompliziert war.

So mal schauen was macht das Outlook sycn. Programm installiert und ...
Supi ich kann die Daten zwischen Outlook und Phprojekt sync.

So das war es erst einmal :roll:

Gruß DJ
Gast

Beitrag von Gast »

Hallo,

ich habe auf meinem SuSE 8.2 (SuSE Standard-Kernel 2.4.20-4GB) OGo nach dem hervorragenden Instal-HowTo von Till Klosheim installiert. Während der Installation lief auch alles Klasse. Dann will ich http://localhost:20000/OpenGroupware aufrufen und erhalte einen OGo Fehlerbilschirm mit folgender Fehlermeldung:

The SKYRIX application server could not connect to the database server!

Please ensure that your database server is running and that the LSConnectionDictionary default is correctly set.

Current database configuration:
database: ogo
server: 127.0.0.1
user: ogo

in der /var/log/ogo.log kommt folgende Meldung:

Oct 17 09:28:30 OpenGroupware [3561]: OGoContextManager: couldn't open adaptor channel

Kennt das jemand und weiss abhilfe??

Gruss Sven
pieradn.Hero
Newbie
Newbie
Beiträge: 2
Registriert: 23. Okt 2003, 09:19

Beitrag von pieradn.Hero »

Habe ganz genau das gleiche Problem wie #2. Weis denn keiner die Lösung?
julian

Zum Fehler: OGoContextManager: couldn't open adaptor channel

Beitrag von julian »

OGoContextManager: couldn't open adaptor channel

Abhilfe, betrifft SuSE 9.0 Pro:

A: The Packages are built on a PostgreSQL 7.2 system. Symlink libpq.so.3 to libpq.so.2:

su -
cd /usr/lib/
ln -s libpq.so.3 libpq.so.2

It is recommended to run:
ldconfig
Aldo

Please ensure that your database server is running and that

Beitrag von Aldo »

Hallo Sven,
Anonymous hat geschrieben:Hallo,

ich habe auf meinem SuSE 8.2 (SuSE Standard-Kernel 2.4.20-4GB) OGo nach dem hervorragenden Instal-HowTo von Till Klosheim installiert. Während der Installation lief auch alles Klasse. Dann will ich http://localhost:20000/OpenGroupware aufrufen und erhalte einen OGo Fehlerbilschirm mit folgender Fehlermeldung:

The SKYRIX application server could not connect to the database server!

Please ensure that your database server is running and that the LSConnectionDictionary default is correctly set.

Gruss Sven
Dasselbe Problem hatte ich auch. Die Ursache war, dass ich im postgresql.conf die Zeile

#tcpip_socket = false

nur auskommentiert hatte. Richtig muss es aber dort

tcpip_socket = true

heissen. War schon spät als ich schnell mal......

Cheers,
Aldo.
marolu

lösung?

Beitrag von marolu »

ich habe das gleiche problem mit suse8.2 gehabt:
nach der installation und dem ersten aufruf der seite kommt eine fehlermeldung, die besagt, dass keine verbindung zur datenbank hergestellt werden kann.
ich habe dann mit tail -f /var/log/ogo.log auf der konsole und dem restart von opengroupware mit dem init-script in /etc/init.d eine fehlermeldung erhalten, die besagte, dass der OGoContextManager irgendein problem hat. also habe ich in der Datei /opt/opengroupware.org/.libFoundation/Defaults/NSGLobalDomain.plist verschiedene Werte ausprobiert (immer mit auge auf die ogo.log) und habe nach einigen versuchen die werte aus der installationsanleitung von thievingmagpie.de wieder eingesetzt und es ging!
der genannte link auf libpq.so.2/3 war vorher gesetzt - also keine abhilfe und das der tcpip_socket auskommentiert und auf true steht ist ja wohl auch klar.
übrigens: die tollen darstellungsprobleme hat er nur mit dem Konquerror... Mozilla 1.6 und IE6 geht ohne probleme.
was jetzt die lösung war? einfach ogo mal falsche werte zum fressen geben und dann die richtigen zum eichen - dann nimmt er sie ;)
datensurfer
Newbie
Newbie
Beiträge: 48
Registriert: 22. Feb 2004, 14:19
Wohnort: hannover
Kontaktdaten:

Beitrag von datensurfer »

Tja ich würde sagen völlig falsche Groupware.
Schau dir mal http://www.phpgroupware.org an, die ist super.
Benutze ich selber und würde dir deshalb auch gerne ein paar tipps für diese geben!
Benutzeravatar
JohnDoe1978
Member
Member
Beiträge: 51
Registriert: 12. Mär 2004, 08:35
Wohnort: München
Kontaktdaten:

Beitrag von JohnDoe1978 »

@datensurfer

Wie sieht denn das genau mit der Outlook synchronisation bei phpgroupware aus ? Ich hätte da ein kleines Büro mit so ca. 20 Leuten, die eine möglichst preiswerte und funktionierende Groupwarelösung suchen. Und da die meisten Outlook benutzen und ein Umstieg auf Linux, zumindest Kurzfristig nicht in Frage kommt, bin ich auf der Suche nach Lösungen, welche auch mit Outlook zusammenarbeiten.

Wäre nett, wenn Du mir ein paar Info´s geben könntest.
datensurfer
Newbie
Newbie
Beiträge: 48
Registriert: 22. Feb 2004, 14:19
Wohnort: hannover
Kontaktdaten:

Beitrag von datensurfer »

Soweit ich weiß ist die phpGroupware wohl die einzige wo eine Outlooksynchronisation funktioniert bzw. bald richtig gut funktionieren wird.
Bei openGroupware funzt das auch noch lange nicht! ;)

Bei mir funktioniert die synchronisation zu Outlook über ein propitäres tool, ehrlich gesagt vermute ich auch dass du eher die synchronisation zum "Exchange" meinst?
Dies funktioniert über ldap-tools, ich weiß aber nicht ob das schon final und damit für jeden verfügbar ist.
Ich selber nutze den code aus dem Head.

Schreib mir einfach mal ne pm oder email an mich falls du mehr infos brauchst! ;)
Antworten