Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Wechsel von SUSE8.0 auf 9.3

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

uwe
Member
Member
Beiträge: 98
Registriert: 23. Aug 2004, 18:06

Beitrag von uwe »

Hier meine vorläufigen Ergebnisse:

Nehme ich meine alte smb.conf, dann muss ich die Benutzer noch mittels smbpasswd -a Benutzer erst noch anmelden. Dachte, das müsste ich nur für ne Anmeldung an Win2000/XP Rechnern machen.

Mit der alten smb.conf sieht auch die Darstellung im SWAT wieder ordentlich aus, nehme ich eine "original" smb.conf, wie sie nach einer Installation vorhanden ist, dann zeigt mir der SWAT nur Unsinn an. Komisch.

Also muss ich anscheinend jetzt jeden Benutzer auch in der smbpasswd anmelden. Gibt es einen schnellen Weg, mit dem ich automatisch jeden benutzer in der smbpasswd bekannt mache oder muss ich tatsächlich für jeden Benutzer dias Kommando smbpasswd -a benutzer durchführen (hoffe ich nicht) ??

Grüsse
Uwe
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

Naja, wie schon geschrieben, eigentlich müßte sich die alte Userdatenbank kopieren lassen.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
uwe
Member
Member
Beiträge: 98
Registriert: 23. Aug 2004, 18:06

Beitrag von uwe »

Nach einigen Versuchen hab ich doch noch ne Frage:

Mit der folgenden smb.conf kann ich mich an Win98 Rechnern anmelden und sehe auch die shares "homes", "pub" und "tmp" mit den jeweiligen Laufwerksbuchstaben, wie sie im logon script zugewiesen sind.
Bei einem Win2000 PC kommt nach Passworteingabe:
"Das Profilverzeichnis \\arktur\profiles\.pds konnte nicht erstellt werden.
Der Netzwerkpfad wurde nicht gefunden."

Alle shares sind auch hier zu sehen. Natürlich sind nach dem Abmelden alle Einstellungen (z.B. Outlook Express Einstellungen) verloren.
Ich vermute das liegt daran, weil auf dem Server, auf dem Samba läuft, die home Verzeichnisse der Benutzer unter /home1 gemountet sind (Samba Server ist NIS Client).
Wie stell ich das in der smb.conf ein ??

Grüsse
Uwe

# Global parameters
[global]
bind interfaces only = Yes
map to guest = Bad User
username map = /etc/samba/smbusers
password level = 2
load printers = No
printcap cache time = 750
logon script = logon.bat
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
domain logons = Yes
os level = 65
lock directory = /var/lock
message command = /bin/bash -c 'rm %s' &
cups options = raw
map archive = No
mangled names = No
include = /etc/samba/smb.conf.proj

[netlogon]
path = /etc/samba/scripts
write list = adm, root
read only = No
guest ok = Yes

[homes]
comment = Stammverzeichnis
path = /home1/%S
read only = No
create mask = 0755
veto files = /etc/bin/
hide files = /.*/
browseable = No
exec = /bin/bash -c 'cat /etc/motd | /usr/samba/bin/smbclient -M %m -I %I' &
wide links = No

[tmp]
comment = Datenaustausch
path = /pub/tmp
read only = No
guest ok = Yes
wide links = No

[pub]
comment = Unterrichtsmaterial
path = /pub/adm
read only = No
guest ok = Yes

logon script:

@echo off
net use u: \\arktur\homes /yes
net use p: \\arktur\pub /yes
net use t: \\arktur\tmp /yes
Antworten