Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

falsche Uhrzeit und Rechner nicht erreichbar ?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

falsche Uhrzeit und Rechner nicht erreichbar ?

Beitrag von Frankie777 »

Hallo,
ich habe große Probleme mit einem neuen Rechner. Dieses scheinen mit der Uhrzeit in Verbindung zu stehen.
Ich habe schalte bereits alle paar Stunden den xntp aus, hole die Uhrzeit und schalte dann den xntp wieder an.
Ein großer problem ist immer ein neustart, gestern z.B. mit Failsafe mode gegen 17.44 neu gebootte und danach war der Rechner bis heute vormittag nicht erreichbar. Erst als um 11.00 Uhr ein Cron reboot war kam er wieder ans Netz...

Kann man noch irgendwas verbessert einstellen. Beim shutdown kommt immer die Meldung das die Uhrzeit geschrieben wird, kann man das vielleicht ausschalten?

Bin für jeden Tip dankbar...

hier Auszüge aus den LogFiles:



13 Sep 02:46:44 ntpd[5339]: time correction of 8594 seconds exceeds sanity limit (1000); set clock manually to the correct UTC time.
13 Sep 07:55:10 ntpd[4952]: ntpd exiting on signal 15
-----
Sep 20 17:49:24 kernel: Losing too many ticks!
Sep 20 17:49:24 kernel: TSC cannot be used as a timesource.
Sep 20 17:49:24 kernel: Possible reasons for this are:
Sep 20 17:49:24 kernel: You're running with Speedstep,
Sep 20 17:49:24 kernel: You don't have DMA enabled for your hard disk (see hdparm),
Sep 20 17:49:24 kernel: Incorrect TSC synchronization on an SMP system (see dmesg).
Sep 20 17:49:24 kernel: Falling back to a sane timesource now.
20 Sep 17:43:36 ntpd[5851]: ntpd exiting on signal 15
20 Sep 17:52:35 ntpd[5849]: synchronized to LOCAL(0), stratum 5
20 Sep 17:52:35 ntpd[5849]: kernel time sync disabled 0041
20 Sep 17:53:41 ntpd[5849]: kernel time sync enabled 0001
20 Sep 18:00:01 ntpd[5849]: ntpd exiting on signal 15
20 Sep 18:00:27 ntpd[5875]: parent died before we finished, exiting
21 Sep 11:14:26 ntpd[5768]: synchronized to LOCAL(0), stratum 5
21 Sep 11:14:26 ntpd[5768]: kernel time sync disabled 0041
21 Sep 11:15:30 ntpd[5768]: kernel time sync enabled 0001
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16636
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois »

Hi

Etwas mehr Hardware Details wären nützlich :wink:

Dazu welche Distribution in welcher Version.
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

'Ältere' Kernel haben auf SMP-Systemen Probleme mit der Uhrzeit. Ich würde mal einen aktuelleren Kernel probieren. Aber ohne genauere Infos kann man da auch nix sagen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Hallo,
der Rechner ist ein ProLiant PIV 3 GHz
keine besondere Hardware angeschlosen.

Installiert ist Suse 9.3 plus alle verfügbaren Patches.
Der Rechner ist frisch aufgesetzt (5 Wochen), hat aber seit Anfang an Probleme mit der Uhrzeit. Selbst der Dauerbetrieb im Failsafe Mode führt bei reboots zu diesen Problemen. Er ist auch schon zweimal vollkommen eingefroren, aber meistens nur nicht erreichbar, aber eben auch nicht nach jedem reboot. Manchmal meldet er sich wieder.

In dem Rechner ist auch eine zweite Ethernetkarte, allerdings zur Zeit deaktiviert, weil ich einen Zusammenhang vermutet habe, hat sich aber nicht bestätigt.

Tux:/etc/cron.d # cat /proc/version
Linux version 2.6.11.4-21.9-smp (geeko@buildhost) (gcc version 3.3.5 20050117 (prerelease) (SUSE Linux)) #1 SMP Fri Aug 19 11:58:59 UTC 2005


Bin für jeden Hack dankbar um das Ding stabil zu bekommen.
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Nochmal mein Tip: Nimm einen 2.6.13er-Kernel.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Du meinst:
Sources runterladen
Konfiguration auslesen
Sources damit compilieren

könnte auf Anhieb klappen, oder komme ich dann vom hunderste ins tausendste...

Kernel habe ich mir bisher nur einmal angeschaut, allerdings länger her und mit mäßigen Erfolg..
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Du kannst auch zuerst mal einen kotd (kernel of the day) probieren.
Findest du hier:
ftp://ftp4.gwdg.de/linux/suse/apt/SuSE/
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Die Verzeichnisse für 9.3 sind leer.
Bei 9.2. liegt was altes drin.

Wird das nicht ein wenig zu experimentell?
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Ich habe noch mal in den LogFiles geschaut:

vielleicht kann damit noch jemand was anfagen.....

<4>Detected 3000.640 MHz processor.
<6>Using pmtmr for high-res timesource
<4>Console: colour dummy device 80x25
<4>Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
<4>Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
<6>Memory: 772280k/785856k available (2114k kernel code, 12916k reserved, 704k data, 248k init, 0k highmem)
<4>Checking if this processor honours the WP bit even in supervisor mode... Ok.
<7>Calibrating delay loop... 5947.39 BogoMIPS (lpj=2973696)
<6>Security Framework v1.0.0 initialized
<6>SELinux: Disabled at boot.
<4>Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
<7>CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 0000041d 00000000 00000000
<7>CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 0000041d 00000000 00000000
<4>monitor/mwait feature present.
<4>using mwait in idle threads.
<6>CPU: Trace cache: 12K uops, L1 D cache: 16K
<6>CPU: L2 cache: 1024K
<6>CPU: Physical Processor ID: 0
<7>CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 0000041d 00000000 00000000
<6>Intel machine check architecture supported.
<6>Intel machine check reporting enabled on CPU#0.
<6>CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
<6>CPU0: Thermal monitoring enabled
<6>Enabling fast FPU save and restore... done.
<6>Enabling unmasked SIMD FPU exception support... done.
<6>Checking 'hlt' instruction... OK.
<6>checking if image is initramfs... it is
<6>Freeing initrd memory: 1408k freed
<6>ACPI: Looking for DSDT in initrd... not found!
<4> not found!
<4>CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 03
<4>per-CPU timeslice cutoff: 2926.02 usecs.
<4>task migration cache decay timeout: 3 msecs.
<4>Booting processor 1/1 eip 3000
<6>Initializing CPU#1
<7>Calibrating delay loop... 5996.54 BogoMIPS (lpj=2998272)
<7>CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 0000041d 00000000 00000000
<7>CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 0000041d 00000000 00000000
<4>monitor/mwait feature present.
<6>CPU: Trace cache: 12K uops, L1 D cache: 16K
<6>CPU: L2 cache: 1024K
<6>CPU: Physical Processor ID: 0
<7>CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 0000041d 00000000 00000000
<6>Intel machine check architecture supported.
<6>Intel machine check reporting enabled on CPU#1.
<6>CPU1: Intel P4/Xeon Extended MCE MSRs (12) available
<6>CPU1: Thermal monitoring enabled
<4>CPU1: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 03
<6>Total of 2 processors activated (11943.93 BogoMIPS).
<4>ENABLING IO-APIC IRQs
<6>..TIMER: vector=0x31 pin1=2 pin2=-1
<6>checking TSC synchronization across 2 CPUs: passed.
<4>Brought up 2 CPUs
<6>NET: Registered protocol family 16
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Frankie777 hat geschrieben:Hallo, der Rechner ist ein ProLiant PIV 3 GHz
Was für ein Proliant ?

HP unterstützt offiziell nur die SLES aber nicht die Pro Versionen.

Ich habe vor einiger Zeit SuSE 9.2 Pro auf einem ML370G3 installiert ohne besondere Probleme. Das HP Management Zeugs habe ich erst gar nicht versucht zu installieren.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Hallo,
es ist ein Proliant ML310 oder 330. Ich bin mir jetzt nicht ganz sicher.

Noch irgendeine Idee?

Irgendein Befehl den der cron starten kann um das System wieder in Gang zu bringen? Es läuft ja im Prinzip, nur irgendeine Systemuhr muß so verstellt sein, daß der Rechner nicht mehr über die Netzwerkkarte kommunizieren kann.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Hmmm... ich weiß nicht was der Fehler ist.

Man könnte mal versuchen ein Skript zu stricken daß z.B. versucht irgendwas anzusprechen und wenn das fehlschlägt ein rcnetwork restart macht. Damit wird aber natürlich am Symptom und nicht am Problem geschraubt.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Der Rechner läuft ja intern, auch die Uhrzeit in den LogEinträgen stimmt. Die Ethernetkarte geht und gibt brav die MAC Nummer raus, nur mehr passiert eben nicht.
Aber rcnetwork restart ist eine gute Idee, alleinige rcxntp restart bringt nicht.
Nach einem Neustart gestern war der Rechner wieder weg, um 23.00 war ein Cron reboot geplant. Punkt 23.00 Uhr hat die Karte für 5 s auf pings geantwortet, war danach wieder weg und nach 1,5 Minuten war der Rechner OK und erreichbar.
Das ist schon alles sehr komisch, durch das runterfahren hat die Karte wieder funktioniert.

Der Rechner läuft seitdem nicht mehr im Failsafe mode und macht keine Probleme.
Antworten