Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

dvb-c fujitsu-siemens karte modul+treiber automatisch laden

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

dvb-c fujitsu-siemens karte modul+treiber automatisch laden

Beitrag von fritzbee21 »

nach sporadischem Basteln (ueber ein Jahr) mit immer wiederkehrenden auszeiten habe ich mittlerweile meine dvb-c Karte von Fujitsu-Siemens zum laufen bekommen.

Viel gibts ueber diese karte hier im Forum nicht zu finden
(hier gibts einen teil der installationsanleitung:
http://www.linux-club.de/viewtopic.php? ... light=dvbc )
die Probleme welche ich jetzt habe sind relativ allgemein, ich denke das mit deswegen der ein oder andere helfen kann.

wenn ich meinen pc starte (suse 9.1, kernel 2.6.4-52) muss ich zum zueden der dvb karte in einer root konsole mit
"modprobe dvb-ttpci"
den treiber manuell laden
die dmesg sieht dann folgendermassen aus:



Linux video capture interface: v1.00
saa7146: register extension 'dvb'.
AMD756: dev 1131:7146, router pirq : 2 get irq : 11
PCI: Found IRQ 11 for device 0000:00:09.0
saa7146: found saa7146 @ mem dcd54c00 (revision 1, irq 11) (0x110a,0x0000).
DVB: registering new adapter (Siemens cable card PCI rev1.5).
Siemens cable card PCI rev1.5 adapter 0 has MAC addr = 00:d0:5c:00:b7:1c
DVB: AV7111(0) - firm f0240009, rtsl b0250018, vid 71010068, app 8000261f
DVB: AV7111(0) - firmware supports CI link layer interface
av7110(0): DVB-C analog module detected, initializing MSP3400
av7110(0): MSP3400 version 0x0303 0x0008
saa7146_vv: saa7146 (0): registered device video0 [v4l2]
saa7146_vv: saa7146 (0): registered device vbi0 [v4l2]
av7110: found av7110-0.
DVB: VES1820(0): setup for tuner spXXXX
DVB: VES1820(0): pwm=0x28
DVB: registering frontend 0:0 (VES1820 based DVB-C frontend)...
saa7146: register extension 'budget dvb'.
saa7146: register extension 'budget_ci dvb'.
saa7146: register extension 'budget dvb /w video in'.
drivers/usb/core/usb.c: registered new driver Technotrend/Hauppauge USB-Nova
drivers/usb/core/usb.c: registered new driver ttusb-dec


wenn ich jetzt eine czap application starte (per kommandozeile auf einen sender tunen) bekomme ich eine fehlermeldung, das mein frontend0 nicht gefunden wurde.
d.h. ich wechsel in mein installationsverzeichnis und lade mit
./insmod.sh load
die module fuer die karte
komischerweise gibt es eine ausgabe, das die module schon vorhanden seien (aber es funzt ohne das laden nicht)
jetzt kann ich mit czap auf einen sender tunen.

ok soweit funzt die karte schonmal
die frage ist jetzt:

wie zum teufel kann ich das prozedere vereinfachen (jedesmal insmod und modprobe ausfuehern ist ziemlich nervig) ?

wenn ich
modprobe dvb-ttpci
in
/etc/init.d/boot.local
eintrage, bekomme ich in dmesg die meldung das die firmaware der karte nicht geladen werden konnte.

laut readme soll mal angeblich folgendes machen:

When everything is working you probably want to install the driver on your
system by typing 'make install'.

allerdings gibt mir make install aus, ich soll doch bitte das ganze mit ./insmod.sh machen

wolfgang@linux:~/linuxtv/linuxtv-dvb-1.1.1> make install
cat: CVS/Root: Datei oder Verzeichnis nicht gefunden
make -C /home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6 install
make[1]: Entering directory `/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6'
Use insmod.sh to load/unload the driver modules.
make[1]: Leaving directory `/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6'

dann haette ich noch folgendes in petto:

If you want to load the modules automatically
when an application tries to open the device you need to add lines like these
to your modules.conf:

probeall /dev/dvb dvb-ttpci
alias /dev/dvb/* /dev/dvb
below dvb-ttpci alps_bsrv2 alps_tdmb7 alps_tdlb7
add below dvb-ttpci grundig_29504-401 grundig_29504-491
add below dvb-ttpci stv0299 ves1820

ok das hab ich gemacht, bringen tuts allerdings garnicht !


tv ausgabe auf dem monitor ist auch noch nicht moeglich, laut readme der karte (hat nen mpeg decoder an board) soll es mit xawtv klappen, allerdings bekomme ich damit folgende ausgabe:

./xawtv
This is xawtv-3.94, running on Linux/i686 (2.6.4-52-default)
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
open /usr/local/share/xawtv/Index.map: Datei oder Verzeichnis nicht gefunden


deutet darauf hin das irgendwas mit den farben nicht ok ist ???


ok das sind noch viele probleme, ich waere euch allerdings fuer jeden tipp dankbar denn ich denke jeder kleine hinweis wird mich weiterbringen ;-)
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Code: Alles auswählen

wolfgang@linux:~/linuxtv/linuxtv-dvb-1.1.1> make install
cat: CVS/Root: Datei oder Verzeichnis nicht gefunden
make -C /home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6 install
make[1]: Entering directory `/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6'
Use insmod.sh to load/unload the driver modules.
make[1]: Leaving directory `/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6'
führe das make install mal als root aus ;)

dein xawtv Problem:
du hast irgendwie kein Standard-RPM installiert ? oder selber compiliert.

Jedenfalls sucht das Programm die Datei in /usr/local/share/xawtv/Index.map.
Mit rpm -ql xawtv solltest du sehen welche Dateien in deinem Paket drin sind ..
Wenn du die Datei index.map woanders stehen hast, dann kopiere sie mal nach /usr/local/share/xawtv. Das musst du evtl für mehrere Datein durchführen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

Beitrag von fritzbee21 »

ok danke erstmal fuer deine Hilfe,
make install
als root hatte ich schon probiert

linux:/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6 # whoami
root
linux:/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6 # make install
Use insmod.sh to load/unload the driver modules.
linux:/home/wolfgang/linuxtv/linuxtv-dvb-1.1.1/build-2.6 #

kann ich denn nicht ein script bauen das sowohl das modprobe als auch das laden der module beim booten ausfuehrt ?

dein rpm -ql xawtv war genau der richtige tipp, angeblich war gar kein xawtv installiert (obwohl ich mir die 3.94 ausm netz geladen und isntalliert hatte).
ich hab jetzt die xawtv (ist 3.91) von der suse 9.1 genommen und siehe da, es funzt ;-) ;-) ;-) ;-)
sehr geil, als naechstes wuerde ich mir gern mit der karte nen vdr aufsetzen (www.vdr-wiki.de), mal schaun was da noch so alles auf mich zukommt
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

fritzbee21 hat geschrieben:kann ich denn nicht ein script bauen das sowohl das modprobe als auch das laden der module beim booten ausfuehrt ?
klar, kannst du das.
Als Einstieg empfehle ich dir dieses Posting:
[HOWTO] runlevel scripte - selber erstellen
http://www.linux-club.de/viewtopic.php?t=16069
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Antworten