Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] postfix - localhost type=A: Host not found

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Benutzeravatar
SD582
Member
Member
Beiträge: 65
Registriert: 1. Jun 2004, 20:29
Wohnort: Salzburg - Flachgau
Kontaktdaten:

[gelöst] postfix - localhost type=A: Host not found

Beitrag von SD582 »

Hallo Leute

Ich quähle mich mal wieder mit postfix und Konsorten.

Beim Versuch eine mail zu versenden, bekomme ich ein schönes log (/var/log/mail) welches mir etwas Kopfzerbrechen bereitet.
Kann mir da jemand bitte mal die Taschenlampe halten? ;)

Code: Alles auswählen

Sep 17 08:10:50 pc-linux postfix/smtpd[9395]: connect from unknown[192.168.0.5]
Sep 17 08:10:50 pc-linux postfix/smtpd[9395]: EE6881FF8C: client=unknown[192.168.0.5]
Sep 17 08:10:51 pc-linux postfix/cleanup[9398]: EE6881FF8C: message-id=<000901c5bb4e$9e92a120$0500a8c0@PCFRANZ>
Sep 17 08:10:51 pc-linux postfix/smtpd[9395]: disconnect from unknown[192.168.0.5]
Sep 17 08:10:51 pc-linux postfix/qmgr[9286]: EE6881FF8C: from=<scfr@sc2web.net>, size=667, nrcpt=1 (queue active)
Sep 17 08:10:51 pc-linux postfix/smtp[9400]: EE6881FF8C: to=<scfr@aon.at>, relay=none, delay=1, status=bounced (Host or domain name not found. Name service error for name=localhost type=A: Host not found)
Sep 17 08:10:51 pc-linux postfix/cleanup[9398]: 1AAF82016C: message-id=<20050917061051.1AAF82016C@hamster.schinagl>
Sep 17 08:10:51 pc-linux postfix/qmgr[9286]: 1AAF82016C: from=<>, size=2443, nrcpt=1 (queue active)
Sep 17 08:10:51 pc-linux postfix/qmgr[9286]: EE6881FF8C: removed
Sep 17 08:10:51 pc-linux postfix/smtp[9400]: connect to ns9.schlundtech.de[62.116.129.129]: Connection refused (port 25)
Sep 17 08:10:52 pc-linux postfix/smtp[9400]: 1AAF82016C: to=<user@sc2web.net>, relay=mail.sc2web.net[217.20.119.62], delay=1, status=sent (250 Ok: queued as A6CB318C8AF)
Sep 17 08:10:52 pc-linux postfix/qmgr[9286]: 1AAF82016C: removed
Ich versteh nicht, warum das Ding die Mail an sich nicht an mail.sc2web.net ausliefert. Zum Senden der bounce-Meldung weiß es dann ja auch plötzlich, wo's lang gehen soll.

Und was will das Ding mit ns9.schlundtech.de? Ich habe keine Ahnung, warum der hier ins Spiel kommt.

Soll wäre, dass alle mails die versendet werden sollen, über mail.sc2web.net versendet werden. Das habe ich ja auch als relayhost so eingetragen, worauf sich postfix ja auch bei der bouncemeldung anscheinend besinnt.

Kann mir jemand sagen was da falsch läuft und was ich kontrollieren/ändern müsste?

Gruß
Franz
Zuletzt geändert von SD582 am 17. Sep 2005, 16:20, insgesamt 1-mal geändert.
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

irgendwie läuft der Nameserver nicht.
und ns9.schlund... ist z.B. ein Nameserver eines großen Providers, wo evtl. nach dem MX-Record gesucht wird.
Prüfe mal deine Einstellungen des DNS und/oder die Daten von postfix.
Aber er kennt ja nicht mal deine eigene Adresse 192.168.0.5, nicht den localhost etcpp.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Benutzeravatar
SD582
Member
Member
Beiträge: 65
Registriert: 1. Jun 2004, 20:29
Wohnort: Salzburg - Flachgau
Kontaktdaten:

Beitrag von SD582 »

Hi

Das ist ja das komische - localhost sollte er doch ohne namserver kennen - da kann ihm sowieso kein Nameserver helfen.
Ebenso 192.168.0.5 - das ist ja schon eine fertig aufgelöste IP. Das würde _mich_ erstmal überhaupt nicht stören, daß er da keinen Plan hat wer das ist.

Ich habe in zwischen noch einen Test gemacht und habe direkt am Linux-Rechner mit KMail eine mail versandt. Das hat wunderbar funktioniniert - auch im log schön nachzuvollziehen.

Jetzt ging die Vermutung in Richtung "von diesem unbekannten Rechner leite ich nichts weiter".
Allso access.db oder sonstige anti-relay-Einstellungen.

Da gibts in main.cf den Parameter mynetworks. Der steht auf 192.168.0.0/24, 127.0.0.0/8 - was erstmal passen müsste.
Dann war da smtpd_sender_restrictions = hash:/etc/postfix/access eingestellt. Das habe ich jetzt erst mal auf nix gestellt (soll keine access verwenden also von mynetworks alles erlauben.
Das hat noch nichts gebracht.

Als nächstes werde ich es mit dem Eintrag 192.168.0 OK in der access (access in der main.cf wieder aktiviert) probieren und wenn das auch nichts hilft, dann versuche ich mein Glück mit einer hosts damit das mit dem reverse lookup sicher funktioniert.

Gruß
Franz
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

schau mal hier:
Postfix kennt localhost nicht
http://www.linux-club.de/viewtopic.php?t=41175
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Benutzeravatar
SD582
Member
Member
Beiträge: 65
Registriert: 1. Jun 2004, 20:29
Wohnort: Salzburg - Flachgau
Kontaktdaten:

Beitrag von SD582 »

Danke sehr :)

Komisch ist das schon. Ich habe noch eine weggesicherte master.cf von einem Server mit Suse 9.1. Da steht ebenfalls [localhost] drinnen. Damals hat das aber klaglos funktioniert.

Ich habe also das [localhost] in der master.cf auf [127.0.0.1] geändert. Damit ist das Problem beseitigt und meine mails gehen raus.

Daß ohne hosts-Eintrag der 192.168.0.5 keinen Namen (bzw. unknown) bekommt ist eigentlich nicht wichtig. Es geht auch so :)

Gruß
Franz
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

entweder localhost oder [127.0.0.1], denn die Klammern schalten die DNS-Nachfrage aus.
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

[] bedeutet kein MX lookup fuer diese ip/namen - sonst nix
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
Benutzeravatar
SD582
Member
Member
Beiträge: 65
Registriert: 1. Jun 2004, 20:29
Wohnort: Salzburg - Flachgau
Kontaktdaten:

Beitrag von SD582 »

carsten hat geschrieben:entweder localhost oder [127.0.0.1], denn die Klammern schalten die DNS-Nachfrage aus.
Nö! hab ich probiert. Die Klammern weglassen bringt nichts. Es half nur die IP da reinzuschreiben.

Gruß
Franz
Gesperrt