Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

XP Anmeldung auf Sambaserver

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

XP Anmeldung auf Sambaserver

Beitrag von ret0 »

Hallo zusammen

Ich bin jetzt seit einigen Stunden auf dem Netz nach einer Lösung für mein Problem am suchen! Ich hoffe nun hier eine zu finden:

Ich habe auf einem aktuellen RedHat den SAMBA-Dienst eingerichtet. Anschliessen erstellte ich einen User, dann mit

smbpasswd -a -e Username

den Sambauser mit demselben Passwort.

Auch folgende Zeile habe ich schon eingegeben:
/etc/passwd | mksmbpasswd.sh > /etc/smbpasswd

Dies klappt jetzt allerdings mit folgender Meldung nicht mehr:
bash: /etc/passwd: Keine Berechtigung

Mein eigentliches Problem jedoch liegt darin, dass ich probiere mit einem Windows XP auf einen Share zuzugreifen will. Das Fenster für die Eingabe von User und Passwort erlaubt jedoch nur die Eingabe eines Passworts (der User ist stets Gast)!

net use z: \\server\share /user:benutzer passwort

wird mit einem systemfehler 1326 quittiert.

smb.conf sieht folgendermassen aus:

[global]
workgroup = workgroup
netbios name = server
server string = samba testserver
security = SHARE
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
os level = 32
preferred master = yes
domain master = yes
dns proxy = no

[share]
comment = Backups
path= /usr/shares/backups
force user = gringle
read only = no
guest ok = no
guest only = no
hosts allow = 192.168.0.
create mask = 700
directory mask = 700
valid users = test3


Bin froh um jeden Hinweis!

Gruss
reto
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

als root den User unter Unix anlegen
dann als root mit smbpasswd -a user
den Samba user anlegen
- e wird eigentlich automatisch gemacht

der Unix User braucht die Rechte auf den Verzeichnissen und Dateien, sonst geht mit Samba nichts zuzugreifen

die smb.conf sieht etwas "wüst" aus..
force user ???
am besten erst mal unter global defaults setzten
und in den einzelnen shares dann die zusätzlichen Regeln eingegen
anschließend mit testparm die smb.conf prüfen, redundante Eintragungen erscheinen da schon gar nicht mehr:
hier die Optionen
http://us3.samba.org/samba/docs/using_samba/appb.html

Versuch mal das hier zum Aufruf für den Anfang
net use M: \\IP\share /USER:name

oder zuvor net view IPserver
oder smbclient -L auf dem Server eingeben
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

Vielen Dank für die prompte Antwort. Users sind eben alle schon erstellt. Die wüste conf kommt daher, weil ich sie in kürzester Zeit abgetippt habe (nicht die selbe kiste) und nicht auf die darstellung geschaut habe. Werde das ganze aber gleich mal angucken.
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

also


testparm meldet keine probleme. force user habe ich rausgenommen. laut meinen büchern müsste diese conf auch funktionieren. den share sehe ich vom windows xp aus. übrigens: windows 2000 kommt ohne probleme auf den share. nur windows xp hat irgendwie mühe damit.

wegen den rechten des unix-users. wo stelle ich die ein?
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

von XP aus
net use /delete *
net use M: \\IPServer\share /USER:sambauser


Unix-Rechte
man chmod, chown, chgrp
und google für Linux-Rechte Datei und Verzeichnisse
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

windowsbefehle sind nicht das problem, das ist ja eigentlich meine welt :)

das mit de verzeichnisberechtigungen werde ich morgen gleich ausprobieren. danke nochmals für die hinweise.

ich denke jedoch es liegt an der smb.conf oder jedenfalls an der netzwerkeinstellung bezüglich samba. weil, ich komme mit windows 2k ohne probleme drauf.
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

Die Berechtigungen sind alle in Ordnung. Das Problem besteht jedoch noch immer.

Noch eine Idee?
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Wenn Du meinst das Deine Einstellungen alle richtig sind, dann LogFiles anschauen
Samba: log level = hochstellen
WinXP: eventlog

Was sagt über Windows bei net use \\IPServer\share
Fehlernummer?
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

dann kommt jeweils die fehlernummer 1326. er scheint einfach den user gast vorzuschreiben und den user der das windows übergeben soll zu ignorieren.

sobald in der smb.conf für einen share die option
guest ok = No
steht, geht es nicht mehr. sonst würde alles laufen.
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

wenn die smb.conf noch stimmt kann sich nur der valid user test3 anmelden, wenn der Gaststaus deaktiviert ist. test3 hat zudem noch Schreibrechte per Samba zugewiesen bekommen.

und sicherstellen, daß Windows nicht schon eine andere Verbindung mit dem Samba-Server aufgebaut hat
net use /delete * vorher machen
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

nützt leider auch nix. aber danke dir trotzdem für deine mühe.
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Grundlagen siehe hier: http://samba.sernet.de/info.html

Samba 3 in der default-Konfiguartion und ein XP aus der Box mit SP2 funktioniert. Es gibt allerdings viele Schalter die das verhindern können.
In den LogFiles sollten sich dazu Hinweise finden.
ret0
Newbie
Newbie
Beiträge: 8
Registriert: 15. Sep 2005, 15:25

Beitrag von ret0 »

danke für den hinweis. ich probierte die version 3 per rpm packet zu installieren. da meinte es, es fehlen diverse andere packete. nach diesen kann ich aber googeln wie ich will und finde nichts. da dies aber newbie-probleme sind, denke ich, gehören die nicht in dieses forum.
Antworten