Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Maschine in die Domain aufnehemem

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Maschine in die Domain aufnehemem

Beitrag von Hades »

Hallo zusammen ,

ich habe das Problem das ein wichtiger PC welcher als Twixtel server ist und weiteres nicht mehr in die Domain bringe..

Vorgeschichte:

Netzlaufwerke /twixtel funktioniert nicht mehr , ich sehe das es probleme gibt mit dem Domaincontroller , also er findet ihn nicht ,im eventlog........

Dan aus der Domain genommen und wollte ihne wieder reintun , nix geht , komische fehlermeldung "Konnte Verbindung zu einem Domaincontroller für Domäne xxxx nicht hergestellt werden."

Weiss nicht was problem ist Maschine Account habe ich glöscht via Webmin -> habe auch dies Script zum erstellen des accounts alles tip top aber ich kann nicht der Domain beitreten.
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

Kannst Du den Domänencontroller denn pingen?
Versuche mal, den smbd und den nmbd auf dem Server neu zu starten.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

Ja kann ich problemlos pingen...
admine
Administrator
Administrator
Beiträge: 8970
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

Gab es irgendwelche Updates am DC ?
Evt. auch mal in dieser Richtung forschen.
Grüße
-------------------------------------
..:: Deutsche Mugge ::..
-------------------------------------
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

Nein es wurden keine Updates gemacht.....
admine
Administrator
Administrator
Beiträge: 8970
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

Dann eben Webmin mal außen vor lassen und manuell in die Domäne hängen.
Und die Dienste restarten.
Grüße
-------------------------------------
..:: Deutsche Mugge ::..
-------------------------------------
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Was steht denn in der Fehlermeldung beim Beitritt?
fehlende SRV Einträge, DNS... etc.

Da er den Samba über WINS suchen wird (DNS Einträge wirst Du wohl nicht haben) wird er wohl den Samba nicht finden, weil NetBios Namen nicht funktionieren

also das erst mal den WINS Server prüfen und die Namensauflösung
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

Ja fehleder SVR Eintrag DNS....

Aber DNS Server ist vorhanden kann auch den Server pingen via Name und IP......

Aber er kann irgendwie die Domain nicht auflösen also den DC finden....
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Ja, aber Du wirst bei Deinen DNS-Server (vermutlich Samba) nicht die notwendigen Einträge haben um darüber den DomainController zu finden.

Du mußt WINS zum laufen bekommen.
Steht in der /var/lib/samba ein #1c Eintrag ?
Dieser ist für den DomainController.
Dein PDC wird auch WinsServer sein??, wenn ja rcnmb stop
/var/lib/samba wins.dat und browse.dat löschen, rcnmb start
20 min warten, PC ebenfalls neu starten

Am PC prüfen ob NetBios über TCP/IP aktiviert ist
Welcher Knotentyp bei ipconfig /all ? h ??
WINS-Server am PC eingetragen?
geht net view PDC oder net view IP-PDC am PC
Firewalls nicht verändert?
irgendwie ein weitere PDC oder WINS-Server in Betrieb gegangen?

dann Konten auf PDC prüfen..
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

steht in der /var/lib/samba ein #1c Eintrag?

Wo ist der, Im verzeichnis Samba , 1C?
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

/var/lib/samba
wins.dat # Daten des WINS-Servers
browser.dat # Daten des NetBios-Browsers

In der wins.dat muß ein Eintrag mit #1c für den PDC sein.
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

Hmm Wins.dat ist gar nicht vorhanden
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

dann ist der Samba Server kein WINS-Server oder rcnmb läuft nicht oder ist kaputt.

nochmal /var/lib/samba/wins.dat ist die gesuchte Datei

wins server = yes
macht ihn zum WINS Server

auf den Win-Clients muß der aber auch eingetragen werden!

und nur einen WINS-Server im SubNet!

PS: ich hoffe die legt bei Dir nicht wo anders, such nochmal systemweit
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

Habe die wins.dat gesucht und nicht gefunden.. nur die browse.dat
Soll ich die wins.dat erstellen ? Welchen inhalt ? Formatierung?
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

Also: Hast Du die Serverdienste neu gestartet? Hast Du den Sambaserver zum WINS-Server gemacht und dabei darauf geachtet, daß kein anderer WINS-Server läuft? Wenn Du uns keine Rückmeldung gibst, was Du alles tust, dann stochern wir hier nur weiter im Nebel. Die Fehlersuche kann aber nur systematisch zum Erfolg führen, wenn, was wir bis auf Dich alle nicht tun, man nicht vor dem Rechner selbst sitzt.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
Benutzeravatar
Hades
Newbie
Newbie
Beiträge: 11
Registriert: 29. Mär 2005, 16:19
Wohnort: Schweiz

Beitrag von Hades »

Also:

Ich hab die Dienste bis jetzt noch nicht neugestartet.....

Der Samba Server steht in einer grossen IT Umgebung hauptsächlich Microsoft , IBM etc ..
Er ist Fileserver für eine Abteilung welche ca. 25 User hat. Er ist nur PDC, Fileserver und WINS server.... DNS mässig ist er bei den DNS Servern sauber eingetragen.

Das Problem ist das er Produktiv ist und ich ihn erst abends neubooten kann, oder dienste ...
Der PC der porbleme macht ist eine XP Kiste die quasi Hilfsserver spielt (Netzlaufwerke , Software etc ..). Diese hat den DC verloren laut eventlog. Alles andern PC`s laufen...

Ich hab ihn aus der Domain genommen , den Maschine Account via Webmin gelöscht und versucht frisch einzubinden.

Dan komt folgende Fehlermeldung:

Bild
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

die wins.dat kann man nicht editieren, sie wird von Samba angelegt und enthält die Informationen über Arbeitsgruppen, Rechner usw.

Linux muß man nicht unbedingt neu starten.
Es reicht rcsmb und nmbd restart um Samba neu zu starten.
Windows sollte man schon neu starten.
Wenn Du keine wins.dat hast, dann ist der Samba-Server kein Wins-Server!
wins server = yes in den globals macht ihn zum Wins-Server

Die Fehlermeldung des PC hatten wir ja schon, leider ist sie nicht sehr aussagekräftig.
Ist beim PC unter WINS-Server der Samba PC eingetragen?

Wenn WINS Server Samba käuft und der PC den WINS-Server eingetragen hat dann die Samba logfiles anschauen warum die Anmeldung nicht klappt.


Ich vermute immer noch, daß der PC den Samba-Server nicht findet und deswegen der Domaine nicht beitreten kann.
Antworten