Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse10---USB Transfarerate zu niedrig

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

djfoxi
Newbie
Newbie
Beiträge: 9
Registriert: 23. Jan 2005, 11:58

Beitrag von djfoxi »

Bei mir war nachdem anstöpseln eines USB-Memorysticks auch nur Maximal 30kb Transferrate möglich.

Nach den automatischen Yast-Updates in letzter Zeit ist das Problem jetzt behoben.

Die Zeit heilt nunmal alle Wunden...auch bei LInux
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Wüsste jetzt nicht, welches Update das gewesen sein sollte. Eigentlich war nichts im you was den HAL geändert hätte, soweit ich das sehe.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
LittleDream
Newbie
Newbie
Beiträge: 41
Registriert: 6. Nov 2004, 15:55
Wohnort: Magdeburg
Kontaktdaten:

Beitrag von LittleDream »

ich habe alle updates entsprechend regelmäßig eingespielt, aber bei mir gab es nichts, was den zustand verändert hätte, dass die transferraten von hause aus passen ... und es funktioniert noch immer nicht ...
sys --> p4 2.53 GHz, ASUS P4PE, 512 MB DDR, HIS Radeon 9600 XT, SuSE 10.0 OSS with kernel 2.6.15.1, gcc 4.0.2, kde 3.5 ...

Mein Leben!!!!
sgh
Newbie
Newbie
Beiträge: 1
Registriert: 8. Nov 2005, 23:00

Beitrag von sgh »

LittleDream hat geschrieben:ich habe alle updates entsprechend regelmäßig eingespielt, aber bei mir gab es nichts, was den zustand verändert hätte, dass die transferraten von hause aus passen ... und es funktioniert noch immer nicht ...
Tip aus dem Kofler Buch, etwas ausgescmückt:
nach Einstecken des ipod (Beispiel)

root (su)
mount -> zeigt den mount an, device und mountpoint beachten,
umount /media/ipod
mount /dev/sda2 /media/ipod

Auch "grep sda /var/log/messages" zeigt den mount und die subfs sync option

Gruss, Stephan
Benutzeravatar
LittleDream
Newbie
Newbie
Beiträge: 41
Registriert: 6. Nov 2004, 15:55
Wohnort: Magdeburg
Kontaktdaten:

Beitrag von LittleDream »

sgh hat geschrieben: Tip aus dem Kofler Buch, etwas ausgescmückt:
nach Einstecken des ipod (Beispiel)

root (su)
mount -> zeigt den mount an, device und mountpoint beachten,
umount /media/ipod
mount /dev/sda2 /media/ipod

Auch "grep sda /var/log/messages" zeigt den mount und die subfs sync option

Gruss, Stephan
das ist mir schon klar, es funktioniert bei mir auch über die abschaltung der sync-option über hal, aber es ist für mich keine wirkliche lösung. ich will, dass mein mp3-player, usb-stick etc. mit der sync option gemounted wird, aber da führ kein weg hin ...
sys --> p4 2.53 GHz, ASUS P4PE, 512 MB DDR, HIS Radeon 9600 XT, SuSE 10.0 OSS with kernel 2.6.15.1, gcc 4.0.2, kde 3.5 ...

Mein Leben!!!!
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Hab das jetzt auch nach den Hinweisen aus den ReleaseNotes gemacht. Hat aber erst im zweiten Anlauf geklappt, warum auch immer.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
konga
Newbie
Newbie
Beiträge: 5
Registriert: 3. Dez 2005, 01:07

/etc/sysconfig/hotplug

Beitrag von konga »

hallo,
bei suse 9.2 kann ich in /etc/sysconfig/hotplug die hotplug parameter verändern (sync, automount...). diese datei gibt es bei suse10 nicht mehr. kann mir jemand sagen, wo ich diese einstellungen vornehmen kann? das würde mir mit meiner usb-platte helfen.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Mach es so, wie hier:
http://sbox.bgweiz.at/stefan.reisinger/ ... keits-bug/

Abschnitt:
<match key="@info.parent:storage.bus" string="usb">

bedeutet, alle USB-Geräte werden ohne sync gemountet.

MfG
misiu
Benutzeravatar
konga
Newbie
Newbie
Beiträge: 5
Registriert: 3. Dez 2005, 01:07

Beitrag von konga »

danke, das klappt!
noch eine frage: weisst du, wie ich den automount abstelle und wie ich den mount-type von subfs auf fstab umstelle?
grüsse
konga
Benutzeravatar
Triade
Newbie
Newbie
Beiträge: 33
Registriert: 15. Aug 2005, 15:29
Wohnort: Hanau

Beitrag von Triade »

Bei mir hats auch geklappt.
Die Transferrate liegt jetzt wesendlich höher, sinkt aber immernoch leicht ab.
GSB d-(++) s+++:- a-- C++>+++ UL+>++ P L++ E? W++ N+ o? K- w O? M?
VMS? PS+ !PE Y-- PGP- t++ 5-- X- R+ tv+ b+ !DI D+ G e>+++ h--- r++ y+++
Vers.: 3.12
Benutzeravatar
Pfalzwolf
Member
Member
Beiträge: 195
Registriert: 21. Jul 2005, 12:28
Wohnort: Pfalz, nahe SP
Kontaktdaten:

Geschwindigkeitszuwachs riesig

Beitrag von Pfalzwolf »

Der Tipp in dem Link, den misiu oben vermittelt hat hat super geklappt - vielen Dank.
Nachdem sich Daten vorher mit ca 10kb/s zum USB Stick schlichen, sind es jetzt 4...5MB/s.
Das lässt sich sehen!
SuSE Leap 42.2|ASUS Prime X370-PRO|Ryzen 7 1700|GraKa:MSI GTX 1050 Ti|LAN: Intel I211AT Gigabit LAN | 4.4.70-18.9-default|KDE 5.8.6
andreasw
Member
Member
Beiträge: 76
Registriert: 12. Dez 2004, 23:29

Beitrag von andreasw »

Leider ist das nur ein Workararound, der das einfache rausziehen von usbsticks dann nicht mehr erlaubt, weil die Daten erst synchronisiert werden müssen.

Und es kann mir keiner erzählen, dass ein synchronisierter Zugriff nur so langsam möglich wäre, es ist vermutliche in Bug im Kernel.

mfg

Andy
Benutzeravatar
Pfalzwolf
Member
Member
Beiträge: 195
Registriert: 21. Jul 2005, 12:28
Wohnort: Pfalz, nahe SP
Kontaktdaten:

Verständnisfrage

Beitrag von Pfalzwolf »

Mein USB Stick wird nach der Aktion beim Einstecken automatisch erkannt und der Datentransfer funktioniert auch weiterhin in der hohen Geschwindigkeit. Die LED zeigt die Aktivität an. Wenn ich nun, wie in diesem Thread mehrfach angesprochen umount aufrufe, kommt die Meldung

Code: Alles auswählen

umount: fstab enthält /media/LEXAR_MEDIA nicht (Nur root kann es aushängen)
versuche ich nun umount unter root, werde ich wieder abgewiesen(2 Zeilen):

Code: Alles auswählen

umount: /media/LEXAR_MEDIA: device is busy
umount: /media/LEXAR_MEDIA: device is busy
busy, obwohl die LED konstant aus ist?
Darf der USB Stick nun nicht mehr während des Betriebes entfernt werden? Was wären die Folgen wenn ich ihn nun nach abgeschlossenem Datentransfers einfach heraus ziehe?
SuSE Leap 42.2|ASUS Prime X370-PRO|Ryzen 7 1700|GraKa:MSI GTX 1050 Ti|LAN: Intel I211AT Gigabit LAN | 4.4.70-18.9-default|KDE 5.8.6
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Verständnisfrage

Beitrag von misiu »

Pfalzwolf hat geschrieben: Darf der USB Stick nun nicht mehr während des Betriebes entfernt werden? Was wären die Folgen wenn ich ihn nun nach abgeschlossenem Datentransfers einfach heraus ziehe?
Normalerweise blinkt die LED sehr schnell während der Datenübertragung
, dann wenn die fertig ist blinkt langsam, oder hört auf (je nach Stick)
dann kann man den abziehen.
Sonst kannst du noch probieren über Arbeitsplatz, dein Wechselmedium
(Stick / usbdisk) , rechte Mastaste ->"Sicher entfernen" abzuhängen.

Oder mit "eject /media/usbdisk" aus der Konsole.

MfG
misiu
Benutzeravatar
Pfalzwolf
Member
Member
Beiträge: 195
Registriert: 21. Jul 2005, 12:28
Wohnort: Pfalz, nahe SP
Kontaktdaten:

eject klappt

Beitrag von Pfalzwolf »

Hi misiu,
das "sicher entfernen" klappt nicht, da kommt, dass man es unter root versuchen soll.

Herausziehen klappt. Dabei verschwindet auf der Arbeitsoberfläche das Symbol. [Edit] Natürlich nachdem die LED aus ist und man nach einer Weile davon ausgehen kann, dass alle Transfers abgeschlossen sind. Das rein physische Herausziehen geht natürlich immer :wink: [/Edit]

"eject" klappt.

Soweit alles ok, danke für die Hinweise.
Zuletzt geändert von Pfalzwolf am 14. Dez 2005, 19:34, insgesamt 1-mal geändert.
SuSE Leap 42.2|ASUS Prime X370-PRO|Ryzen 7 1700|GraKa:MSI GTX 1050 Ti|LAN: Intel I211AT Gigabit LAN | 4.4.70-18.9-default|KDE 5.8.6
andreasw
Member
Member
Beiträge: 76
Registriert: 12. Dez 2004, 23:29

Beitrag von andreasw »

Wie gesagt bei nicht synchroner Datenübertragung kann das einfache herausziehen gefährlich sein, weil er dann evtl nicht alles geschrieben hat.

mfg

Andy
Bea
Newbie
Newbie
Beiträge: 39
Registriert: 25. Feb 2005, 12:37

Beitrag von Bea »

Ich hatte dasselbe Problem mit meinem USB-Stick:
saulahm unter Suse 10.0

Ich hab dann auch diese Datei aus dem Link gebastelt.
Nungut, er ist zwar jetzt schneller wie 10kb/sec aber ca. 120kb/sec ist auch noch nicht der Bringer :(

Was hab ich falsch gemacht?


Edit:
Habs inzwischen so gemacht, wies in den Release-Notes steht.
Jetzt gehts.
Zuletzt geändert von Bea am 2. Feb 2006, 21:47, insgesamt 1-mal geändert.
taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin

Beitrag von taki »

Diese Frage stelle ich aus reiner Neugier.

Kann es sein, dass das Problem sich nur auf bestimmte USB-Geräte beschränkt? Zumindest scheint nur USB 1 betroffen zu sein.

Ich verwende über USB (2) eine Fotokamera (Lumix FZ20) und ein PMA (Archos AV420) an. Bei beiden ist der Durchsatz pfeilschnell. Zahlen hab ich jetzt nicht, aber als ich heute früh für den Weg zur und von der Arbeit eine CD als MP3-Verzeichnis auf meinen Archos kopierte, ging es so schnell, dass ich mich selbst gewundert hatte... Die Geräte werden bei mir vom SUSE-Plugger gemountet. Ich habe keine Einstellungen verändert und habe bisher mit dem Automounten noch keine Probleme feststellen können (ausser bei DVDs und Kaffeine, aber das ist ein völlig anders Thema).
SuSE 12.3 kernel 3.7.10-1.16-desktop, K Desktop Environment Version 4.10.5 r1 - Medion Titanium Aldi v. 03/2009
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Wenn man es beobachtet, wie sich das bei SuSE 9.3 / 10.0 verhaelt, kann ich nur
folgendes sagen:

1. Die meisten Probleme kommen bei Verwendung von mehreren USB-Massenspeichermedien.
Wenn diese nacheinander aneschlossen werden (am derselben USB-Anschluss)
oder gleichzeitig (z.B. USB-Stick und USB-Festplatte).

2. Es gibt Probleme bei gemischtem Betrieb von USB 1.0/1.1 und 2.0
USB-Massenspeichermedien. Nach entladen vom USB 2.0 - Modul geht es
dagegen in meisten Faellen problemlos.

3. Andere USB-Geraete , wie Drucker , Scanner bereiten eientlich recht wenig
Probleme, was zum Enderebnis fuehrt:
Es betrifft in den meisten Faellen nur Massenspeichermedien an USB-Anschluss.

MfG
misiu
felixr
Newbie
Newbie
Beiträge: 3
Registriert: 20. Aug 2004, 21:41
Kontaktdaten:

Re: Suse10---USB Transfarerate zu niedrig

Beitrag von felixr »

Habe mir den neuesten Patch für Submount über YOU runter geladen. Beschreibung:

"Dieses Update behebt Probleme mit der Schreibgeschwindigkeit auf Disketten und Zip-Medien. Diese werden nun mit der Option noatime und async gemounted (#130271). Mit diesem Paket wird das Mounten von DVD-RAM Medien geändert. Diese werden nun statt mit cdfss mit dem durch HAL erkannten Dateisystemen gemountet, da cdfss nur udf/iso9660 formatierten Medien behandeln kann (#131743). Zudem wurden Probleme beim Mounten Medien, die async und mit readonly eingehangen werden sollen , wie beispielsweise NTFS Partitionen, behoben (#137207)."

Version 0.9-80.2

Ich hatte davor den Release-Notes Trick angewandt, dass USB-Massenspeicher nicht mit sync eingebunden werden. Hatte auch gut funktioniert.

Was aber ein Problem war, ist das Ausbinden - geht unter KDE und Gnome nicht "...nur Root darf das aushängen etc."

Deshalb hoffte ich, dass dieser Patch das Problem mit sync behebt, so dass ein USB-Stift einfach raus gezogen werden kann.

Habe noch mal die Beschreibung gelesen und gesehen, dass dort einfach sync durch async ersetzt wird - leider wird das Problem dadurch nicht behoben. Habe in einem Forum gelesen, dass der Fehler im Kernel liegt und nicht an Submount etc.

Obwohl der Patch nicht das Sync-Problem löst, sollte er wenigstens USB-Massenspeicher per async einhängen. Leider wird mein USB-Stift weiterhin mit sync eingebunden.

Der Patch scheint nicht zu funktionieren. Hat den schon jmd. eingespielt und Ähnliches beobachtet?
Antworten