Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse 9.2 und firefox 106

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Mautzer
Newbie
Newbie
Beiträge: 6
Registriert: 29. Nov 2004, 18:11

Suse 9.2 und firefox 106

Beitrag von Mautzer »

Hi Leute,
ich werde hier gleich wahnsinnig. Ich versuche mich intensiv mit Suse zu beschäftigen, habe endlich herrausgefunden wie man Programme die man aus dem Internet gezogen hat installieren kann und nun erhalte ich immer den Fehler xpistub-bibliothek konnte nicht geöffnet werden.

Okay....die scheint es im System auch nicht zu geben ....aber wo denn?

Habe gelesen und nach RPM dateinen gesucht für meine 1.06 Firefox Version...nicht zu finden!

Helft bitte ehe ich wieder auf Windows wechsel


Mautzer
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

Firefox 1.06 kannst du dir als rpm für Suse 9.2 hier runterladen:
http://ftp.suse.com/pub/projects/mozill ... /9.2-i386/
"libxpistub.so" müsste in dem Paket enthalten sein.

Nimm mal das rpm aus dem besagten Link, installier es dir und teste es dann.

Installier ggf. mal über die Konsole mit

Code: Alles auswählen

rpm -Uhv MozillaFirefox-1.0.6-3.1.i586.rpm
und

Code: Alles auswählen

rpm -Uhv MozillaFirefox-translations-1.0.6-3.1.i586.rpm
Vielleicht kommen da Fehlermeldungen, mit denen man etwas anfangen kann.

Edit:
Zur Installation von Software schau mal hier:
http://www.linux-club.de/viewtopic.php?t=41353
Lesenswert mit weiteren Nachweisen. :wink:
Mautzer hat geschrieben:Helft bitte ehe ich wieder auf Windows wechsel
Das willst du doch nicht wirklich. :wink:
Aller Anfang ist schwer! Linux ist da keine Ausnahme. Wenn du dich aber durch die ersten Anfangsschwierigkeiten durchgebissen hast, macht es einfach grenzenlos Spaß!
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
Mautzer
Newbie
Newbie
Beiträge: 6
Registriert: 29. Nov 2004, 18:11

Beitrag von Mautzer »

Vielen Dank für den Link. Ich habe die Dateien geladen. Habe die Datei mit rechts angeklickt bin auf mit Yast installieren gegangen und Yast hat sich geöffnet.
Allerdings habe ich das Problem das meine rpm Datei nicht auftaucht und keine installation durchgeführt wird.
Gehe ich auf Datei importieren kann ich die rpm Datei suchen und auswählen.
Allerdings ist auch so eine installation nicht möglich denn es sucht automatisch Dateien mit der Endung *. sel.

Ich glaube ich habe einfach das Prinzip dwer installation mit Yast nicht verstanden.

Ich habe die Dateien doch auf meiner Festplatte. Bitte erklärt mir doch einmal wie ich diese nun mit Yast installiert bekomme.

Danke

Mautzer
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

Installier die Dateien erstmal über die Konsole.
Geh in das Verzeichnis, in dem sie liegen, melde dich mit su als root an und installier mit den Befehlen, die ich dir oben angegeben habe.
Allgemein:

Code: Alles auswählen

rpm -Uhv Paketname.rpm
An sich solltest die rpm's auch im Konqueror mit der rechten Maustaste anklicken können. Im nun geöffneten Fenster steht oben in der Mitte "Installiere mit YaST" (oder ähnlich). Wenn du das anklickst, sollte eigentlich installiert werden.

Edit: Ach ja, ich hatte da auch mal einen Fehler. Wenn in dem Verzeichnisnamen, in dem die rpm's liegen, irgendwo ein Leerzeichen war, ging es nicht (grafisch mit YaST). Kontrollier mal, ob da irgendwelche Leerzeichen sind.
Z.B.: /home/du/Downloads/hier Leerzeichen/
Mach lieber
/home/du/Downloads/hier_Leerzeichen/
Zuletzt geändert von Griffin am 13. Sep 2005, 18:56, insgesamt 1-mal geändert.
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
Mautzer
Newbie
Newbie
Beiträge: 6
Registriert: 29. Nov 2004, 18:11

Beitrag von Mautzer »

Habe den Befahl in der Konsole auch ausgeführt und folgende Meldung erhalten.


kbeisner@Papa:~/Programme> rpm -Uhv MozillaFirefox-1.0.6-3.1.i586.rpm
warning: MozillaFirefox-1.0.6-3.1.i586.rpm: V3 DSA signature: NOKEY, key ID 71423d59
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Die Operation ist nicht erlaubt (1)
error: cannot open Packages database in /var/lib/rpm
kbeisner@Papa:~/Programme>
towo
Moderator
Moderator
Beiträge: 3731
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo »

Mautzer hat geschrieben:Habe den Befahl in der Konsole auch ausgeführt und folgende Meldung erhalten.


kbeisner@Papa:~/Programme> rpm -Uhv MozillaFirefox-1.0.6-3.1.i586.rpm
warning: MozillaFirefox-1.0.6-3.1.i586.rpm: V3 DSA signature: NOKEY, key ID 71423d59
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Die Operation ist nicht erlaubt (1)
error: cannot open Packages database in /var/lib/rpm
kbeisner@Papa:~/Programme>
Programme darf nur Root installieren, ergo mußt Du vorher per su zu Root werden!

Ich empfehle Dir dringend, die Linux-Grundlagen zu erlernen!
Signatur nach Diktat spazieren gegangen

Bild
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

Griffin hat geschrieben:... melde dich mit su als root an und installier mit den Befehlen, die ich dir oben angegeben habe.
su
Passwort
rpm -Uhv ...
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
Mautzer
Newbie
Newbie
Beiträge: 6
Registriert: 29. Nov 2004, 18:11

Beitrag von Mautzer »

Du Hast recht und nachdem ich mich als root angemeldet habe hat es auch geklappt.
Zu Deinen Aussage das ich mich mit den Grundlagen befassen muss , da hast Du sicherlich recht aber wenn selbst das Michael Kofler Buch nicht weiterhilft dann sind doch solche Foren dafür da. Leuten die Hilfe brauchen diese auch zu gewähren....oder.

Mautzer
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

error: cannot get exclusive lock on /var/lib/rpm/Packages
Und lass yast geschlossen, während du über die Konsole installieren willst. Beides gleichzeitig geht nicht.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

Mautzer hat geschrieben:Du Hast recht und nachdem ich mich als root angemeldet habe hat es auch geklappt.
Zu Deinen Aussage das ich mich mit den Grundlagen befassen muss , da hast Du sicherlich recht aber wenn selbst das Michael Kofler Buch nicht weiterhilft dann sind doch solche Foren dafür da. Leuten die Hilfe brauchen diese auch zu gewähren....oder.

Mautzer
Genau! Lesen und lernen! Und wenn das nicht weiterhilft, fragen! :wink:
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Wobei im Kofler bestimmt die Installation per Kommandozeile erkläert ist. Hab das Ding jetzt gerade nicht in der Hosentasche, aber es steht bestimmt drin.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
nollsa
Advanced Hacker
Advanced Hacker
Beiträge: 1072
Registriert: 31. Mär 2004, 21:02
Kontaktdaten:

Beitrag von nollsa »

gut, dann dürfte ja alles gesagt sein. -> closed
Acer Aspire 5610
SuSE 10.3, KDE 3.5.5
Gesperrt