Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

HowTo für Dante??

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

HowTo für Dante??

Beitrag von Kasselhöfer »

Hallo,
obwohl es nicht im Squid geht, poste ich meine Frage hier. Kennt jemand ein HowTo für Dante/ Socks unter Suse 9.3 kennt?
Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

Beitrag von Falkenstein »

Vielleicht ist da was für dich dabei: :)
http://www.inet.no/dante/
http://www.socks.nec.com/
http://www.google.com/linux?q=(dante,so ... &oi=lrtip9
man socks
man socks.conf
/usr/share/doc/packages/dante/README
/usr/share/doc/packages/dante-server/README
http://linux.cudeso.be/linuxdoc/dante.php

Viel mehr gibts, glaub ich, gar nicht.
http://lists.suse.com/archive/suse-linu ... /2680.html
Zuletzt geändert von Falkenstein am 17. Okt 2005, 21:45, insgesamt 1-mal geändert.
Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

Beitrag von Kasselhöfer »

Gut. Dann werde ich mir mal die Seiten anschauen.
Jetzt habe ich mal wieder eine dumme Frage :oops: . Zur Zeit habe ich Squid als Proxy mit Auth.. laufen, Wird der Socks-Proxy parallel zu Squid betrieben, oder wird Squid deaktiviert und der Socks-Proxy ersetzt diesen?

Sorry wegen der Frage :?
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4327
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Beitrag von framp »

Es ist kein Problem beide parallel zu betreiben. Socks nutzt ueblichweise Port 1080. Proxy ueblicherweise 8080 oder 3128.
Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

Beitrag von Kasselhöfer »

Hallo,
leider komme ich mit Dante/Socks weiterhin nicht ganz klar.

Ich möchte nochmal darstellen, warum ich einen Dante-/ Socks-Proxy aufsetzen möchte. Seit dem ich einen Squid-Proxy aufgesetzt habe, komme ich mit meiner Bank-Software Wiso Mein Geld nicht mehr ins Internet. Grund hierfür ist, dass ich alle Ports in der Suse-Firewall geschlossen habe und nur noch über Squid mit Auth.. ins Internet wollte. Leider habe ich nicht bedacht, dass meine Banksoftware noch weitere Ports benötigt als nur die für das surfen im Internet. Nun habe ich mal in der Bank-Software gestöbert, und bemerkt, dass man dort einen Socks-Proxy mit Auth.. einstellen kann. Daher möchte ich einen solchen nun aufsetzen.
Zu Testzwecken habe ich noch nicht die Auth... aktiviert. Trotzdem funktioniert der Socks-Proxy noch nicht so wie ich möchte, da ich mit der Bank-Software weiterhin noch nicht ins Internet komme.

Hier nun meine sockd.conf:

logoutput: syslog /var/log/dante/sockd.log
internal: 192.168.1.100 port = 1080
external: 192.168.0.1
method: none
clientmethod: none
#user.privileged: sockd
#user.notprivileged: sockd
#user.libwrap: libwrap
compatibility: sameport
#extension: bind
connecttimeout: 90
iotimeout: 0
srchost: nounknown
#####################################################################
######################## "client" rules.#############################
#####################################################################
#--------------------------------------------------------------------
######################### welche clients ############################
#--------------------------------------------------------------------
client pass {
from: 192.168.1.0/24 port 1-65535
to: 192.168.1.100/24
method: none
}
# keine sonstigen Clients erlauben
client block {
from: 0.0.0.0/0 to: 0.0.0.0/0
log: connect error
}
#--------------------------------------------------------------------
######################## welche Dienste #############################
#--------------------------------------------------------------------
# loopback am Server
block {
from: 0.0.0.0/0 to: 127.0.0.0/8
log: connect error
}
block {
from: 0.0.0.0/0 to: 0.0.0.0/0
command: bind
log: connect error
}
#-------------------------------------------------------------------
################### Erlaubt ########################################
#-------------------------------------------------------------------
# "active" ftp uses it.
pass {
from: 0.0.0.0/0
to: 192.168.1.0/24
command: bindreply udpreply connect
log: connect error
}
pass {
from: 192.168.1.0/24
to: 0.0.0.0/0 port = domain #192.168.1.100/24 port = domain
method: none
log: connect error
}
# alle clients duerfen surfen
# da bin ich noch am arbeiten
pass {
from: 192.168.1.0/24
to: 0.0.0.0/0 port = http
log: connect error
method: none
}

#--------------------------------------------------------------
####################### tcp,udp Erlaubt #######################
#--------------------------------------------------------------
pass {
from: 192.168.1.0/24 to: 0.0.0.0/0
protocol: tcp udp
method: none
log: connect error
}
# den rest sperren
block {
from: 0.0.0.0/0 to: 0.0.0.0/0
log: connect error
}

und meine socks.conf:

resolveprotocol: udp
#resolveprotocol: tcp
#resolveprotocol: fake
#-----------------------------------------------------------------
######################### ueber DNServer #########################
#-----------------------------------------------------------------

route {
from: 0.0.0.0/0
to: 192.168.0.2/24 port = domain
via: direct
}
#-------------------------------------------------------------
######################## loopback direct #####################
#-------------------------------------------------------------

route {
from: 0.0.0.0/0
to: 127.0.0.0/8
via: direct
command: connect udpassociate
}
#-----------------------------------------------------------
################### internes netzwerk ######################
#-----------------------------------------------------------
route {
from: 0.0.0.0/0
to: 192.168.1.0/24
via: direct
}

route {
from: 192.168.1.0/24
to: 0.0.0.0/0
via: 192.168.1.100 port = 1080
protocol: tcp udp
proxyprotocol: socks_v4 socks_v5
method: none
command: connect
}
route {
from: 192.168.1.0/24
to: 0.0.0.0/0
via: 192.168.1.100 port = 1080
protocol: tcp udp
proxyprotocol: socks_v4 socks_v5
command: connect
method: none
log: connect error
}
#das ist erstmal nicht so wichtig ich versuche ob ich über den socks auch
#sürfen kann aber mit dem protocol http weiß ich nicht ob der server das
#unterstützt fals einer eine ide hat, bin ich dafür sehr dankbar
#route {
# from: 0.0.0.0/0
# to: .
# via: 192.168.1.3 port = 1080
# protocol: tcp udp
# proxyprotocol: socks_v4 socks_v5
# method: none
#}
#route {
# from: 192.168.1.6/24 to: 0.0.0.0/0 via: 192.168.1.3 port =
# command: connect
# proxyprotocol: http_v1.0
# method: none
#}
#
#route {
# from: 192.168.1.6/24 to: . via: 192.198.1.3/24 port = 1080
# command: connect
# proxyprotocol: http_v1.0
# method: none
#}
###############################################

Die sockd.conf und die socks.con habe ich in Anlehnung an folgendem Posting erstellt
http://www.linux-club.de/viewtopic.php? ... ight=dante

Was könnte ich noch falsch bzw. nicht eingestellt haben

Kasselhöfer
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4327
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Beitrag von framp »

Es ist also so, dass Du einen WIN Rechner mit BankSW hast, dem man sagen kann einen Socks zu benutzen oder? BankSW fuer Linux kenne ich jedenfalls noch nicht. Die sind immer so konservativ :-)
Dann verstehe ich nicht, wieso Du den Router socksified hast (socks.conf)? Das bring nichts da wenn socksifien, dann haette der BankSW Clients socksified werden muessen. (Geht uebrgens mit dem Hummingbird socks - kostenlos!)
Aber auch das brauchst Du nicht. Wenn es moeglich ist in der BankSW einen Socks einzutragen braucht der Client nicht socksified zu sein.

Der socks server schreibt access logs in /var/log/sockd/sockd.log. Sieh mal nach was da passiert. Ist da noch was geblocked? Nach Deiner sockd.conf sollte das eigentlich nicht sein.
Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

Beitrag von Kasselhöfer »

Sorry, ist ein Windows XP Rechner.
habe nun socks.conf wieder in die Standart-Datei umgewandelt. Somit ist dort nichts aktiviert. In der log-Datei von sockd bekomme ich nach einem Restart des Socks-Servers folgendes eingetragen:.

Oct 14 19:53:13 sockd[13459]: sockdexit(): terminating on signal 15
Oct 14 19:53:13 sockd[13465]: recv_io(): recvmsg(): Bad file descriptor (errno = 9)
Oct 14 19:53:13 sockd[13511]: fixsettings(): setting the unprivileged uid to 0 is not recommended
Oct 14 19:53:13 sockd[13513]: created new negotiatorchild
Oct 14 19:53:13 sockd[13516]: created new requestchild
Oct 14 19:53:13 sockd[13517]: created new requestchild
Oct 14 19:53:13 sockd[13518]: created new requestchild
Oct 14 19:53:13 sockd[13519]: created new requestchild
Oct 14 19:53:13 sockd[13520]: created new iochild
Oct 14 19:53:13 sockd[13512]: dante/server v1.1.14 running

Sonst nichts. Auch wenn ich mit der Banking-Software versuche ins Internet zu gehen.

Etwas scheint da nicht ganz zu laufen. Was muß mit Bind gemacht werden. Zur Zeit ist mein DNS-Server mein Hardware-Router (IP 192.168.0.2). Des weiteren ist mir nicht ganz klar welchen Socks-Server ich eingebunden habe (4, 4a oder 5). Muß ich in der Banking-Software einstellen.
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4327
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Beitrag von framp »

Entweder ist die Einstellung im WIN bzgl Socks falsch oder es steht nicht

Code: Alles auswählen

log: connect error
in jeder Anweisung.

DNS ist hier egal.

dante ist sowohl socks 4 als auch 5. Was 4a ist weiss ich nicht.

Lass doch mal tcpdump auf der Router laufen. Also etwa

Code: Alles auswählen

tcpdump -i ethx -n host a.b.c.d
wobei Du natuerlich ethx und a.b.c.d mit den richtigen Werten setzen musst.
Dann sieht man mal was Dein Client beim Verbindungsaufbau fuer Ports benutzt.
Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

Beitrag von Kasselhöfer »

Jetzt muß ich leider etwas dumm fragen:

ethx (interne- oder externe-Netzwerkkarte?) a.b.c.d (Server-IP oder Client-IP?)

Muß ich bei Win unter Internetoptionen auch den Socks eintragen?

Zur Sicherheit. Der Socks wird mit rcsockd start gestartet, oder?
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4327
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Beitrag von framp »

Kasselhöfer hat geschrieben:ethx (interne- oder externe-Netzwerkkarte?) a.b.c.d (Server-IP oder Client-IP?)
ethx - intern
a.b.c.d - Client-IP
Muß ich bei Win unter Internetoptionen auch den Socks eintragen?
Sollte nicht notwendig sein.
Zur Sicherheit. Der Socks wird mit rcsockd start gestartet, oder?
ja
Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

Beitrag von Kasselhöfer »

Mit der Eingabe von

Code: Alles auswählen

tcpdump -i ethx -n host a.b.c.d
komme ich nun leider nicht ganz klar. Wie soll ich die fortlaufende Anzeige deuten?

Des weiteren, mir kommt es vor, dass mein Windows Client gar nicht auf den Socks zugreifen kann. Meine interne Netzwerkkarte ist ja als Intern in der Suse Firewall eingestellt. Die externe als Extern. Somit kann es ja nicht an der Suse Firewall liegen. Oder?
Wie kann testen, ob der Client überhaupt auf den Socks zugreift. Gibt es hier eine Log-Datei?
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4327
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Beitrag von framp »

Kasselhöfer hat geschrieben:Wie kann testen, ob der Client überhaupt auf den Socks zugreift.
Mit tcpdump wie oben angegeben. Da siehst Du wer auf welchen Port zugreift. :roll:
Gibt es hier eine Log-Datei?
Das Ziel ist in /etc/sockd.conf definiert. Bei mir steht z.B. logoutput: /var/log/sockd/sockd.log 8)

Code: Alles auswählen

18:48:27.178842 IP 192.168.0.1.22 > 192.168.0.6.32786: P 159264:159440(176) ack 193 win 2728 <nop,nop,timestamp 5984405 788543>
zeigt dass der Client 192.168.0.1 auf Port 22 etwas an CLient 192.168.0.6 Port 32786 gesendet hat.
Antworten