Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Kein Sound von Audio CDs unter SuSE 9.2

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Tiikeri
Newbie
Newbie
Beiträge: 15
Registriert: 6. Feb 2005, 11:17
Wohnort: Schweden

[solved] Kein Sound von Audio CDs unter SuSE 9.2

Beitrag von Tiikeri »

Hi!
Wenn ich eine AudioCD unter zB Kscd abspiele, wird sie zwar gespielt (sprich die Zeit im Playfenster läuft), aber es kommt nichts aus den Lautsprechern.
1) CD-Audio ist nicht auf mute;
2) weder Alsa noch OSS helfen;
3) Audiokabel von CDROM ist auch an Soundkarte angeschlossen.
Ich denke, dass es kein Hardwareproblem ist, da es unter Windoofs funktioniert. Bin etwas ratlos ... sonstige Soundwiedergaben (mp3, DVD, etc) funktionieren.
Tschö! Tiggers
Zuletzt geändert von Tiikeri am 7. Sep 2005, 22:10, insgesamt 1-mal geändert.
BildBild
Caput
Member
Member
Beiträge: 149
Registriert: 2. Jun 2005, 21:14
Wohnort: Mindelheim

Beitrag von Caput »

versuchs mal mit kaffeine abzuspielen!
bei mir gings dann!
Benutzeravatar
Tiikeri
Newbie
Newbie
Beiträge: 15
Registriert: 6. Feb 2005, 11:17
Wohnort: Schweden

Beitrag von Tiikeri »

caput hat geschrieben:versuchs mal mit kaffeine abzuspielen!
bei mir gings dann!
Bei mir geht's so auch ... aber warum ?!? :shock: Wieso kann Kaffeine (bzw. die xine-lib) die Audio-CDs abspielen, aber ein "normaler" CD-Spieler nicht ???
Danke für den Tipp! :D
BildBild
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Habe das Problem auch.
Weder kscd noch amarok spielen Audio-CDs ab. D.h. abspielen tun die es wohl, aber ich höre nichts. Mit kaffeine tönt es dann auch aus den Lautsprechern. Kaffeine holt auch bei freecddb die Daten für die CD ab, das tun die anderen Player auch nicht.
Keiner 'ne Idee warum das so ist?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

aus einem anderen Forum (http://www.linuxquestions.org/questions/history/369659)
just encountered and solved the same problem, I think. I could play MP3s and other media from my disk, but I couldn't get any sound from an audio CD when I put one in. KsCD would pop right up and "play" the CD, but no sound. After a bit of experimentation, I found that if I simply killed KsCD, clicked the My Computer icon that SuSE 9.3 puts up on its default KDE desktop, then right clicked the "Audio CD" item and selected "Play with Kaffeine", it worked just great. Instant sound! So, I then did a "ps -ef" to see what command was running Kaffeine, so I could see how it was identifying the drive to play from. It was "media:/hdc". Not entirely obvious...

So, open up KsCD and go to the Extras menu at the lower right of the window. Select "Configure KsCd" and then find the area in the resultant config settings window called "CD-ROM Device". This is set to "/dev/cdrom" by default. To make your audio CDs play correctly, change it to "media:/hdc". In this case, my CD-RW drive is hdc, and so I have used "media:/hdc". If your CD drive was hdb, you would instead use "media:/hdb". Basically, use "media:/hd[your_cd_rom_letter]

Now pop an audio CD into the drive. KsCD should start up automatically, and you should now be rewarded with your favorite tunes. Good luck!
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Geht auch nicht. Keine Rechte.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
FreakOfNature
Member
Member
Beiträge: 54
Registriert: 17. Apr 2005, 00:35

Beitrag von FreakOfNature »

Ich hab' genau das gleiche Problem wie ihr - Kaffeine scheint das einzige Programm zu sein, das CDs abspielt. Der Tip mit dem umstellen des Device hat auch nix genützt. Ich hoffe, daß dieses Problem demnächst noch gelöst werden kann...
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Für mich die Lösung:
Mit 'alsamixer' den Regler für capture hochziehen. Ich höre gerade über ksCD wieder eine Audio-CD. *freu*
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
alexb
Newbie
Newbie
Beiträge: 1
Registriert: 9. Nov 2005, 21:32

Beitrag von alexb »

Ein bisschen Off-Topic, aber das gleiche gilt auch beim Abspielen von DVDs. Wenn man in den xine-Engine-Parametern das DVD-Medium von /dev/dvd auf /dev/hdx stellt funktionierte es auch mit der Soundausgabe beim Anschauen von DVDs.

(Für Suchmaschinen: Unter Kaffeine kein Sound beim Abspielen von einer DVD)
Antworten