Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Soundblaster USB Audigy 2NX schweigt

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

[solved] Soundblaster USB Audigy 2NX schweigt

Beitrag von shattered »

Seltsam...

Sowohl in kamix als auch kmix richtig erkannt.

Channel ist auf Audigy 2NX, amaroK spielt zwar Musik ab, aber hören tu ich nichts.

Mute ist nicht an.

Auf Kanotix funzt diese Soundkarte, die LEDs leuchten genau gleich, Einstellungen sind auch gleich.

Die Suchfunktion erzählt mir, dass Suse und Audigy offensichtlich Probleme macht.

Kennt wer eine Lösung?

KDE 3.4.2, neustes ALSA, das im APT ist, Suse 9.3! :roll:
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Ich habe nun auch noch Google gequält, aber keine Hilfe gefunden.

Komischerweise wird die Karte zwar angezeigt und richtig erkannt, ist aber in Yast nicht konfiguriert und lässt sich dort auch nicht konfigurieren...

Uhm? :roll:
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Sorry, nochmals ich.

Es handelt sich um diese Soundkarte, vielleicht hilft das:

*click*

Edit: Offensichtlich hat sie unter Suse 9.1 mal funktioniert:

*click*

Code: Alles auswählen

hsgpublicnet41:/home/fish # lsusb
Bus 001 Device 002: ID 041e:3020 Creative Technology, Ltd SoundBlaster Audigy 2 NX
Bus 001 Device 001: ID 0000:0000
hsgpublicnet41:/home/fish # cat /proc/asound/cards
--- no soundcards ---
hsgpublicnet41:/home/fish # lsmod | grep snd
snd_pcm_oss            57888  0
snd_pcm                92680  1 snd_pcm_oss
snd_timer              24580  1 snd_pcm
snd_mixer_oss          18944  1 snd_pcm_oss
snd                    60292  4 snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
snd_page_alloc          9988  1 snd_pcm
soundcore               8928  1 snd
Wo bekomme ich denn den snd-usb-audio Treiber für Suse 9.3?

Habe die Original CDs gerade zu Hause und nicht hier...
Zuletzt geändert von shattered am 8. Sep 2005, 09:16, insgesamt 1-mal geändert.
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Weiss wirklich niemand Rat? :roll:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16636
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois »

Hi

Hast du auch in Yast - Hardware - Soundkarte-alles ausgereizt.

Vielleicht liegt da der Fehler ?

Ich habe Audgy 2 auch laufen ohne Probleme.

Noch was es gibt einige Lösungs Möglichkeiten hier hast du mal die SuFu gebraucht :wink:
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Ja, SuFu habe ich gebraucht, steht ja oben... :wink:

Ich sehe bis jetzt KEINE Lösungsmöglichkeit.

Wie schon gesagt, die Karte lässt sich in Yast nicht konfigurieren (NX kann ich da nicht auswählen, nur Audigy 2, das klappt aber nicht) und sie erscheint in Yast nicht. Sie wird aber offensichtlich erkannt und wird mir auch angezeigt, siehe oben!

Wie weiter? :roll:
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Ich sehe schon, das ist wohl aussichtlos... :cry:
seuchato
Newbie
Newbie
Beiträge: 8
Registriert: 10. Sep 2005, 15:59

vielleicht doch...

Beitrag von seuchato »

versuch mal das:

http://www.linuxquestions.org/questions/history/204642

PS: habe das gleiche Problem, bin aber noch nicht dazu gekommen obiges zu prbieren
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Es funzt nun!

(suse 10.0 rc1)

Allerdings nur, wenn ich die on-board Soundkarte deaktiviere! :roll:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

stokedfish: Das ist ja auch eine nicht so glückliche Idee, beide Soundkarten gleichzeitig zu betreiben. Warum sollte man das tun?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Warum nicht?

Für irgendwas erlaubt KMix ja einen Wechsel der Soundkarte und unter Kanotix funktioniert das problemlos...

(ich weiss z.B. nicht, ob ich mein Mik mit der Audigy verwenden kann, muss mal testen) 8)
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

So, nach dem es "funzte" kam auch gleich die grosse Ernüchterung.

Ich habe gerade was dazu auf ubuntuusers.de gepostet und möchte es den Suse NX Benutzern nicht vorenthalten.

*copy'n'paste*

Okay, die ganze Nacht durchgebastelt, das Teil läuft!

Allerdings nur auf Suse 10.0, nicht bei (K)Ubuntu, Yast sei Dank.

Erstmal, obige Tips haben leider alle nicht geholfen. Wie schon gesagt, den onboard Sound kann ich leider NICHT im Bios deaktivieren, da lässt sich wohl nichts machen. Das mit der /etc/hotplug/blacklist klappt vielleicht, bei mir allerdings nicht! :roll:

Ich möchte die Lösung trotzdem hier erläutern, auch wenn ich es nur auf Suse zum laufen gebracht haben.

Mit der Karte gibt es 2 Probleme:

1. Wenn der Onboard Sound aktiviert ist, läuft sie nicht
2. Wenn der Onboard Sound deaktiviert ist, läuft sie zwar, tönt aber miserabel (Knacksen!)

Zum 1. Problem:

Ich konnte es nur auf Suse lösen ---> in Yast onboard Soundkarte löschen, dann ist das Problem erledigt.

Lasst euch nicht von den Einstellungen in Mixer wie kmix, alsamixer und so täuschen, die bringen alle nichts - selbst wenn der "channel" auf Audigy NX steht, läuft weiterhin der Onboard Sound. Ihr MÜSST ihn deaktivieren, anders geht es nicht!

Es kann sein, dass es eine andere Lösung gibt, auf der ALSA Seite wird erklärt, wie man 2 Soundkarten gleichzeitig betreiben kann, das habe ich auch versucht umzusetzen, bin aber gescheitert.

Zum 2. Problem:

Wenn ihr das erste gelöst habt, wird die Freude gleich wieder getrübt. Die Soundausgabe hat ein nervtötendes Knacksen und ist schlicht ungeniessbar. Ich habe endlos rumgebastelt, bis ich das Teil zum Laufen gebracht habe.

Ihr müsst folgende Datei anlegen im HOME Verzeichnis, wohl egal auf welcher Distri.

.asoundrc (mit dem Punkt, ist eine versteckte Datei, sie muss in /home sein)

Code: Alles auswählen

pcm.dmixer {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:1,0"
	period_time 0
	period_size 1024
	buffer_size 8192
    rate 48000
     }

     bindings {
         0 0
	 1 1
     }
}

pcm.dmixer {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
	period_time 0
	period_size 1024
	buffer_size 8192
    rate 48000
     }

     bindings {
         0 0
	 1 1
     }
}

pcm.dsp0 {
    type plug
    slave.pcm "dmixer"
}

pcm.dsp1 {
    type plug
    slave.pcm "dmixer"
}

pcm.!default {
        type plug
	slave.pcm "dmixer"
}

pcm.default {
   type plug
   slave.pcm "dmixer"
}

ctl.mixer1 {
    type hw
    card 1
}

ctl.mixer0 {
    type hw
    card 0
}
Eigentlich war es mein Ziel, mit obiger ALSA Konfiguration beide Soundkarten "gleichzeitig zu benutzen" - wenn die USB Karte angesteckt ist, wird sie genutzt, sonst läuft der Onboard-Sound - das funktioniert aber leider nicht. Obwohl tatsächlich automatisch der USB Channel angewählt wird, wenn ich sie angesteckt habe, höre ich keinen Sound.

Nun gut, wenn der Onbaord Chip deaktiviert ist, funktioniert obige Konfiguration!

Ihr könnt sie beliebig abändern und rumexperimentieren, Angaben dazu findet man auf der ALSA Homepage:

http://www.alsa-project.org/

(guckt auch ins Archiv der Mailingliste oder fragt gar darauf nach wenn ihr verzweifelt)

Damit bringt meine Karte nun einen klaren Ton hin, ohne Knacksen. Getestet habe ich mit amaroK und der xine engine!

Das Problem ist, dass die Karte standardmässig nicht sauber funktioniert, weil irgendetwas mit der "sampling rate" nicht passt (44,1 kHz vs 48.0 kHz) - obige config zwingt die Audigy dazu, alles in 48,0 kHz auszugeben, nur so bringt sie einen knacksfreien Sound.

Wenn ihr immer noch Probleme habt, versucht (als KDE Benutzer) folgendes:

- KDE Sound System ausschalten
- oder zumindest bei --> Kontrollzentrum --> Sound System --> Hardware die "sampling rate" auf 48,0 kHz forcieren

Hier noch 2 "kuriose" Tipps aus dem Netz:

- schliesst die Karte wenn möglich nicht über einen PCMCIA USB-Hub an, sondern direkt beim Laptop Anschluss
- angeblich soll es etwas bringen, die Karte unter Windows anzuschliessen, sie spiele dann ein Treiber Update auf die Karte ein, womit sie auch unter Linux besser laufen soll

(ich glaub da nicht so recht dran) :wink:

Aber, macht am einfachsten folgendes: FINGER WEG VON DER AUDIGY SOUNDBLASTER NX USB!!!

Kauft euch gleich eine andere Soundkarte...

Nochmals Danke an alle, die mir in diesem Beitrag versucht haben zu helfen.

Nun gut, ich habs geschafft, hier läuft gerade Conjure One, glasklar, und ich bin glücklich - redemption! :D
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered »

Ich habe soeben rausgefunden, wie man die NX auch auf Kubuntu zum laufen kriegt!

In der /etc/modprobe.d/alsa-base folgende Zeile ergänzen:

Code: Alles auswählen

# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-via82xx index=-2
Die meisten Werte für euer System sollten schon drin sein, wenn ihr die Datei öffnet, nur die des on-board sounds fehlen.

Ich musste also nur noch options snd-via82xx index=-2 ergänzen.

Die Option verhindert, dass sich der on-board chip die Soundausgabe kapert! :D
Antworten