Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

CDs werden nicht gelesen und hängen im Laufwerk fest

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Palantir
Newbie
Newbie
Beiträge: 9
Registriert: 22. Aug 2005, 15:06

CDs werden nicht gelesen und hängen im Laufwerk fest

Beitrag von Palantir »

Hallo!
Ich besitze ein DVD Laufwerk (Sony ) und einen DVD Brenner (BenQ DW1640). Lege ich nun in das Laufwerk (egal welches) eine CD (Audio/Daten CD) ein, dann kommt es in 1 von 3 Fällen dazu, dass die CD nicht gelesen wird und im Laufwerk festhängt. Ich kann zwar mount/umount Befehlen bringt aber nichts (Daten werden nicht eingebunden). eject funktioniert nicht. Die Tasten am Laufwerk ebenso. AudioCDs werden in 1 von 2 Fällen gar nicht richtig behandelt. Teilweise stürzt KsCD beim CD wechseln ab.
Ich muss also immer mal den Rechner herunterfahren und neustarten, um die CD wieder zu entfernen und das Laufwerk zu öffnen und wieder freizugeben.

Bei dem neueren DVD Brenner ist es teilweise noch möglich die Klappe wieder zu öffnen und er gibt sie freiwillig wieder frei, aber bei dem älteren Sony DVD geht gar nichts mehr. Das System verliert ebenfalls an Performance und hängt schubweise.

Liegt es am System oder könnte es auch ein Laufwerkshardwareproblem sein?

Hier sicherheitshalber die fstab, bei der ich mir nicht sicher bin, ob die so stimmt (hab versuchsweise leicht abgewandelt nach Forumsbeiträgen)
/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda1 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hda3 /windows/C ntfs ro,users,exec,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5 /windows/D ntfs ro,users,gid=users,umask=0002,utf8=true 0 0
/dev/hda6 /windows/E ntfs ro,users,gid=users,umask=0002,utf8=true 0 0
/dev/hda7 /windows/F vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/dvdrecorder /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Dankeschön

Palantir
Palantir
Newbie
Newbie
Beiträge: 9
Registriert: 22. Aug 2005, 15:06

Beitrag von Palantir »

Kann jemand einfach bitte die fstab schnell überfliegen und sagen, ob es daran liegt und einfach nur ein Parameter geändert werden muss oder ob es an etwas anderem liegen kann/muss...

Unter Windows läuft das Laufwerk einwandfrei, jedenfalls bis jetzt keinen Fehler gehabt.



DAAAAAANKE!!!
Benutzeravatar
Fytzi
Hacker
Hacker
Beiträge: 305
Registriert: 1. Aug 2004, 17:14
Kontaktdaten:

Beitrag von Fytzi »

Die fstab sieht in Ordnung aus. Daher muss es an etwas anderem liegen. Vielleicht wird der Controller einfach nicht richtig erkannt und daher wird das Laufwerk nicht richtig angesprochen.
There are only 10 types of people in the world: those who understand binary and those who don't.
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4423
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 »

Moin Palantir,

setz mal in der fstab statt der symlinks die echten Devices ein. Ansonsten: hängen beide Laufwerke an einem Kontroller? Was für Kabel verwendest Du für deine Laufwerke?
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
Antworten