Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Drucker oder USB Problem?

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Monstera
Newbie
Newbie
Beiträge: 16
Registriert: 31. Aug 2005, 23:19

Drucker oder USB Problem?

Beitrag von Monstera »

Hallo, ich habe einen AMILO A7645 Notobook. SUSE 9.3 will meinen Deskjet 930c am USB anschluss nicht erkennen. Wenn ich den Drucker anschließe, erhalte ich in der Systemlog folgende mitteilung:

09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 6
09/02/05 16:44:58 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 7
09/02/05 16:44:58 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 8
09/02/05 16:44:59 linux kernel usb 1-1: device not accepting address 8, error -110
09/02/05 16:44:59 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 9

Ich habe leider noch nicht die Ahnung diese Angaben zu bewerten. Gibt es ein Problem und wenn ja welches?

Wenn ich den Drucker über Yast von Hand installieren will sagt mir Yast das mein USB evtl. nicht richtig funktioniert. Eine Knoppix LiveCD hat den Drucker schonmal erkannt. Windows XP erkennt ihn allerdings auch nicht. -> Unbekanntes Gerät und will nichma Treiber haben...

Vielen Dank für eure Hilfe

Monstera
Monstera
Newbie
Newbie
Beiträge: 16
Registriert: 31. Aug 2005, 23:19

Beitrag von Monstera »

Ich habe jetzt noch zwei andere USB Geräte ausprobiert. Diese werden von Linux problemlos erkannt. Die USB treiber scheinen also i.O. sein...
Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2484
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Beitrag von TomcatMJ »

Hi!
"Fullspeed" im log hört sich nach usb 1.1 an,bei usb 2.0 sollte da eigentlich "highspeed" stehen wenn ich mich recht entsinne.
Ich hatte neulich auch ein ziemlich bescheuertes Problem mit meinem Epson R300 USB-Drucker. Er druckte kurz nach neustart des CUPS-Servers genau einen druckauftrag udn beim zweiten ein paar Minuten später war der Drucker nicht mehr ansprechbar. Nach einiger Testerei fand ich heraus, daß dies schlichtweg am USB-Kabel lag. Der USB-Drucker konnte USB2.0, der Rechner ebenso aber das Kabel war leider einfach nur ein IUSB-Kabel ohne explizite Bezeichnung ob 1.1er oder 2.0er USB. Also hab ich mir ein explizites USB 2.0 Kabel besorgt,ausgetauscht und siehe da: Problem erledigt. Dürfte also vermutlich ein Abschirmungsproblem gewesen sein, das sauberen Datentransfer verhindert hatte. USB 2.0er Kabel sind definitiv besser abgeschirmt als die alten 1.1er, von daher würd ichs mal an deiner stelle mit einem Kabeltausch probieren wenn dein Rechner und dein Drucker beide USB 2.0 können.

Bis denne,
Tom
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4019
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Drucker oder USB Problem?

Beitrag von misiu »

Monstera hat geschrieben:Hallo, ich habe einen AMILO A7645 Notobook. SUSE 9.3 will meinen Deskjet 930c am USB anschluss nicht erkennen. Wenn ich den Drucker anschließe, erhalte ich in der Systemlog folgende mitteilung:

09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: device descriptor read/64, error -110
09/02/05 16:44:58 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 6
09/02/05 16:44:58 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 7
09/02/05 16:44:58 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 8
09/02/05 16:44:59 linux kernel usb 1-1: device not accepting address 8, error -110
09/02/05 16:44:59 linux kernel usb 1-1: new full speed USB device using ohci_hcd and address 9

Ich habe leider noch nicht die Ahnung diese Angaben zu bewerten. Gibt es ein Problem und wenn ja welches?

Wenn ich den Drucker über Yast von Hand installieren will sagt mir Yast das mein USB evtl. nicht richtig funktioniert. Eine Knoppix LiveCD hat den Drucker schonmal erkannt. Windows XP erkennt ihn allerdings auch nicht. -> Unbekanntes Gerät und will nichma Treiber haben...

Vielen Dank für eure Hilfe

Monstera
Hast du die andere Anschlussbüchse probiert?
Ist USB-Hub dazwischen?
Was sagt KDE->Infozentrum->USB? (Ist der Drucker da?)
(evtl. usbview nachinstallieren)
in der Textkonsole:
Was liefert

Code: Alles auswählen

su + rootpasswort
/sbin/lsusb
?
MfG
misiu
P.S. Habe auch SuSE9.3 und HP930c : läuft prima .

P.S.2.

USB gibts als 1.1
und
USB 2 Fullspeed (ist nichts anderes , alsUSB1.1)
oder Highspeed (volle USB2-Geschwindigkeit)
Antworten