Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Profile für Win-XP pro werden nicht gespeichert

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
renate

Profile für Win-XP pro werden nicht gespeichert

Beitrag von renate »

HI,
ich habe das Problem, dass die Benutzerprofile nicht gespeichert werden.

System: SuSE9.2pro mit Samba-3.0.9-2.3 als PDC
An diesem Server melden sich 30 WIN-XPpro Rechner an.

Bei einigen Benutzern kommt folgende Fehlermldung:

Code: Alles auswählen

Das servergespeicherte Benutzerprofil wurde nicht geladen. Sie werden mit einem lokalen Benutzerprofil angemeldet. Ändeungen an dem Profil werden nach der Abmeldung nicht auf den Server kopiert.
Das Profil wurde nicht geladen, weil eine bereits vorhandene Serverkopie des Profilnamens nicht die richtigen Sicherheitseinstellungen besitzt. Entweder muss der aktuelle Benutzer oder die Administratorengruppe Besitzer dieser Domäne sein.
Wenden Sie sich an den Netzwerkadministrator.
Ich habe aber noch einen Rechner mit Win2000pro laufen. Auf diesem klappt die Anmeldung aber dieser User einwandfrei.

Bei anderen Benutzern klappt die Anmeldung ohne Fehlermeldung, eine Profil wird aber nicht abgespeichert. Angelegt ist es aber sehr wohl. Ein Laufwerk X:, welches das jeweilige Linux-Homedirectory ist, ist vorhanden. Bei dem Win2000pro-Rechner ist dieses Laufwerk X: aber nicht vorhanden.

Ich habe die Zugriffsrechte auch schon geändert:

Code: Alles auswählen

linux:/var/lib/samba/profiles/anneke # ls -ls
total 914
  1 drwxrwx---+ 14 anneke users    560 Sep  1 19:10 .
  0 drwxrwx---   8 root   users    192 Sep  1 18:37 ..
132 -rw-------   1 anneke users 131567 Aug 10 12:36 .fonts.cache-1
  1 drwx------+ 21 anneke users    896 Aug 10 12:43 .gimp-2.2
  0 drwxrwx---+  5 anneke users    184 Aug 10 12:43 Anwendungsdaten
  0 drwxrwx---+  2 anneke users     80 Sep  1 19:10 Cookies
  0 drwxrwx---+  2 anneke users    176 Sep  1 18:44 Desktop
  0 drwxrwx---+  2 anneke users     48 Aug 10 12:43 Druckumgebung
  0 drwxrwx---+  4 anneke users    144 Aug 10 12:43 Eigene Dateien
  0 drwxrwx---+  4 anneke users    200 Sep  1 18:44 Favoriten
  0 drwxrwx---+  2 anneke users     48 Aug 10 12:43 Netzwerkumgebung
  0 drwxrwx---+  2 anneke users    144 Sep  1 19:10 Recent
  0 drwxrwx---+  2 anneke users    328 Sep  1 18:44 SendTo
  0 drwxrwx---+  3 anneke users    112 Aug 10 12:43 Startmen??
  0 drwxrwx---+  2 anneke users    432 Aug 10 12:43 Vorlagen
769 -rw-------   1 anneke users 786432 Sep  2  2005 ntuser.dat
  4 -rw-------   1 anneke users   1024 Sep  2  2005 ntuser.dat.LOG
  4 -rwxrwx---   1 anneke users   1024 Aug  9 15:38 ntuser.dat.ref.LOG
  4 -rw-------   1 anneke users    282 Sep  1 19:10 ntuser.ini
In der smb.conf sieht es wie folgt aus:

Code: Alles auswählen

# Samba config file created using SWAT
# from localhost (127.0.0.1)
# Date: 2005/02/02 18:27:22

# Global parameters
[global]
        workgroup = TUX-NET
        netbios name = LINUX-SERVER
        encrypt passwords = Yes
        update encrypted = Yes
        security = user
        map to guest = Bad User
        time server = Yes
        unix extensions = Yes
        socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
        printcap name = CUPS
        logon script = logon.bat
        logon drive = X:
        logon path = \\%N\profiles\%u
        logon home = \\%N\%U\profiles
        wins support = yes
        domain logons = Yes
        os level = 65
     preferred master = Yes
        domain master = Yes
        local master = Yes
        printing = cups
        veto files = /*.eml/*.nws/riched20.dll/*.{*}/

[netlogon]
        path = /var/lib/samba/netlogon
        read only = yes
        write list = ntadmin

[profiles]
        path = /var/lib/samba/profiles
        read only = no
        create mask = 0600
        directory mask = 0700

[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        create mask = 0640
        directory mask = 0750
        browseable = No
Im Moment weiß ich nicht weiter??

cu renate
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

Versuche mal die Option 'profiel acls = yes' in Deiner profiles-Freigabe.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
dshks

Beitrag von dshks »

Den Fall hatte ich auch einmal. Ich habe dann den User mit smbpasswd -x Username gelöscht und mit smbpasswd -a username neu angelgt. Danach klappte es.

cu
Selloso
Newbie
Newbie
Beiträge: 11
Registriert: 7. Jun 2005, 09:09
Wohnort: Nahe FFM
Kontaktdaten:

Beitrag von Selloso »

Hallo Leute,

ich habe ein ähnliches Problem.
Das Profile wird vom Server geholt, ich kann auch nach Anmeldung schreibend auf das Profil-Verzeichnis zugreifen. Es werden allerdings keine Daten von meinem Profil auf dem Server gespeichert und auch keinerlei Fehlermeldungen beim Abmelden ausgegeben.

Das Profil-Verzeichnis soll mit einer separten Dateifreigabe, die auf /home/profiles zeigt, zur Verfügung gestellt werden. Die Dateirechte stimmen, die Desktop-Firewall lässt im internen Netzwerk alles zu.

Habt Ihr eine Idee, wie ich ich vielleicht überhaupt Informationen zu dem vorliegenen Fehler finden könnte, eine Logdatei oder etwas ähnliches?

Ich wäre Euch sehr dankbar
Sel
Ich weiß nicht viel, möchte aber viel lernen.
Antworten