Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

NFS-Server gibt trotz export nicht alles her

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

NFS-Server gibt trotz export nicht alles her

Beitrag von froster »

Hallo,

ich habe ne alte SUN auf der ein NFS-Server läuft. Mit exportfs kann ich alle freigegebenen Verzeichnisse sehen (alle rw). Aber ein Unterverzeichnis ist über chmod auf der SUN nur für eine spezielle Gruppe freigegeben (in der root aber Mitglied ist). Seitdem kann ich auch als root auf meinem NFS-Client auf der Suse dieses Unterverzeichnis nicht mehr sehen. Da ich die Daten öfter mal kopieren muss ist das schlecht. Wie komme ich da wieder ran, ohne die Rechte auf der SUN zu ändern?

froster
SUSE 9.2 + Samba 3.0.7-5
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Ist da root_squash am Werk ?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

Beitrag von froster »

hm.. das root_squash müsste ja dann auf der SUN sein weil dort der NFS-Server läuft?

froster
SUSE 9.2 + Samba 3.0.7-5
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

froster hat geschrieben:hm.. das root_squash müsste ja dann auf der SUN sein weil dort der NFS-Server läuft?
Ja ... allerdings
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

Beitrag von froster »

hast du da vielleicht nen tipp wo das stehen könnte?

froster
SUSE 9.2 + Samba 3.0.7-5
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

In der /etc/exports ;)
und du solltest da mal "no_root_squash" setzen.
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

Beitrag von froster »

unter SUN gibts die datei unter /etc leider nicht. muss woanders stehen.

froster
SUSE 9.2 + Samba 3.0.7-5
AntiSuse
Newbie
Newbie
Beiträge: 16
Registriert: 23. Aug 2005, 19:06

Beitrag von AntiSuse »

/etc/exportfs
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
AntiSuse
Newbie
Newbie
Beiträge: 16
Registriert: 23. Aug 2005, 19:06

Beitrag von AntiSuse »

*schäm*in die ecke stell*
/etc/dfs/dfstab

dfs == distributed filesystem
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

AntiSuse hat geschrieben:*schäm*in die ecke stell*
/etc/dfs/dfstab

dfs == distributed filesystem
... mir hat das auch nur google verraten ;)
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
AntiSuse
Newbie
Newbie
Beiträge: 16
Registriert: 23. Aug 2005, 19:06

Beitrag von AntiSuse »

Naja, aber als Ex-Sunny sollte ichs ja eigentlich wissen...
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

Beitrag von froster »

da gibts natürlich keine root_squash...

froster
SUSE 9.2 + Samba 3.0.7-5
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Ich weiß nicht wie das bei SUN ist aber AFAIK ist root_squash per default an und muß deswegen nicht explizit angegeben werden um zu wirken. no_root_sqash schaltet das aus.

Ich habe aber noch nie mit einer SUN gearbeitet :(
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

@froster

schau doch nochmal in meinen Link wegen den Optionen bei SUN.
Ich hab mit so 'nem Teil leider auch keine Erfahrung.
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

Beitrag von froster »

das ist bei Linux so und ich peile mal dass SUN das auch so macht. mein prob ist wie und wo ich dem NFs-Server jetzt no_root_squash sage um den Zugriff auf alle Verzeichnisse des NFS-Servers zu erhalten.

froster
SUSE 9.2 + Samba 3.0.7-5
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

froster hat geschrieben:das ist bei Linux so und ich peile mal dass SUN das auch so macht. mein prob ist wie und wo ich dem NFs-Server jetzt no_root_squash sage um den Zugriff auf alle Verzeichnisse des NFS-Servers zu erhalten.
froster
wo ??? ... na in dieser /etc/dfs/dfstab
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
froster
Member
Member
Beiträge: 82
Registriert: 13. Okt 2004, 13:36

Beitrag von froster »

in der dfstab sind für alle freigegeb. Laufwerke jeweils ein share-Befehl in der Form
share -F nfs -d "Name" /Pfad
angegeben. wo soll jetzt no_root_squash hin? in der Manpage gibts keinen Hinweis auf no_root_squash.

froster
SUSE 9.2 + Samba 3.0.7-5
admine
Administrator
Administrator
Beiträge: 8939
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

froster hat geschrieben:in der dfstab sind für alle freigegeb. Laufwerke jeweils ein share-Befehl in der Form
share -F nfs -d "Name" /Pfad
angegeben. wo soll jetzt no_root_squash hin?
müsste dann wenn möglich in der Form dazu:

Code: Alles auswählen

share -F nfs - o no_root_squash -d "Name" /Pfad
froster hat geschrieben: in der Manpage gibts keinen Hinweis auf no_root_squash.
hm ... dann gibts diese Option bei SUN evt. nicht oder sie nennt sich anders ... :roll:
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Antworten