Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

NUR mit win xp kein zugriff auf home verzeichnis möglich

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

NUR mit win xp kein zugriff auf home verzeichnis möglich

Beitrag von fritzbee21 »

ich hab nen samba server unter suse 9.1 laufen.
unter suse funzt das teil
den user gibts unter linux (homelaufwerk), unter samba und mein notebook user heisst genauso.
im terminal unter linux kann ich lokal den samba server testen
das klappt sowohl mit
smbclient //linux/homes

oder smbclient //linux/homes -U wolfgang

smbclient -L linux -N
gibt folgendes aus:

Anonymous login successful

Sharename Type Comment
--------- ---- -------
homes Disk Home Directories
profiles Disk Network Profiles Service
users Disk All users
groups Disk All groups
diskette Disk diskette
nfs_mount Disk /home/wolfgang/nfs_mount
IPC$ IPC IPC Service (Samba Server)
ADMIN$ IPC IPC Service (Samba Server)
hp_drucker Printer HP DeskJet 510 hpdj
Anonymous login successful

Server Comment
--------- -------
LINUX Samba Server
WOLFGANG

Workgroup Master
--------- -------
TEST WOLFGANG


mit meinem windows xp rechner (benutzer: wolfgang)
bekomme ich mit
"net view linux"

alle freigaben richtig angezeigt.
wenn ich mich allerdings mit "net use t: \\linux\homes"
verbinden möchte, bekomme ich einen "systemfehler 53 - der netzwerkpfad wurde nicht gefunden"
ich werde aber nicht aufgefordert ein username passwort einzugeben.

dann versuche ich mit mit "net use t: \\linux\users"
"Das kennwort für \\linux\users" ist ungültig"
gleichzeitig aber
"Geben sie den benutzernamen für "linux" ein"
ok ich gebe
"wolfgang"
und mein "passwort" ein

"systemfehler 1219
mehrfache verbindungen zu einem server oder einer freigegebenen recource von demselben benutzer unter verwendung mehrerer benutzernamen sind nciht zulaessig. trennen sie alle frueheren verbindungen zu dem server bzw. der freigegebenen recource und versuchen sie es erneut"

ich habe allerdings keine verbindung unter einem anderen namen am laufen. wenn ich im explorer das netzlaufwerk verbinden will, bekomme ich genau die gleich fehlermeldung. der samba server scheint aber richtig zu laufen, lokal kann ich mich verbinden.
wo liegt denn der hund begraben ?
manchmal kann ich mich tatsaechlich verbinden, allerdings auch nur solange das notebook laeuft. beim neustart wird das netzlaufwerk nicht mehr verbunden (auch wenn hacken gesetzt das dies beim naechsten mal wieder passieren soll). fehlermeldung ist die gleiche.
samba server version ist die

3.0.9-2.6-suse

eventuell hat ja jemand nen tipp, mit nem 2. xp rechner (anderer benutzername) funzt es auch nicht, auch wenn der anmeldename in "wolfgang" geaendert wird.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

*Grübel*

Könnte es sein daß Windows schon eine Verbindung als 'Gast' aufgebaut hat ?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
torbla
Member
Member
Beiträge: 183
Registriert: 31. Aug 2004, 13:27
Wohnort: Mönchengladbach

Beitrag von torbla »

1.Schaue mal nach ob Du auch den richtigen Ordner angegeben hast in der /etc/samba/smb.conf.

2. Schaue nach ob der Benutzer richtig angelegt ist einmal in der /etc/samba/smbusers und einmal ob dieser User auch in der /etc/samba/smbpasswd existiert

3. Sollte das alles nicht helfen dan poste mal deine smb.conf
ES IST LEICHTER EIN ATOM ZU SPALTEN, ALS VORURTEILE ABZUBAUEN (Albert Einstein)
fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

Beitrag von fritzbee21 »

hm wie kann ich denn nachschaun ob der win xp rechner beim booten eine verbindung als "gast" aufgebaut hat ?

smbstatus gibt mir folgendes zurueck

Samba version 3.0.9-2.6-SUSE
PID Username Group Machine
-------------------------------------------------------------------
4163 wolfgang users wolfgang (192.168.155.23)

Service pid machine Connected at
-------------------------------------------------------
wolfgang 4163 wolfgang Fri Sep 2 10:59:18 2005

No locked files


heute klappt komischerweise wieder der zurgiff von meinem notebook.


ok es gibts noch einige kleinigkeiten wie z.b.

- ich kann in meinem homeverzeichnis nicht schreiben obwohl ich read only = no
in der smb conf unter homes habe

- ein fremdrechner kann nicht ohne passwort auf den server zugreifen, obwohl es ein public verzeichnis gibt, sondern muss in der netzwerkumgebung ein passwort eingeben.

[linux_server]
path = /home/backup
comment = /home/backup
writeable = yes
force user = wolfgang
public = yes
valid users = wolfgang flying
write list = wolfgang flying
guest ok = no
browseable = yes
printable = no


1.Schaue mal nach ob Du auch den richtigen Ordner angegeben hast in der /etc/samba/smb.conf.

ja, denn sonst wuerde ich mich ja nicht lokal verbinden koennen


2. Schaue nach ob der Benutzer richtig angelegt ist einmal in der /etc/samba/smbusers und einmal ob dieser User auch in der /etc/samba/smbpasswd existiert

in der smbpasswd bin ich drin, allerdings in der smbusers nicht

# This file allows you to map usernames from the clients to the server.
# Unix_name = SMB_name1 SMB_name2 ...
#
# See section 'username map' in the manual page of smb.conf for more
# information.

root = administrator
;nobody = guest pcguest smbguest

zur zeit klappt die verbindung mal wieder, ich wuerde nur gern wissen warun es ab und zu eben nicht funzt
Antworten