Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Schreibrechte im freigegebenen Ordner

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
dspayre
Newbie
Newbie
Beiträge: 13
Registriert: 1. Mai 2004, 08:50

Schreibrechte im freigegebenen Ordner

Beitrag von dspayre »

Hallo zusammen,

hab nach langem probieren einen Samba-Server zum laufen gebracht. Mittlerweile kann ich mich auch mit meinem XP-Laptop ohne Probleme auf dem Server einloggen und auch die gewünschten Verzeichnisse lesen. Nur mit dem Schreiben, das krieg ich absolut nicht hin. Ich kann zwar von Linux aus auf dem Laptop schreiben und lesen, auch auf dem Verzeichniss des Linuxrechners, aber letzteres nur dann, wenn ich es direkt anspreche, wähle ich den weg über smb:/linux/dokumente kann ich zwar die dokumente sehen, aber ändern, löschen, neuerstellen geht nicht.
Die Firewall (Serverseitig) ist meines wissens nicht schuld, da ich die nicht konfiguriert krieg hab ich sie immer manuell abgeschalten. Spricht auch dagegen, daß ich ja grundsätzlich zugriff habe. Die Win-FW ist ganz aus, da der Schleppi eh nie online ist.
Mein Linux-PC ist mit Suse 9.3 bestückt, das ansonsten tadellos läuft. Das Schlepptop ist ein fast nagelneues Maxdata-Win-XP-SP2-Laptop.
Was ich schon gesehen hab ist folgendes: die freizugebenden Dokumente sind auf einer fat32-part auf hdb6 gemountet als windows/D, die hat immer den status user=root gruppe=users. Aber das kann ich nicht ändern, da ja fat32 keine users usw. kennt. Falls es an der FSTAB liegt die sieht so aus:

/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hdb5 /data1 auto noauto,user 0 0
/dev/hdb1 /data2 auto noauto,user 0 0
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb6 /windows/D vfat users,gid=users,umask=0002,utf8=true,others 0 0
/dev/hdb2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdram /media/dvdram subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0

das "others" bei hdb6 hab ich in einem anderen Beitrag gesehen, hat aber bei mir nix gebracht. Bei den Freigabeeigenschaften hab ich auch die Option "Schreiben" angekreuzt, eingerichtet ist das verz. eigentlich so, daß jeder da drauf zugreifen darf.

Das Netz baut sich wahlweise über Ethernet-Crosslink-Kabel oder WLAN auf, der effekt ist der selbe.

Hat jemand schon mal was ähnliches gehabt?

Gruß Martin
Vengeance
Member
Member
Beiträge: 142
Registriert: 27. Jul 2005, 15:02
Wohnort: Hünfeld
Kontaktdaten:

Re: Schreibrechte im freigegebenen Ordner

Beitrag von Vengeance »

dspayre hat geschrieben:Was ich schon gesehen hab ist folgendes: die freizugebenden Dokumente sind auf einer fat32-part auf hdb6 gemountet als windows/D, die hat immer den status user=root gruppe=users. Aber das kann ich nicht ändern, da ja fat32 keine users usw. kennt.
Irrtum. Fat32 kennt zwar keine Zugriffsberechtigungen, doch kannst du durchaus festlegen, wer auf dieses Laufwerk zugreifen darf und wer nicht. Dieses Problem hatte ich auch schon mal gehabt. Überprüfe mal die Zugriffsberechtigungen und den Eigentümer für /windows/D. Dieser Ordner liegt ja auf der Root-Partition, die laut fstab im ReiserFS Dateisystem existiert, was Zugriffsberechtigungen unterstützt.
Es gibt drei Dinge, die ich mir nicht merken kann. Buchstaben, Zahlen ......... und das Dritte habe ich schon wieder vergessen
Benutzeravatar
dspayre
Newbie
Newbie
Beiträge: 13
Registriert: 1. Mai 2004, 08:50

Beitrag von dspayre »

Stimmt. Aber der Eintrag ist auch der selbe. Und wenn ichs genau überlege müsste ja der Eintrag Gruppe=Users bedeuten, jeder der mitglied der Gruppe User ist darf alles (das ist auch freigegeben). Aber habs grad als angemeldeter Root probiert. Immernoch - über SMB:/ kann ich nichr löschen, erstellen, schreiben.
Nur direkt über /windows/D/...
Leider ist das so ne ziemliche Fehlkonstruktion. Ich will ja das Laptop mit dem PC syncen, aber ohne schreiben kann ichs glatt vergessen, da muss ich wieder alles von hand machen. oder halt mit windows booten und da.
samba ist da wohl ein rohrkrepierer, dachte für solche aufgaben wär das das richtige.
Falls doch noch jemand Ideen hat, bin immer dankbar.
(übrigens, der zusätzliche eintrag "others" s.o. in der fstab sorgt dafür, daß meine partion nicht mehr automatisch beim start mountet. must ich wieder rausnehmen).

gruß martin
Vengeance
Member
Member
Beiträge: 142
Registriert: 27. Jul 2005, 15:02
Wohnort: Hünfeld
Kontaktdaten:

Beitrag von Vengeance »

Poste am Besten mal die smb.conf. Vielleicht kann ich dann mehr sagen.
Es gibt drei Dinge, die ich mir nicht merken kann. Buchstaben, Zahlen ......... und das Dritte habe ich schon wieder vergessen
Benutzeravatar
dspayre
Newbie
Newbie
Beiträge: 13
Registriert: 1. Mai 2004, 08:50

Beitrag von dspayre »

Hier ist die smb.conf:

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-03-22
[global]
workgroup = NETZ
printcap name = cups
printcap cache time = 750
cups options = raw
printer admin = @ntadmin, root, administrator
username map = /etc/samba/smbusers
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain master = No
winbind gid = 10000-20000
winbind uid = 10000-20000

[homes]
comment = Home Directories
valid users = %S
browseable = No
read only = No
inherit acls = Yes

[users]
comment = All users
path = /home/
read only = no
inherit acls = yes
veto files = /aquota.user/groups/shares/
guest ok = yes
case sensitive = no
msdfs proxy = no

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[DOKUMENTE]
path = /windows/D/dokumente/
guest ok = yes
read only = no
case sensitive = no
msdfs proxy = no
hide dot files = no


Mir würde auch eine Einstellung reichen, in der jeder Windows-Einlogger alles darf, das mach eh nur ich.

Unter Freigabe beim Ordner hab ich folgendes eingestellt:

Ordner im lok. Netz freigeben
Freigeben per NFS
Öffentlich und Schreibbar

Freigeben mit Samba
Name DOKUMENTE
Öffentlich und Schreibbar

Vielleicht liegt ja da der haken.

Gruß Martin
Vengeance
Member
Member
Beiträge: 142
Registriert: 27. Jul 2005, 15:02
Wohnort: Hünfeld
Kontaktdaten:

Beitrag von Vengeance »

Welche Samba Version verwendest du? Und mit welchem Namen meldest du dich vom Windows-Client aus an? Ich vermute mal, du meldest dich mit einem falschen Namen an, den Samba als falschen Benutzer wahrnimmt und ihn deshalb als Gast abstempelt. Gäste dürfen, wenn überhaupt, lesen, aber nicht schreiben. Du musst die Benutzer, die du in Samba verwenden willst, auch in Samba eintragen.
Es gibt drei Dinge, die ich mir nicht merken kann. Buchstaben, Zahlen ......... und das Dritte habe ich schon wieder vergessen
Benutzeravatar
dspayre
Newbie
Newbie
Beiträge: 13
Registriert: 1. Mai 2004, 08:50

Beitrag von dspayre »

Hallo,

also zur Samba-Version:

Installiert ist Samba 3.0.12-5 und mit YOU auf 3.0.13-1.1 updated.

Die gute Nachricht:

Das mit den Usern war tatsächlich richtig. Mein alter Win-Anmeldename war "Martin", den hatte ich auch unter Linux als User (nicht in Samba) angelegt.

Da stand dann in der smbuser die Zeile Martin = sr.

Denn Benutzer Martin hatte ich aber inzwischen überall gelöscht und melde mich jetzt sowohl unter Win wie auch unter Lin mit "sr" an.

Die schlechte Nachricht:

Am ergebnis ändert sich nix. Von Linux aus kann ich immer noch lokal über /windows/D/... Datein anlegen, löschen usw. und die Dateien auf dem Laptop über Samba von Desktop aus auch. Die Dateien auf dem Desktop über Samba kann ich nicht löschen oder erstellen.

Beim Laptop ist es eigentlich genau das gleiche, Lokal alles machbar, über Netz nur die Laptop-Datein manipulierbar, die Destop-Dateien gehen nicht.

Vom gefühl her muss es an der Freigabe des Desktop-Ordners liegen. Denn auf dem Linuxrechner bin ich ja als "sr" angemeldet. Und trotzdem geht nix.

Vielleicht haben die Jungs von Novell ja was verbastelt. Ein neues YOU gibts allerdings im moment nicht.

Gruß Martin
Vengeance
Member
Member
Beiträge: 142
Registriert: 27. Jul 2005, 15:02
Wohnort: Hünfeld
Kontaktdaten:

Beitrag von Vengeance »

LOL. Jetzt sehe ich erst, was los ist. Schmeiß den Eintrag guest ok = yes raus. Mit dieser Zeile erreichst du, dass du zwar ohne Passwort auf die Freigabe zugreifen kannst, aber das passiert als Gastbenutzer, der standardmäßig nur Leserechte hat. Kein Wunder, wenn das nicht geht, aber wenn ich besser und genauer lesen könnte. Achte nach dem Entfernen der Zeile darauf, dass du dich an der Freigabe mit dem richtigen Benutzernamen und Passwort anmeldest.
Es gibt drei Dinge, die ich mir nicht merken kann. Buchstaben, Zahlen ......... und das Dritte habe ich schon wieder vergessen
Benutzeravatar
dspayre
Newbie
Newbie
Beiträge: 13
Registriert: 1. Mai 2004, 08:50

Beitrag von dspayre »

OK, hab ich gemacht. Das hat technisch (glaub ich) eine Verbesserung gebracht. Defakto geht im Moment allerdings garnix.

Ich hab jetzt keinen Zugriff auf die Shares (in dem Fall "dokumente"), stattdessen kommt ein Bildschirm, auf dem ich Benutzer und Passwort eingeben soll.

Hab alles probiert: root, sr, neuen testbenutzer mit yast anlegen, alles mit und ohne passworteingabe. Er läßt mich einfach nicht rein. Der Bildschirm taucht auf Win und Lin auf und ist gleich aufgebaut.

Ich hab auch schon gegoogelt und hier umgeschaut wie man für Samba benutzer anlegt. Hab aber nirgends was gefunden.

Ich vermute, er bringt nicht auf die Reihe welcher Benutzer grad reinkommt. Aber in der smbusers hab ich sr = sr eingegeben. Damit müsste doch jeder einlogger mit der Win-Kennung sr als Linux-User sr erkannt werden. Und der hat Zugriffsrechte auf "dokumente".

Hab auch versucht Webmin zu installieren, da ich dem Yast für fortgeschrittenere Aufgaben nicht so ganz traue, den läst er micht leider nicht installieren.

Hab auch schon versucht mit smbpasswd als root ein Passwort für sr einzugeben. Aber da meint er nur, er finde keinen User???

Wie leg ich den einen Samba-User an? Ein Dummy zum einloggen mit rootrechten würd es ja tun. Oder ich leg den Guest-User wieder an. Wie kann ich dem root-Rechte geben?

Gruß Martin
Vengeance
Member
Member
Beiträge: 142
Registriert: 27. Jul 2005, 15:02
Wohnort: Hünfeld
Kontaktdaten:

Beitrag von Vengeance »

Das habe ich mir gedacht. Wie ich oben schon erwähnt habe, muss ein Benutzer, der für Samba verwendet werden soll, in Linux existieren und in Samba eingetragen werden.
Öffne eine Konsole als Root. Dann gibst du Folgendes ein:

smbpasswd -a Name des Benutzers

Dann fragt er dich nach einem Passwort.

Dann gibst du ein:

smbpasswd -e Name des Benutzers


Die Datei smbusers dient dazu, Benutzernamen in Windows zu Benutzernamen in Samba/Linux zuzuordnen. Die Beispielzeile in der Datei zeigt es am Besten:

root = administrator

Der Windowsbenutzer Administrator wird dem Linuxbenutzer Root zugeordnet. Übertragen wir das jetzt mal auf deinen Fall. So wie du das vorher hattest mit der Zeile Martin = sr, war es nicht ganz verkehrt gewesen, du musst es nur drehen, sodass da stehe sr = martin. Jetzt müsste es auch funktionieren.

Kleiner Tipp am Rande: Ich habe festgestellt, dass es sinnvoll ist, Root als Samba-User einzutragen für alle Fälle.
Es gibt drei Dinge, die ich mir nicht merken kann. Buchstaben, Zahlen ......... und das Dritte habe ich schon wieder vergessen
Benutzeravatar
dspayre
Newbie
Newbie
Beiträge: 13
Registriert: 1. Mai 2004, 08:50

Beitrag von dspayre »

Du siehst mich grad einen geistigen Kniefall vor dir machen. Plötzlich gings einwandfrei.

Er hat jetzt auch einen neuen (und damit den ersten) Eintrag in der smbpasswd erstellt. sr = aljföal fasjf lajölsf oder so ähnlich. Vermute mal das ist das verschlüsselte Passwort. Soll ja auch so sein.

Hatte mich zwar schon mit dieser Datei kurz befasst, ich dachte aber immer, erst in Samba den User anlegen, und habs ganz wo anders gesucht. Naja, zugriff auf das Verzeichnis, Linux-Home, Linux-Desktop MIT Schreibrecht funktioniert.

Sogar die Firewall lässt Samba sauber durch.

Ich lobpreise den Tag, an dem ich über dieses Forum gestollpert bin.

Dank jedenfalls.
Antworten