Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit DHCP Server

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
LinuxBoy
Newbie
Newbie
Beiträge: 8
Registriert: 22. Nov 2004, 10:26
Kontaktdaten:

Problem mit DHCP Server

Beitrag von LinuxBoy »

Hi leute,

ich bastel gerade an einem DHCP Server, aber leider klappt das nicht so ganz wie ich mir das vorgestellt habe. folgendes:

Als OS nutze ich Fedora Core 4 als Server installation mit ISC DHCPd V.3.0.2
soweit so gut ...

der server lässt sich, im ersten moment auch starten, aber halt nur im ersten.
Sobald ich die dhcpd.conf unter /etc/ anpasse und den deamon neu starte, passiert nichts mehr...

dhcpd starten: [FEHLGESCHLAGEN]

das ist alles was raus kommt ...

ich bin nun schon soweit, dass mir aufgefallen ist, dass wenn die dhcpd.conf leer ist oder fehlt, das dann der deamon ohne probleme läuft, sich starten, stoppen und auch neustarten lässt ...

aber das bringt mir nicht viel, da er ja keine anweisungen hat wie er auf broadcast anfragen regieren soll, mit ethereal habe ich die anfragen halt mit gesnifft ... anfragen kommen von dem client, werden entgegengenommen, aber nicht bearbeitet.

die datei /var/lib/dhcp/dchpd.leases existiert auch ...
die firewall ist auch aus ...
syntax fehler schließe ich erstmal auch aus, da es auch nicht mit der sample datei funkrioniert hat.

als server dient ein neuer Dell Rechner mit wie oben schon genannt FC4

als client verwende ich ein dell notebook mit Redhat linux 9

dazwischen hängt ein NETGEAR 8 Port 10/100 Mbit switch
an normalen STP Kabeln,


#####
#DELL#-------------------|NETGEAR SWITCH|------------**CLIENT**
#####
SERVER


der switch ist komplett neu und die kabel alle getestet, also liegt es auch nicht daran ... mache ich etwas bei dem server falsch ???

habt ihr noch eine idee was ich versuchen könnte ???

danke
na-cx
Hacker
Hacker
Beiträge: 493
Registriert: 18. Mai 2004, 20:00
Wohnort: Syke

Re: Problem mit DHCP Server

Beitrag von na-cx »

LinuxBoy hat geschrieben:habt ihr noch eine idee was ich versuchen könnte ???
JA!

Erstmal die Konfigurationsdateien hier mal einstellen.
CU
Christian

Bild
LinuxBoy
Newbie
Newbie
Beiträge: 8
Registriert: 22. Nov 2004, 10:26
Kontaktdaten:

Beitrag von LinuxBoy »

okay ...

ich habe es mit dieser selber erstellten versucht ...

Code: Alles auswählen

defaul-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-adress 192.168.1.255;
option routers 192.168.1.15;
option domain-name "test.de";
option domain-name-servers 192.168.1.10;

subnet 192.168.1.0 netmask 255.255.255.0{
range 192.168.1.20 168.168.1.100;
}
und das zweite ist ja die beispieldatei ... mit der es auch nicht klappt
aber auch hier mit ...

Code: Alles auswählen

ddns-update-style interim;
ignore client-updates;

subnet 192.168.0.0 netmask 255.255.255.0 {

# --- default gateway
	option routers			192.168.0.1;
	option subnet-mask		255.255.255.0;

	option nis-domain		"domain.org";
	option domain-name		"domain.org";
	option domain-name-servers	192.168.1.1;

	option time-offset		-18000;	# Eastern Standard Time
#	option ntp-servers		192.168.1.1;
#	option netbios-name-servers	192.168.1.1;
# --- Selects point-to-point node (default is hybrid). Don't change this unless
# -- you understand Netbios very well
#	option netbios-node-type 2;

	range dynamic-bootp 192.168.0.128 192.168.0.254;
	default-lease-time 21600;
	max-lease-time 43200;

	# we want the nameserver to appear at a fixed address
	host ns {
		next-server marvin.redhat.com;
		hardware ethernet 12:34:56:78:AB:CD;
		fixed-address 207.175.42.254;
	}
}
na-cx
Hacker
Hacker
Beiträge: 493
Registriert: 18. Mai 2004, 20:00
Wohnort: Syke

Beitrag von na-cx »

Cool.

Da du nicht der Besitzer von "domain.org" bzw. "test.de" bist erstmal was anderes wählen!
irgendwas.home / irgendwas.lokal

Code: Alles auswählen

# we want the nameserver to appear at a fixed address 
   host ns { 
      next-server marvin.redhat.com; 
      hardware ethernet 12:34:56:78:AB:CD; 
      fixed-address 207.175.42.254; 
   }
Den Mist hau mal ganz schnell raus! Da wird versucht auf den (vermeintlichen) Namensserver von Redhat zuzugreifen.
CU
Christian

Bild
LinuxBoy
Newbie
Newbie
Beiträge: 8
Registriert: 22. Nov 2004, 10:26
Kontaktdaten:

Beitrag von LinuxBoy »

bringt nichts ... hab es mit der zeile

Code: Alles auswählen

option domain-name "test.de";
probiert
na-cx
Hacker
Hacker
Beiträge: 493
Registriert: 18. Mai 2004, 20:00
Wohnort: Syke

Beitrag von na-cx »

Gib mal in einem Internetbrowser www.test.de ein.

Bei der DHCP-Konfiguration Finger weg von TLD's wie z.B. .de / .com / .org / .net !!!
CU
Christian

Bild
LinuxBoy
Newbie
Newbie
Beiträge: 8
Registriert: 22. Nov 2004, 10:26
Kontaktdaten:

Beitrag von LinuxBoy »

problem gelöst ...
an dem domain-name lag es nicht

ich habe einmal mit

Code: Alles auswählen

dhcpd -cf /home/dhcp/dhcpd.conf
gestartet und seit dem läuft er ohne probleme ...

sogar mit neustart, und allem anderen
Antworten