Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] ProFTPd RPM Installation

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Kilu
Newbie
Newbie
Beiträge: 6
Registriert: 21. Aug 2005, 20:47

[gelöst] ProFTPd RPM Installation

Beitrag von Kilu »

Halli hallo,

also ich habe folgendes Problem bei der Installation des RPM Paketes von proftpd.

wenn ich mit das Paket installieren will erhalte ich folgende meldung:

Code: Alles auswählen

warning: proftpd-1.2.10-9tr.i586.rpm: V3 DSA signature: NOKEY, key ID c2bd224b
error: Failed dependencies:
        chkconfig is needed by proftpd-1.2.10-9tr
        setup is needed by proftpd-1.2.10-9tr
        /sbin/restart_maybe is needed by proftpd-1.2.10-9tr
jetzt habe ich angefangen mir unter
http://linker.kilu.de/?url=http://rpm.p ... 6.rpm.html
die pakete runterzuladen.
Allerdings braucht jedes dieser Pakete wiederum eine Reihe anderer Pakete, das führt ins Unendliche
was mache ich falsch?
oder ist das normal?

Also ich bin folgendermaßen vorgegangen:

Code: Alles auswählen

cd /home/proftpd
wget ftp://ftp.pbone.net/[....]/rpms/proftpd-1.2.10-9tr.i586.rpm
chmod 777 proftpd-1.2.10-9tr.i586.rpm
rpm -ivh proftpd-1.2.10-9tr.i586.rpm
und dann kam halt die fehlermeldung

wenn ich das rpm über YaST2 installieren will sagt er ungefähr das selbe, irgendwas fehlt ihm

mfG

Simon
Benutzeravatar
nbkr
Guru
Guru
Beiträge: 2858
Registriert: 10. Jul 2004, 15:47

Beitrag von nbkr »

Diese Abhängigkeiten sind normal. Installier proftpd über YaST, das löst die Abhängigkeiten auf. Oder installiert apt (da gibts ein ganzes Unterforum dafür), das löst die Abhängigkeiten auch auf.
Kann gar nicht sein, ich bin gefürchtet Wald aus, Wald ein.
Benutzeravatar
Kilu
Newbie
Newbie
Beiträge: 6
Registriert: 21. Aug 2005, 20:47

Beitrag von Kilu »

also das kommt bei YaST raus:
http://linker.kilu.de/?url=http://webma ... e/yast.bmp

atp sagt mir bis jetzt noch nichts
Benutzeravatar
Kilu
Newbie
Newbie
Beiträge: 6
Registriert: 21. Aug 2005, 20:47

Beitrag von Kilu »

also ich hab mir jetzt nach dieser anleitung
http://susewiki.org/index.php?title=Install-apt4suse
APT installiert

Jetzt wollte ich mit

Code: Alles auswählen

apt-get install proftpd
ProFTPd installieren und bekomme folgende Fehlermeldung:

Code: Alles auswählen

Reading Package Lists... Done
Building Dependency Tree... Done
proftpd is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  proftpd: Depends: chkconfig but it is not installable
           PreDepends: setup but it is not installable
           PreDepends: /sbin/restart_maybe but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Benutzeravatar
Kilu
Newbie
Newbie
Beiträge: 6
Registriert: 21. Aug 2005, 20:47

Beitrag von Kilu »

ok hat sich erledigt....war wohl keine suse rpm.
habs kompilliert
Antworten