Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Internet okay, aber kein Zugriff innerhalb des WLAN

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
CHA
Newbie
Newbie
Beiträge: 2
Registriert: 21. Aug 2005, 18:40

Internet okay, aber kein Zugriff innerhalb des WLAN

Beitrag von CHA »

Hallo Experten,

Nach langer Zeit als stiller und interessierter Mitleser muss ich mich nun doch noch mal zu einem Problem melden, für das ich bisher noch keine Lösung hier gefunden habe (dass es sowas gibt ... ).

Mein WLAN-Router ist konfiguriert, mit allen Geräten (mehrere PCs, Notebooks und PDAs) komme ich ins Internet und alle Windows-Systeme verstehen sich auch wunderbar untereinander.
Das einzige Problem ist ein Notebook auf dem sowohl WinXP als auch Suse 9.1 läuft.
Unter XP ist alles paletti (WLAN und Netzwerkkarte) und auch mit Suse komme ich über WLAN-Adapter problemlos ins Web, allerdings kann ich über WLAN NICHT auf andere Geräte im lokalen Netz zugreifen (Samba oder auch direkt auf den Router über http://192.168.1.1), über die Netzwerkkarte gibt es hier kein Problem.

Der WLAN-Adapter wird über DHPC konfiguriert, die Netzwerkkarte hat eine feste IP zugewiesen (anders hat das WLAN nicht funktioniert).

Was kann ich also tun? Ich bin ziemlich ratlos und habe schon mehrfach versucht in den Netzeinstellungen rumzuspielen.

Danke für jede Hilfe!


Servus,
CHA
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Zum einen könnte das an der Firewall liegen. Daher mal prüfen was eingetragen ist, bzw. mal

Code: Alles auswählen

iptables -L
prüfen

Zum anderen mag es SuSE überhaupt nicht zwei Netzwerkadapter im gleiche Subnetz zu haben, wenn nur einer Verbunden ist.

was gibt denn ein

Code: Alles auswählen

netstat -r
aus. Dann brauchen wir aber auch die ausgabe von

Code: Alles auswählen

ifconfig
CHA
Newbie
Newbie
Beiträge: 2
Registriert: 21. Aug 2005, 18:40

Beitrag von CHA »

DANKE schon mal für die Tipps ...

Na dann schauen wir doch mal:
Die Firewall habe ich schon deaktiviert, das sollte kein Problem darstellen.

Hier der Auszug für NETSTAT

Code: Alles auswählen

chris@linuxnet:~> netstat -r
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
192.168.1.0     *               255.255.255.0   U         0 0          0 eth0
192.168.1.0     *               255.255.255.0   U         0 0          0 wlan0
link-local      *               255.255.0.0     U         0 0          0 eth0
loopback        *               255.0.0.0       U         0 0          0 lo
default         192.168.1.1     0.0.0.0         UG        0 0          0 wlan0
default         192.168.1.1     0.0.0.0         UG        0 0          0 eth0
chris@linuxnet:~>
Und dann noch:

Code: Alles auswählen

chris@linuxnet:/sbin> ./ifconfig
eth0      Protokoll:Ethernet  Hardware Adresse 00:E0:00:1C:EA:31
          inet Adresse:192.168.1.100  Bcast:192.168.1.255  Maske:255.255.255.0
          inet6 Adresse: fe80::2e0:ff:fe1c:ea31/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 b)  TX bytes:586 (586.0 b)

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:4188 (4.0 Kb)  TX bytes:4188 (4.0 Kb)

wlan0     Protokoll:Ethernet  Hardware Adresse 00:80:C6:09:7A:03
          inet Adresse:192.168.1.12  Bcast:192.168.1.255  Maske:255.255.255.0
          inet6 Adresse: fe80::280:c6ff:fe09:7a03/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1773 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1991 errors:0 dropped:1 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:860057 (839.8 Kb)  TX bytes:283022 (276.3 Kb)

chris@linuxnet:/sbin>
Ich geb's zu, dass ich auf diesem Gebiet nicht der Superexperte bin, aber mir sagen diese Zeilen für die Fehlersuche nicht viel.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Code: Alles auswählen

default         192.168.1.1     0.0.0.0         UG        0 0          0 wlan0
default         192.168.1.1     0.0.0.0         UG        0 0          0 eth0 
Da ist das Routing durcheinander. Lesen:

TIP: Probleme bei WLAN mit zweiter Netzwerkkarte

http://www.linux-club.de/viewtopic.php?t=21559
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Antworten