Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

smbclient -M

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

smbclient -M

Beitrag von zero0109 »

Ich versuche hier von einem PDC aus mittels smbclient -M IP oder Username Nachrichten an Windows 2000 Clients zu verschicken. Der Nachrichtendienst läuft und auf den Clients ist auch keine Firewall installiert. Die SuSE Firewall ist ebenfalls deaktiviert.
Leider läuft die Sache immer so ab, egal ob ich Username oder IP benutze:
smbclient -M 10.6.3.28
added interface ip=10.6.0.2 bcast=10.6.255.255 nmask=255.255.0.0
Client started (version 3.0.13-1.1-SUSE).
Connecting to 10.6.3.28 at port 445
message start: Call timed out: server did not respond after 20000 milliseconds
texus
Member
Member
Beiträge: 129
Registriert: 14. Jul 2005, 11:02
Wohnort: Berlin

Beitrag von texus »

Vielleicht hilft das:

http://www.tei-lin-net.de/tip_samba_05.html

MfG
texus
Benutzeravatar
torbla
Member
Member
Beiträge: 183
Registriert: 31. Aug 2004, 13:27
Wohnort: Mönchengladbach

Beitrag von torbla »

Versuche mal

echo "hallo world" | smbclient -M Rechnername

Achte darauf, das der DNS funktioniert solltest ein ging an den Rechnernamen nicht möglich sein, trage in in der /etc/hosts ein. Dann klappt es auch mit dem net send ;-)
ES IST LEICHTER EIN ATOM ZU SPALTEN, ALS VORURTEILE ABZUBAUEN (Albert Einstein)
fiderallalla
Newbie
Newbie
Beiträge: 16
Registriert: 3. Mai 2004, 08:22
Wohnort: Mönchengladbach
Kontaktdaten:

Beitrag von fiderallalla »

torbla hat geschrieben:echo "hallo world" | smbclient -M Rechnername
.. und falls das nicht funktioniert könnte man noch ein -I IP-Adresse dranhängen.
rentner-wk
Newbie
Newbie
Beiträge: 34
Registriert: 21. Jun 2006, 11:40
Wohnort: Wermelskirchen

smbclient -M funktioniert nicht

Beitrag von rentner-wk »

Hallo,
ich schlage mich gerade mit smbclient -M rum, und es funktioniert leider nicht so wie ich das gerne hätte :?
Ich bekomme einfach keine Nachricht an Linux Rechner geschickt (von Suse 9.3 an Suse 10.0), Nachrichten an Windows Rechner kommen an(Win2k mit deaktivierung von Firewall).
Ich habe folgenden Befehl benutzt:

Code: Alles auswählen

echo "hallo" | smbclient -M reached -I 192.168.178.22
Als ergbins erhalte ich:

Code: Alles auswählen

Error connecting to 192.168.178.22 (Connection refused)
Connection to reached failed
Das passiert auch, wenn ich auf beiden Rechnern die Firewall deaktiviere (keine Ahnung welche Ports ich dafür freigeben muss)

Den einzigen Fehler den ich in den Log Files gefunden habe ist in der /var/log/samba/log.nmbd:

Code: Alles auswählen

[2006/12/16 11:23:32, 0] nmbd/nmbd.c:main(668)
  Netbios nameserver version 3.0.13-1.1-SUSE started.
  Copyright Andrew Tridgell and the Samba Team 1994-2004
[2006/12/16 11:23:32, 0] nmbd/asyncdns.c:start_async_dns(149)
  started asyncdns process 12783
[2006/12/16 11:23:32, 0] lib/util_sock.c:open_socket_in(708)
  bind failed on port 137 socket_addr = 192.9.200.49.
  Error = Cannot assign requested address
[2006/12/16 11:23:32, 0] nmbd/nmbd_subnetdb.c:make_subnet(126)
nmbd_subnetdb:make_subnet()
  Failed to open nmb socket on interface 192.9.200.49 for port 137.  Error was Cannot assign requested address
[2006/12/16 11:23:32, 0] nmbd/nmbd.c:main(736)
  ERROR: Failed when creating subnet lists. Exiting.
Ich hab keine Ahnung ob es daran liegt.
Ich hoffe jemand kann mir da helfen!

MfG
Rentner
rentner-wk
Newbie
Newbie
Beiträge: 34
Registriert: 21. Jun 2006, 11:40
Wohnort: Wermelskirchen

Beitrag von rentner-wk »

Ok, ich habe es jetzt geschaft, das die Nachricht an den Linux Rechner übermittelt wird. Aber es wird nicht angezeigt,
Habe folgende Kommandos in der smb.conf schon ausprobiert:

Code: Alles auswählen

message command = bash -c 'xedit %s;rm %s' &
und

Code: Alles auswählen

message command = /usr/local/samba/var/popup/get_popup "%f" "%t" "%s" "%I" &

Code: Alles auswählen

message command = /usr/bin/X11/linpopup "%f" "%m" %s; rm %s &
Ich habe den verdacht, das die Nachricht irgendwie verloren geht, Sie wird werder angezeigt, noch in der Datei gespeichert.

Kann mir jemand helfen und mir sagen, wie ich es hin bekomme, das die Nachricht direkt angezeigt wird (am besten mit XDialog) ??

MfG
Rentner
Antworten