Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Mailserver aus ct Heft 17/2005 macht mich fertig- Hilfeee!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

/etc/fetchmailrc

keep
Gruß crazyrolf
-EX-Moderator-Mail-
Kai-Christoph
Newbie
Newbie
Beiträge: 15
Registriert: 17. Aug 2005, 22:59

Beitrag von Kai-Christoph »

Einfach nur keep am Ende der "poll ..." Zeilen?

Sorry, aber ich bin noch so dermaßener Noob...

Kannst Du mir genau sagen, wo ich den "keep"-Befehl eintragen muss?
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

Gruß crazyrolf
-EX-Moderator-Mail-
Kai-Christoph
Newbie
Newbie
Beiträge: 15
Registriert: 17. Aug 2005, 22:59

Beitrag von Kai-Christoph »

Also bei mir sieht die Zeile so aus:

poll "pop.gmx.net" protocol POP3 : user "xxx@gmx.de" there with password "xxx" is "xxx" here -k -v;

Stimmt das auch?
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

der parameter -k muss bei dem aufruf von fetchmail eingegeben werden.

z.b. auf der konsole:

fetchmail -k -v zum direkten testen.


in der fetchmailrc schreibst du obendrueber einfach "keep", denn die parameter -k etc wird von fetchmail in der datei nicht mehr ausgewertet.

fetchmail kannst du mit einem intervall von 3 minuten auch mit fetchmail -k -d 180 in der konsole starten.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
Kai-Christoph
Newbie
Newbie
Beiträge: 15
Registriert: 17. Aug 2005, 22:59

Beitrag von Kai-Christoph »

Super, vielen, vielen Dank für eure Hilfe.
Jetzt hat alles geklappt!

ABER: IMMER HAB ICH PECH!!! :shock:

Die Kiste lief jetzt ca. eine halbe Stunde wunderbar, ich war gerade am Mails sichern, da klackte es plötzlich so merkwürdig aus dem Gehäuse... :evil: :shock:

Ich hatte schon böse Ahnungen. Um die ganze Geschichte zu testen habe ich eine alte 10 Gig Platte, die ich aus einem PIII-Rechner noch hatte, in einen Wechselrahmen gebaut und da dann den Mailserver aufgesetzt...

Das Ende vom Lied: Der Server lief endlich für ne halbe Stunde, ich dachte ich kann meine Mails noch retten..

UND JETZT IST DIE PLATTE ÜBER'N JORDAN GEGANGEN!!! :evil: Ich kann's nicht fassen. :(

Ich habe fertig!

KC
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

zm testen ist sowas ja immer ganz nett, aber fuer den "scharfen" betrieb sollte es dann doch ein kleines raid sein ;-)

durch das neue aufsetzen lernst du es dann auch richtig *fg*


ansonsten: /etc immer auf einen anderen rechner/usb-stick sichern.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

ja so ein pech !

also echt. :lol:
Gruß crazyrolf
-EX-Moderator-Mail-
Kai-Christoph
Newbie
Newbie
Beiträge: 15
Registriert: 17. Aug 2005, 22:59

Beitrag von Kai-Christoph »

Ja, ja wer den Schaden hat.... spottet keiner Beschreibung... :lol:

Also gehe ich heute Abend oder am Wochenende mal in den Keller und such' mir ne frischere Platte.

Und dann heißt's: Same procedure than last year Mrs. SUSE... :wink:

Wenn ich das dann in der nächsten Zeit noch drei- bis achtmal gemacht habe, nenn ich mich Mailmeister... :wink:

Ansonsten: Ich meld' mich dann wieder, wen ich nicht mehr weiter weiß.

Für heute habe ich aber die Schnauze bis oben hin voll. :twisted:

Schönes Wochenende

KC
Benutzeravatar
SD582
Member
Member
Beiträge: 65
Registriert: 1. Jun 2004, 20:29
Wohnort: Salzburg - Flachgau
Kontaktdaten:

Beitrag von SD582 »

Hi Leute

Da hätte ich jetzt auch eine Frage dazu.
Ich schicke mich gerade an, cyrus zu installieren. Nur finde ich das Dings nicht auf der Ct-DVD (Suse 9.3). Das Heft habe ich nicht zur Hand.
Frage: Muß ich mir cyrus irgendwo runtersaugen? Wenn ja, wo finde ich das Paket am besten?

Ich hab das vor etwa einem Jahr schon mal unter Suse 9.1 gemacht. Inzwischen ist aber wieder fast ein Jahr ohne Linux vergangen. Und damals war's bei der Distri dabei, wenn ich mich nicht irre.

Ich hatte damals übrigens auch das Problem, daß ich mich an cyrus nicht anmelden konnte. Wenns interessiert - hier der alte thread dazu http://www.linux-club.de/viewtopic.php?t=11288

Gruß
Franz
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

hier kannst du cyrus downloaden:

http://asg.web.cmu.edu/cyrus/download/


bei den heft-cds sind meistens keine serverdienste dabei.
mounte einfach ueber FTP einen suse-mirror (z.b. gwdg.de oder
leo.org). dann kannst die diese sachen wie cyrues etc installieren.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
sami77
Newbie
Newbie
Beiträge: 6
Registriert: 19. Jul 2005, 09:31

Wo sind die Mails??!?!!

Beitrag von sami77 »

Hi!

Bin auch gerade dabei, das c´t Projekt zu verwirklichen! Beim ersten Versuch hat mir mein Server schön meinen IMAP Server leergeräumt und alle Mails in eine EMail_Datei, die nach meinem Benutzernamen genannt ist, abgelegt. Die Datei befindet sich unter /var/spool/mail, da bis dahin noch nicht der Verweis zum Cyrus IMAP Server bestand.

Frage Nr. 1: Wie bekomme ich diese Mails wieder in ein Mailprogramm???

Weiterhin habe ich meinen Mailserver nach C´t Vorgabe eingerichtet und meinen Cyrus mit neuem Mailkonto in Betrieb genommen. Danach habe ich Outlook Express auf meinem Notebook reaktiviert und meinen neuen Mailserver angesprochen. Dieser konnte sich auch authentifizieren und ich war zunächt glücklich, doch er ruft keine Mails ab!!! Fetchmail hat schön brav wieder den Server leergeräumt, allerdings hat er die Mails nicht zum Cyrus IMAP durchgestellt!

Frage Nr. 2: Wo sind die Dinger???? :x


Vielen Dank im Voraus und schöne Grüsse!

Uwe
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

mails aus einer mbox neu versenden?

suche im forum nutzen! mehrfach gefragt!!!!

hint: formail


wo deine mails sind - hmm... kristallkugel...
ja... das koennten sie sein.... ja genau...hmm....


hint: tail -f /var/log/mail

.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
sami77
Newbie
Newbie
Beiträge: 6
Registriert: 19. Jul 2005, 09:31

Hmmm....

Beitrag von sami77 »

Vielen Dank erstmal, aber wieso die Mails nicht von fetchmail zum IMAP weitergeleitet werden kannste mir auch nicht sagen, oder?

Gruss U
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

die sollen auch nicht zum mda (imap) sondern zum mta (postfix).
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
sami77
Newbie
Newbie
Beiträge: 6
Registriert: 19. Jul 2005, 09:31

Ääääh und?

Beitrag von sami77 »

D.h.? Wie kann ich nun meine Mails, die von fetchmail abgefecht wurden über meinen client abrufen? Kommunikation besteht, die Mails werden auch von arcor abgerufen, aber keine in meinen IMAP Ordner abgelgt... :cry:

Danke danke danke!
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

du musst in der main.cf den "mailbox_transport = " richtig setzen.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
sami77
Newbie
Newbie
Beiträge: 6
Registriert: 19. Jul 2005, 09:31

OK!

Beitrag von sami77 »

Ok, ich versuche jetzt erst mal mit diesen Informationen zurechtzukommen, wenn ich wieder vor der Kiste sitze!

Vielen Dank und schöne Grüsse!

:oops:
Gesperrt