Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

gelöst: firefox startet nicht...gdk-critical

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
elcarotino
Newbie
Newbie
Beiträge: 13
Registriert: 24. Mai 2005, 22:10
Kontaktdaten:

gelöst: firefox startet nicht...gdk-critical

Beitrag von elcarotino »

moin leutz :wink:

hab seit tagen das problem, dass mein firefox nicht mehr starten will...habs in der konsole gestartet und folgendes bekommen:

Code: Alles auswählen

elcarotino@linux:~> firefox

(Gecko:7702): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion `GDK_IS_DRAWABLE (drawable)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_window_set_back_pixmap: assertion `pixmap == NULL || gdk_drawable_get_depth (window) == gdk_drawable_get_depth (pixmap)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion `GDK_IS_DRAWABLE (drawable)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_window_set_back_pixmap: assertion `pixmap == NULL || gdk_drawable_get_depth (window) == gdk_drawable_get_depth (pixmap)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion `GDK_IS_DRAWABLE (drawable)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_window_set_back_pixmap: assertion `pixmap == NULL || gdk_drawable_get_depth (window) == gdk_drawable_get_depth (pixmap)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion `GDK_IS_DRAWABLE (drawable)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_window_set_back_pixmap: assertion `pixmap == NULL || gdk_drawable_get_depth (window) == gdk_drawable_get_depth (pixmap)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion `GDK_IS_DRAWABLE (drawable)' failed

(Gecko:7702): Gdk-CRITICAL **: gdk_window_set_back_pixmap: assertion `pixmap == NULL || gdk_drawable_get_depth (window) == gdk_drawable_get_depth (pixmap)' failed

(Gecko:7702): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed

(Gecko:7702): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadPixmap (invalid Pixmap parameter)'.
  (Details: serial 1542 error_code 4 request_code 55 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
was soll ich nun tun, damit ich firefox wieder benutzen kann?

m4ny thx im voraus
elcarotino :wink:
cozi
Member
Member
Beiträge: 172
Registriert: 19. Apr 2004, 15:31
Wohnort: Bruchsal
Kontaktdaten:

Beitrag von cozi »

Steht in der Fehlermeldung:
To debug your program, run it with the --sync command line option to change this behavior.

Probier das mal, ansonsten das übliche Programm: Profil sichern, löschen, deinstallieren, alle Überbleibsel entfernen und neu draufpacken...

Viel Spaß, COZi
Der Weg ist das Ziel...
elcarotino
Newbie
Newbie
Beiträge: 13
Registriert: 24. Mai 2005, 22:10
Kontaktdaten:

Beitrag von elcarotino »

hi,

erstmal vielen dank cozi für deine schnelle hilfe :wink:

firefox --sync brachte eine ähnliche fehlermeldung, wie anfänglich gepostet...
vorschlag #2...löschen,etc...neu install...soweit gut, als dass die fehlermeldung kürzer ausfällt:

Code: Alles auswählen

elcarotino@linux:~> firefox

(Gecko:17498): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
/usr/bin/firefox: line 259: 17498 Speicherzugriffsfehler  $MOZ_PROGRAM $MOZ_LANG
elcarotino@linux:~> firefox --sync

(Gecko:17606): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
/usr/bin/firefox: line 318: 17606 Speicherzugriffsfehler  $MOZ_PROGRAM $MOZ_LANG ${1+"$@"}
hab nun in nem anderen thread gelesen, es läge an der gtk-qt-engine, die man einfach deinstallieren solle und alles wird gut...
ich brauch die aber für andere sachen...

was mach ich nun mit dieser fehlermeldung?
zu hülf :(

thx
elcarotino
elcarotino
Newbie
Newbie
Beiträge: 13
Registriert: 24. Mai 2005, 22:10
Kontaktdaten:

[gelöst] firefox startet nicht...gdk-critical

Beitrag von elcarotino »

Hi,

ok, manchmal zahlt es sich doch aus, fehlermeldungen und die sufu hier bissel besser zu kombinieren, um effektiver zu nutzen. und siehe da, noch n anderen thread gefunden und lösung ausprobiert...gtk-qt-engine deinstallieren...firefox und auch gimp laufen wieder :lol:

@oc2pus:

danke für dein howto+skript für die sufu im firefox :wink:
habs ausprobiert --> it works great :wink:

als dann
elcarotino :wink:
Gesperrt