Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

libxine1 oder xine-lib, Unterschied?

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Thomas4000
Member
Member
Beiträge: 178
Registriert: 8. Aug 2004, 20:20
Wohnort: Bayern

libxine1 oder xine-lib, Unterschied?

Beitrag von Thomas4000 »

Hi, folgendes ist mir aufgefallen:

Code: Alles auswählen

apt-get -s install xine
Reading Package Lists... Done
Building Dependency Tree... Done
Package xine is a virtual package provided by:
  libxine1 1.1.0-0.pm.0
  xine-lib 1.0-10.2 [Installed]
You should explicitly select one to install.

Code: Alles auswählen

apt-get -s install libxine
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting libxine1 for 'libxine'
The following packages will be REPLACED:
  xine-lib (by libxine1)  xine-mad (by libxine1)
The following NEW packages will be installed:
  libxine1
0 upgraded, 1 newly installed, 2 replaced, 0 removed and 154 not upgraded.
Inst libxine1 (1.1.0-0.pm.0 SuSE:9.3/stable) [libxine1 on xine-lib] [libxine1 on xine-mad] []
Conf libxine1 broken
 Obsoletes:xine-lib Obsoletes:xine-mad
 []
E: Conf Broken libxine1
Was ist besser, xine-lib oder libxine1?
Mir stürzt Kaffeine 0.7 immer ab wenn ich in den xine-engine-Paramtern "arts" als Audio-Treiber einstelle, deswegen würde ich evtl. updaten...


THX,
Thomas
ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl »

Soweit ich weiss ist die libxine1 die Version von Packman, da ist nix "kastriert". Die xine-lib ist die mit der Suse ausgelieferte, und wegen relchtlicher bedenken beschnitten.
AFAIK.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Saber_Rider hat geschrieben:Soweit ich weiss ist die libxine1 die Version von Packman, da ist nix "kastriert". Die xine-lib ist die mit der Suse ausgelieferte, und wegen relchtlicher bedenken beschnitten.
AFAIK.
... und suser-guru hat auch ein xine-lib Paket, ich denke seine Version ist auch nicht "kastriert".

So hies das Paket früher mal.
Das Problem wird auch gerade im apt-Forum diskutiert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Thomas4000
Member
Member
Beiträge: 178
Registriert: 8. Aug 2004, 20:20
Wohnort: Bayern

Beitrag von Thomas4000 »

Aha, danke, bringt Licht ins dunkel.
Hab vorher xine-lib durch libxine1 per apt ersetzt, das ging.

Das Problem mit Kaffeine besteht weiter, liegt aber nicht an xine, da gxine z.B. mit arts läuft.
Antworten