Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Es werden unter XP nicht alle Dateien angezeigt

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Es werden unter XP nicht alle Dateien angezeigt

Beitrag von Martin Breidenbach »

Ich kämpfe momentan gegen ein dubioses Problem.

Da meine ca 580 CDs zwei Zimmer weiter im Regal stehen habe ich im Linux-Rechner eine Platte mit jeder Menge MP3-Dateien. Spart Laufarbeit. Meistens spiele ich die unter Linux mit XMMS ab.

Jetzt habe ich festgestellt daß auf XPSp2-Clients z.B. im Explorer nicht alle Dateien angezeigt werden.

Andere Windows-Versionen habe ich nicht ausprobiert (müßte ich eh unter VMware starten).

Wenn ich z.B. im Total Commander (Windows Dateimanagementtool ahnlich dem Midnight Commander) die Dateien in ein anderes Verzeichnis verschiebe dann sehe ich plötzlich die vorher fehlenden.

Schiebe ich die jetzt auch rüber sind sie wieder 'unsichtbar' !

Mache ich unter cmd.exe 'dir' fehlen Dateien.

Gebe ich unter cmd.exe sowas wie 'dir anfang*' ein dann werden vorher fehlende Dateien (die mit 'anfang' beginnen) mit angezeigt.

In einem betroffenen Verzeichnis liegen weniger als 100 Dateien. Umkopieren der Dateien (s.o.) löst das Problem nicht. An den Dateinamen kann ich nichts besonders feststellen.

Ich habe eben mal testweise das Share unter Linux mit mount -t smbfs gemountet - und da sind alle Dateien gleich sichtbar. DRECKSACK.

Der Rechner läuft unter SuSE 9.2, upgedatet mit apt. Die installierten Samba-Pakete sind:

Code: Alles auswählen

samba-pdb-3.0.20rc2-0.1
kdebase3-samba-3.4.2-12
yast2-samba-client-2.10.5-2.1
samba-3.0.20rc2-0.1
yast2-samba-server-2.10.7-3.1
samba-client-3.0.20rc2-0.1
samba-doc-3.0.11-0.1
samba-python-3.0.20rc2-0.1
samba-winbind-3.0.20rc2-0.1
libsmbclient-devel-3.0.20rc2-0.1
ldapsmb-1.33-1.1
libsmbclient-3.0.20rc2-0.1
Hier die [global] Sektion aus der smb.conf:

Code: Alles auswählen

workgroup = discworld
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
printer admin = @ntadmin, root, administrator
username map = /etc/samba/smbusers
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
security = user
encrypt passwords = yes
ldap idmap suffix = ou=Idmap
ldap machine suffix = ou=Computers
ldap suffix = dc=example,dc=com
passdb backend = tdbsam
wins support = yes
*kopfkratz*
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Zunächst möchte ich mich für die rege Anteilnahme bedanken :shock:

Habe soeben die 3.0.20rc2 auf die Release-Version geupdatet und das *scheint* zu helfen. Zumindest ist ein solcher reproduzierbarer Fehler jetzt weg. Endgültige Ergebnisse gibts erst nach ausführlichem Test.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Antworten