Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Desktop-Datenbank Win2K

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
siemens
Newbie
Newbie
Beiträge: 2
Registriert: 15. Aug 2005, 16:58
Wohnort: Aurich

Desktop-Datenbank Win2K

Beitrag von siemens »

Moin,

Ich brauche Unterstützung bei der Konfiguration meines Netzwerks:
ich habe Suse 9.3 Professional als Server eingesetzt. Die Clients laufen unter Windows 2000 (SP4). Auf dem Server liegt eine dBase-Datenbank über die mit der Borland Database Engine zugegriffen wird.
Das Problem taucht bei 2 gleichzeitig zugreifenden Clients auf:
der erste Client hat nach 2 Sekunden alle Datentabellen geöffnet. Alle folgenden Clients brauchen 20 (!) Sekunden.

Ich habe in der smb.conf oplocks deaktiviert (Auszug siehe unten). In der Registry der Clients sind oplocks auch deaktiviert:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters]
"CscEnabled"=dword:00000001

Setzt man die dbase-Tabellen auf ReadOnly haben alle Clients nach 2 Sekunden die Dateien geöffnet.

MS - Access Dateien sind von diesem Problem auch betroffen. Es sollte also kein BDE - Problem sein.
Im Netz läuft ein Win98 - Client, der von diesem Problem aber nicht betroffen ist.
Es kann aber kein reines Client-Problem sein, da die dbase-Tabellen zuvor auf einem Novell 3.12 Server problemlos geöffnet werden konnten.

Kennt jemand die Parameter die bei Samba und/oder bei Windows2000 eingestellt werden müssen, damit der Zugriff besser funktioniert.

- Danke -

mit freundlichem Gruß

Dieter Siemens
-----------------------
siemens@goldschmaus.de
-----------------------


meine smb.conf
[global]
workgroup = MITTELERDE
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon script = scripts\logon.bat
logon path = \\%L\Profiles\%U
logon drive = H:
logon home = \\%L\%U
domain logons = yes
os level = 65
preferred master = yes
domain master = yes
winbind uid = 15000-20000
winbind gid = 15000-20000
restrict anonymous = no
wins support = yes
max protocol = NT1
ldap ssl = No
server signing = Auto
printcap name = lpstat
use client driver = Yes
printer admin = root
case sensitive = no
msdfs proxy = no
read only = no
username map = /etc/samba/smbusers
server string = linux
deadtime = 1440
idmap gid = 15000-20000
idmap uid = 15000-20000
locking = yes
lock spin time = 15
lock spin count = 30
socket options = TCP_NODELAY SO_SNDBUF=65536 SO_RCVBUF=65536 IPTOS_LOWDELAY
use sendfile = no
oplocks = no
level2 oplocks = no
[sys]
comment = Anwender Daten
path = /home/sys
guest ok = yes
create mask = 0775
directory mask = 0775
oplocks = no
level2 oplocks = no
siemens
Newbie
Newbie
Beiträge: 2
Registriert: 15. Aug 2005, 16:58
Wohnort: Aurich

Beitrag von siemens »

Moin,

das Problem ist zwar nicht gelöst, aber umgangen:
Der Win2000-Client arbeitet nicht sauber mit dem Linux-Samba-Server zusammen. (keine Ahnung, wer Schuld ist)
Besser und deutlich schneller läuft alles mit NFS. MS stellt unter dem Namen SFU (Support For Unix) einen NFS-Client zur Verfügung.

http://www.microsoft.com/windowsservers ... fault.mspx

Anders als Samba unterscheidet NFS aber zwischen GROSS und klein Buchstaben und die Autentifizierung läuft andern. (Man kann nicht alles haben).

Ein Mischbetrieb ist möglich:
SMB für normale Dateien, Dokumente, Drucker etc und
NFS für Desktop-Datenbanken
Antworten