Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] DHCP Server macht Probleme

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Niko_K
Newbie
Newbie
Beiträge: 44
Registriert: 7. Sep 2004, 12:45
Kontaktdaten:

[gelöst] DHCP Server macht Probleme

Beitrag von Niko_K »

Hi,

ich habe hier bei mir ein NSLU2 von Linksys stehen, auf dem eine unslung firmware installiert ist (damit kann man auf dem kleinen device eine art apt verwenden).

Jetzt habe ich darauf dnsmasq installiert und komme damit leider nicht ganz klar. Die DNS Auflösung scheint zu funktionieren, aber ich will auch die DHCP Funktion von dnsmasq verwenden!

Immer wenn ich meinen SuSE Client sage, dass er seine IP Adresse und die Nameserver per DHCP beziehen soll, dann gibt es Probleme. Ich bekomme zwar eine IP Adresse und ich kann auch pings auf das nslu2 und die gateway durchführen, aber im internet klappt kaum was.
Die Anfragen kommen so gut wie nie durch (komischerweise schaffen sie es manchmal für so ungefähr 15min).

Ich bin am rätseln ob das was mit der lease time oder auch mit ip forwarding zu tun hat, aber leider ist das mein erster dns und dhcp server den ich konfiguriere... ich kann also nicht behaupten dass ich mich damit auskenne.

Hat jemand eine Idee?
Niko
Zuletzt geändert von Niko_K am 11. Okt 2005, 09:41, insgesamt 2-mal geändert.
Niko_K
Newbie
Newbie
Beiträge: 44
Registriert: 7. Sep 2004, 12:45
Kontaktdaten:

Wieder ein bisschen herumprobiert

Beitrag von Niko_K »

Hi,

ich habe heute wieder mal ein wenig Zeit gefunden den Fehler bei meinem dnsmasq zu suchen. Ich hab mal die logs aktiviert und nachgesehen, wann genau der Server flöten geht.

Also mein config file sieht jetzt so aus:

Code: Alles auswählen

# General Settings:
###################

domain-needed
bogus-priv
strict-order
expand-hosts
domain=krismer.lan

# DHCP Settings:
################

dhcp-range=192.168.0.1,192.168.0.9
# set the standard gateway
dhcp-option=3,192.168.0.10
# set the DNS
dhcp-option=6,192.168.0.30
# enable IP forwarding
#dhcp-option=19,1
dhcp-leasefile=/var/lib/misc/dnsmasq.leases

# Fixed IP Adresses:
#-------------------
dhcp-host=00:0e:0c:65:26:69,192.168.0.1,desktop,infinite,override-static
dhcp-host=00:a0:d1:d6:73:e9,192.168.0.2,laptop,infinite,override-static
dhcp-host=00:04:23:69:d4:3d,192.168.0.21,server,infinite,override-static

log-queries
Das override-static war nötig, weil ich die drei fix eingetragenen Rechner auch in der /etc/hosts habe (damir arbeitet die lokale namensauflösung; was sie bei durch dhcp hinzugefügte einträge nicht macht...).

Die Log Datei sieht bei mir so aus (mit eigenen Kommentaren):

Code: Alles auswählen

# Funktionierender Ausgangsstatus:

<30>Aug 24 18:17:45 dnsmasq[1149]: started, version 2.15 cachesize 150
<30>Aug 24 18:17:45 dnsmasq[1149]: DHCP, IP range 192.168.0.1 -- 192.168.0.9, lease time 1h
<30>Aug 24 18:17:45 dnsmasq[1149]: read /etc/hosts - 11 addresses
<30>Aug 24 18:17:45 dnsmasq[1149]: reading /etc/resolv.conf
<30>Aug 24 18:17:45 dnsmasq[1149]: using nameserver 195.3.96.68#53
<30>Aug 24 18:17:45 dnsmasq[1149]: using nameserver 195.3.96.67#53
<31>Aug 24 18:19:43 dnsmasq[1149]: query www.usenetlinux.com[AAAA] from 192.168.0.1
<31>Aug 24 18:19:43 dnsmasq[1149]: forwarded www.usenetlinux.com to 195.3.96.67
<31>Aug 24 18:19:43 dnsmasq[1149]: query www.usenetlinux.com.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:19:43 dnsmasq[1149]: forwarded www.usenetlinux.com.krismer.lan to 195.3.96.67
<31>Aug 24 18:19:44 dnsmasq[1149]: query www.usenetlinux.com[A] from 192.168.0.1
<31>Aug 24 18:19:44 dnsmasq[1149]: forwarded www.usenetlinux.com to 195.3.96.67
<31>Aug 24 18:19:44 dnsmasq[1149]: reply www.usenetlinux.com is 147.4.70.85
<31>Aug 24 18:19:45 dnsmasq[1149]: query itxt2.us.intellitxt.com[AAAA] from 192.168.0.1
<31>Aug 24 18:19:45 dnsmasq[1149]: forwarded itxt2.us.intellitxt.com to 195.3.96.67
<31>Aug 24 18:19:45 dnsmasq[1149]: query itxt2.us.intellitxt.com.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:19:45 dnsmasq[1149]: forwarded itxt2.us.intellitxt.com.krismer.lan to 195.3.96.67
<31>Aug 24 18:19:45 dnsmasq[1149]: query itxt2.us.intellitxt.com[A] from 192.168.0.1
<31>Aug 24 18:19:45 dnsmasq[1149]: forwarded itxt2.us.intellitxt.com to 195.3.96.67
<31>Aug 24 18:19:45 dnsmasq[1149]: reply itxt2.us.intellitxt.com is 161.4.63.209
<31>Aug 24 18:19:45 dnsmasq[1149]: query a.tribalfusion.com[AAAA] from 192.168.0.1
<31>Aug 24 18:19:45 dnsmasq[1149]: forwarded a.tribalfusion.com to 195.3.96.67
<31>Aug 24 18:19:45 dnsmasq[1149]: query a.tribalfusion.com.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:19:45 dnsmasq[1149]: forwarded a.tribalfusion.com.krismer.lan to 195.3.96.67
<31>Aug 24 18:19:45 dnsmasq[1149]: query a.tribalfusion.com[A] from 192.168.0.1
<31>Aug 24 18:19:45 dnsmasq[1149]: forwarded a.tribalfusion.com to 195.3.96.67
<31>Aug 24 18:19:45 dnsmasq[1149]: reply a.tribalfusion.com is 204.11.109.61
<31>Aug 24 18:19:45 dnsmasq[1149]: reply a.tribalfusion.com is 204.11.109.62
<31>Aug 24 18:19:45 dnsmasq[1149]: reply a.tribalfusion.com is 204.11.109.63
<31>Aug 24 18:19:45 dnsmasq[1149]: reply a.tribalfusion.com is 204.11.109.64

# Laptop sendet nun einen dhcp lease und einen sofortigen renew...

<30>Aug 24 18:20:01 dnsmasq[1149]: DHCPRELEASE(ixp0) 192.168.0.2 00:a0:d1:d6:73:e9
30>Aug 24 18:20:03 dnsmasq[1149]: DHCPDISCOVER(ixp0) 192.168.0.2 00:a0:d1:d6:73:e9
<30>Aug 24 18:20:03 dnsmasq[1149]: DHCPOFFER(ixp0) 192.168.0.2 00:a0:d1:d6:73:e9
<30>Aug 24 18:20:03 dnsmasq[1149]: DHCPREQUEST(ixp0) 192.168.0.2 00:a0:d1:d6:73:e9
<30>Aug 24 18:20:03 dnsmasq[1149]: DHCPACK(ixp0) 192.168.0.2 00:a0:d1:d6:73:e9 override-static

# Jetzt funktioniert nichts mehr...

# Also mal sehen, ob der Router noch antwortet (ja, der antwortet noch)

<31>Aug 24 18:20:36 dnsmasq[1149]: query router.krismer.lan[A] from 192.168.0.1
<31>Aug 24 18:20:36 dnsmasq[1149]: /etc/hosts router.krismer.lan is 192.168.0.10
<31>Aug 24 18:20:36 dnsmasq[1149]: query 10.0.168.192.in-addr.arpa[PTR] from 192.168.0.1
<31>Aug 24 18:20:36 dnsmasq[1149]: /etc/hosts 192.168.0.10 is router.krismer.lan

# Versuchen wirs sicherheitshalber nocheinmal...

<31>Aug 24 18:21:22 dnsmasq[1149]: query www.orf.at[AAAA] from 192.168.0.1
<31>Aug 24 18:21:22 dnsmasq[1149]: forwarded www.orf.at to 195.3.96.67
<31>Aug 24 18:21:27 dnsmasq[1149]: query www.orf.at[AAAA] from 192.168.0.1
<31>Aug 24 18:21:27 dnsmasq[1149]: forwarded www.orf.at to 195.3.96.68
<31>Aug 24 18:21:32 dnsmasq[1149]: query www.orf.at.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:21:32 dnsmasq[1149]: forwarded www.orf.at.krismer.lan to 195.3.96.67
<31>Aug 24 18:21:37 dnsmasq[1149]: query www.orf.at.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:21:37 dnsmasq[1149]: forwarded www.orf.at.krismer.lan to 195.3.96.68
<31>Aug 24 18:21:42 dnsmasq[1149]: query www.orf.at[A] from 192.168.0.1
<31>Aug 24 18:21:42 dnsmasq[1149]: forwarded www.orf.at to 195.3.96.67
<31>Aug 24 18:21:47 dnsmasq[1149]: query www.orf.at[A] from 192.168.0.1
<31>Aug 24 18:21:47 dnsmasq[1149]: forwarded www.orf.at to 195.3.96.68

# Eine Minute später versuchen wir erneut eine Website zu laden...

<31>Aug 24 18:22:40 dnsmasq[1149]: query www.computerbase.de[AAAA] from 192.168.0.1
<31>Aug 24 18:22:40 dnsmasq[1149]: forwarded www.computerbase.de to 195.3.96.67
<31>Aug 24 18:22:40 dnsmasq[1149]: query www.computerbase.de.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:22:40 dnsmasq[1149]: forwarded www.computerbase.de.krismer.lan to 195.3.96.67
<31>Aug 24 18:22:40 dnsmasq[1149]: query www.computerbase.de[A] from 192.168.0.1
<31>Aug 24 18:22:40 dnsmasq[1149]: forwarded www.computerbase.de to 195.3.96.67

# ... und jetzt funktioniert es... wieso???

<31>Aug 24 18:22:40 dnsmasq[1149]: reply www.computerbase.de is 216.4.80.237
<31>Aug 24 18:22:41 dnsmasq[1149]: query pics.computerbase.de[AAAA] from 192.168.0.1
<31>Aug 24 18:22:41 dnsmasq[1149]: forwarded pics.computerbase.de to 195.3.96.67
<31>Aug 24 18:22:41 dnsmasq[1149]: query pics.computerbase.de.krismer.lan[AAAA] from 192.168.0.1
<31>Aug 24 18:22:41 dnsmasq[1149]: forwarded pics.computerbase.de.krismer.lan to 195.3.96.67
<31>Aug 24 18:22:46 dnsmasq[1149]: query pics.computerbase.de.krismer.lan[AAAA] from 192.168.0.1
In dem Log kann der Server eine Minute lang gar nichts machen (ist ein NSLU2... zwar nicht der Server mit enormer Rechenleistung, aber das Ding läuft bei mir immerhin mit 266Mhz).

Es kommt schon mal vor, dass der Server nicht nur eine Minute nichts macht, sondern auch mal länger (das hat auch schon mehrere Stunden gedauert... allerdings kam da der Reqeust immer von dem Rechner, der per dhcp zugewiesen wurde...)

Ach ja, was man vielleicht noch wissen sollte. Der Laptop (192.168.0.2) wurde per dhcp zugewiesen. Der Desktop PC ist zwar auch im config file eingetragen, in dem Beispiel verwendete er (192.168.0.1) aber kein dhcp!

Kann aus dem log jemand schlauer werden als ich?
Niko
Niko_K
Newbie
Newbie
Beiträge: 44
Registriert: 7. Sep 2004, 12:45
Kontaktdaten:

Zusammenfasung

Beitrag von Niko_K »

Hi,

also ich hab mir die logs und alles nochmal genauer angesehen.
Anscheinend liegt das Problem dabei nicht wirklich am DHCP Server.

Mein Router schreint aber keine DHCP Requests an den Server zu vertragen (naja, eigtnlich laufen die Request nur über den Switch... und ganz erklären kann ich mir das auch nicht), aber es kommt meist (nicht immer) vor, dass wenn ich ein dhcp renew mache, dass ich dann von keinem rechner aus, den router pingen kann.

Manchmal schmiert der Router komplett ab (deshalb wohl meherer Stunden Wartezeit...) und manchmal nur für wenige Minuten (erklärt die log oben)!

Ich bin mir noch nicht zu 100% sicher, wie das bei DHCP Requests ist, die nicht als statisch in der config file eingetragen sind, aber das ist mir auch nicht soo wichtig.

Ich werde vermutlich Ende September von der Telekom einen neuen Router bekommen, weil die haben da grad so ne xDSL Aktion bei mir zu Hause in der Region laufen ;-) (der Router soll angeblich von Cisco sein... ich persönlich denke eher linksys (steht ja auch cisco drauf; is halt die billig schiene)... auf jeden Fall klingst gut)
Trifft sich ja gut!!

In diesem Sinne,
Niko
Niko_K
Newbie
Newbie
Beiträge: 44
Registriert: 7. Sep 2004, 12:45
Kontaktdaten:

Router

Beitrag von Niko_K »

Hi,

nachdem ich nun einige Zeit meinen neuen Router hab, kann ich sagen, dass es mit Sicherheit der Router war. So ein Billigteil halt...

Niko
Antworten