Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Prozesse?!?

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
» blade
Newbie
Newbie
Beiträge: 12
Registriert: 30. Jun 2005, 21:28

Prozesse?!?

Beitrag von » blade »

Hi

Ich hab seit einigen Tagen ja nen Linux SuSE 9.2 Server hier zu hause stehn und hab den auch schon teilweise konfiguriert. Der Server soll für ne LAN Party sein, bei der ich TurnierOrga bin und dafür ein paar Gameserver brauche. Außerdem soll auf dem Server nen TeamSpeak laufen. Beides (GS und TS2) hab ich am laufen, aber über ps uax bekomm ich einige Prozesse mehr. Jetzt frag ich mich natürlich, ob ich die für nen Gameserver und nen Voiceserver brauche. Vielleicht könnt ihr mir ja helfen. Außerdem wollte ich den Gameservern über nice eine erhöhte Priorität zuweisen, aber da kam eine Fehlermeldung. Vielleicht kann mir auch da jemand helfen.
Seht euch einfach mal die Quote's an... Danke schonmal...
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
root 1 0.0 0.0 596 236 ? S Aug12 0:01 init [3]
root 2 0.0 0.0 0 0 ? S Aug12 0:00 [migration/0]
root 3 0.0 0.0 0 0 ? SN Aug12 0:00 [ksoftirqd/0]
root 4 0.0 0.0 0 0 ? S Aug12 0:00 [migration/1]
root 5 0.0 0.0 0 0 ? SN Aug12 0:00 [ksoftirqd/1]
root 6 0.0 0.0 0 0 ? S< Aug12 0:00 [events/0]
root 7 0.0 0.0 0 0 ? S< Aug12 0:00 [events/1]
root 8 0.0 0.0 0 0 ? S< Aug12 0:00 [khelper]
root 9 0.0 0.0 0 0 ? S< Aug12 0:00 [netlink/0]
root 10 0.0 0.0 0 0 ? S< Aug12 0:00 [netlink/1]
root 11 0.0 0.0 0 0 ? S< Aug12 0:00 [kblockd/0]
root 12 0.0 0.0 0 0 ? S< Aug12 0:00 [kblockd/1]
root 44 0.0 0.0 0 0 ? S Aug12 0:00 [pdflush]
root 43 0.0 0.0 0 0 ? S Aug12 0:00 [kirqd]
root 45 0.0 0.0 0 0 ? S Aug12 0:00 [pdflush]
root 47 0.0 0.0 0 0 ? S< Aug12 0:00 [aio/0]
root 46 0.0 0.0 0 0 ? S Aug12 0:00 [kswapd0]
root 48 0.0 0.0 0 0 ? S< Aug12 0:00 [aio/1]
root 630 0.0 0.0 0 0 ? S Aug12 0:00 [kseriod]
root 1395 0.0 0.0 0 0 ? S< Aug12 0:00 [ata/0]
root 1396 0.0 0.0 0 0 ? S< Aug12 0:00 [ata/1]
root 1398 0.0 0.0 0 0 ? S Aug12 0:00 [scsi_eh_0]
root 1399 0.0 0.0 0 0 ? S Aug12 0:00 [scsi_eh_1]
root 1544 0.0 0.0 0 0 ? S Aug12 0:00 [kjournald]
root 2132 0.0 0.0 0 0 ? S Aug12 0:00 [khubd]
root 2180 0.0 0.0 1360 308 ? S<s Aug12 0:00 udevd
root 2441 0.0 0.0 1432 436 ? S Aug12 0:00 [hwscand]
root 3602 0.0 0.0 1444 620 ? Ss Aug12 0:00 /sbin/syslogd -a /var/lib/named/dev/log -a /var/lib/ntp/dev/log
root 3628 0.0 0.0 1520 580 ? Ss Aug12 0:00 /sbin/klogd -c 1 -2 -x
root 3653 0.0 0.0 1408 484 ? Ss Aug12 0:00 /sbin/resmgrd
root 3675 0.0 0.1 4708 1292 ? Ss Aug12 0:00 /usr/sbin/saslauthd -a pam
root 3677 0.0 0.0 2072 924 ? Ss Aug12 0:00 /usr/sbin/xinetd
root 3679 0.0 0.1 4708 1292 ? S Aug12 0:00 /usr/sbin/saslauthd -a pam
root 3680 0.0 0.1 4708 1292 ? S Aug12 0:00 /usr/sbin/saslauthd -a pam
root 3681 0.0 0.1 4708 1292 ? S Aug12 0:00 /usr/sbin/saslauthd -a pam
root 3682 0.0 0.1 4708 1292 ? S Aug12 0:00 /usr/sbin/saslauthd -a pam
root 3718 0.0 0.2 5156 2064 ? Ss Aug12 0:00 /usr/sbin/sshd -o PidFile=/var/run/sshd.init.pid
root 3886 0.0 0.0 43096 836 ? Ssl Aug12 0:00 /usr/sbin/nscd
root 3905 0.0 0.0 1660 604 ? Ss Aug12 0:00 /usr/sbin/cron
root 3920 0.0 0.0 1824 620 tty1 Ss+ Aug12 0:00 /sbin/mingetty --noclear tty1
root 3921 0.0 0.0 1824 620 tty2 Ss+ Aug12 0:00 /sbin/mingetty tty2
root 3922 0.0 0.0 1824 620 tty3 Ss+ Aug12 0:00 /sbin/mingetty tty3
root 3923 0.0 0.0 1824 620 tty4 Ss+ Aug12 0:00 /sbin/mingetty tty4
root 3924 0.0 0.0 1824 620 tty5 Ss+ Aug12 0:00 /sbin/mingetty tty5
root 3925 0.0 0.0 1824 620 tty6 Ss+ Aug12 0:00 /sbin/mingetty tty6
und...
fallen-soulz:~ # nice /home/hlds1/hlds_run -15
Invalid game type 'valve' sepecified.
Ich nehm mal an, dass ich da bei dem Versuch die Priorität zu erhöhren einen Fehler gemacht hab.

Mit freundlichen Grüßen

» blade
Bild
fabian2de
Newbie
Newbie
Beiträge: 11
Registriert: 10. Mai 2005, 17:08

Re: Prozesse?!?

Beitrag von fabian2de »

» blade hat geschrieben:
fallen-soulz:~ # nice /home/hlds1/hlds_run -15
Invalid game type 'valve' sepecified.
Ich nehm mal an, dass ich da bei dem Versuch die Priorität zu erhöhren einen Fehler gemacht hab.
Mit freundlichen Grüßen
» blade
also zu den einzelnen Prozessen kann ich dir leider nichts sagen, aber bei der Priorität hast du die Parameter für hlds_run vergessen... ( -game cstrike -port ) usw.

ich hoffe ich konnte dir helfen :)
flo41
Hacker
Hacker
Beiträge: 290
Registriert: 9. Feb 2005, 11:47

Beitrag von flo41 »

die prozesse sehen alle eigentlich in ordnung aus...
Du kannst aber mal mit dem Yast runlevel-editor schauen welche prozesse beim systemstart gestartet werden und deaktivieren wenn du sie nicht brauchst...
» blade
Newbie
Newbie
Beiträge: 12
Registriert: 30. Jun 2005, 21:28

Beitrag von » blade »

also die prozesse sind in ordnung, aber das problem mit "nice" hab ich immernoch. hat jemand ne idee? ich will halt den gameservern eine erhöte Prio geben.
Bild
Benutzeravatar
TeXpert
Guru
Guru
Beiträge: 2166
Registriert: 17. Jan 2005, 11:22

Beitrag von TeXpert »

Code: Alles auswählen

$ man nice

SYNOPSIS
       nice [OPTION] [COMMAND [ARG]...]
und was machst Du?

Code: Alles auswählen

# nice /home/hlds1/hlds_run -15 
denk mal drüber nach ;)

Code: Alles auswählen

# to resolve all your problems, try this:
HOWTO='pack c5,41*2,sqrt 7056,unpack(c,H)-2,oct 115' && perl -le "print $HOWTO"
Ich beantworte keine Supportfragen per PM!
» blade
Newbie
Newbie
Beiträge: 12
Registriert: 30. Jun 2005, 21:28

Beitrag von » blade »

Texpert das hab ich auch schon selber heraus gefunden. Habs auch anders gemacht. Nämlich nice -20 /home/hlds1/hlds_run ... mit parametern. Jedoch kam dann die selbe Fehlermeldung
Bild
Antworten