Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Cyus IMAP- Post da, aber kein Zugriff drauf

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
scoopy
Newbie
Newbie
Beiträge: 24
Registriert: 15. Apr 2005, 14:35

Cyus IMAP- Post da, aber kein Zugriff drauf

Beitrag von scoopy »

Hallo!

Mein Cyrus IMAP läuft soweit.
Kann Mails lokal versenden und die werden auch auf die Postfächer verteilt.(In /var/spool/mail)
Kann dann aber mit Mozilla nicht drauf zugreifen. "Login auf dem Server meins fehlgeschlagen!"

Die Authentifikation soll über ldap laufen.

Hab momentan in meiner /etc/imapd.conf

folgende Einträge drin:

sasl_pwcheck_method: ldap
ldap_auth: user
ldap_bind_dn: cn=user,dc=172.21.2.218,dc=de
ldap_base: dc=172.21.2.21.8,dc=de
ldap_filter: uid=%u
ldap_realm: Anmeldung am Proxyserver!
ldap_password: 'geheim'
sasl_ldap_basedn: dc=172.21.2.218,dc=de


Stimmt das so oder fehlt noch was?

Danke!
Ich kann ja nicht alles wissen...
Z-City
Hacker
Hacker
Beiträge: 649
Registriert: 17. Jan 2005, 15:16
Wohnort: Kreis Karlsruhe
Kontaktdaten:

Beitrag von Z-City »

Ist da nicht ein Punkt zuviel drin:
ldap_base: dc=172.21.2.21.8,dc=de
stka
Moderator
Moderator
Beiträge: 3351
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Beitrag von stka »

Zum einen ist der Eintrag mit dem ldap_realm falsch, dort muss der Domain-suffix der Maschine stehen. zum anderen, solltest du das ganze über den saslauth machen, das ist besser, hier mal ein Tipp:
In der Datei /etc/sysconfig/saslauthd den Parameter SASLAUTHD_AUTHMECH von "pam" auf "ldap" umstellen. Dann eine Datei /etc/saslautd.conf mit folgendem Inhalt erstellen:

Code: Alles auswählen

ldap_servers: ldap://localhost/
ldap_version: 3
ldap_search_base: dc=home,dc=stka
ldap_bind_dn: uid=cyrus,ou=users,dc=home,dc=stka
ldap_bind_pw: geheim
ldap_filter: (uid=%U)
ldap_scope: sub
#ldap_tls_check_peer: yes
#ldpa_tls_cacert_file: /etc/openldap/demoCA/cacert.pem
#ldap_tls_cacert_dir: /etc/openldap/demoCA
#ldap_tls_cert: /etc/openldap/ldapcert.pem
#ldap_tls_key: /etc/openldap/ldapkey.pem
Hier gleich mit deb Parametern für TLS. Der Benutzer uid=cyrus ist nur ein "Simple Security Object" Also ein Ojekt das nur einen Namen und ein Passwort hat. Damit kann sich niemand am System anmelden. Da Objekt dient nur zur Authentifizierung beim Zugriff durch cyrus auf den LDAP-Baum, damit das ganze nicht anonym klappt. Die Rechte solten hier auf 640 stehen ;-)
Die imapd.conf sieht dann so aus:
configdirectory: /var/lib/imap
partition-default: /var/spool/imap
sievedir: /var/lib/sieve
admins: cyrus root
allowanonymouslogin: no
autocreatequota: 10000
reject8bit: no
quotawarn: 90
timeout: 30
poptimeout: 10
dracinterval: 0
drachost: localhost
sasl_pwcheck_method: saslauthd
sasl_mech_list: PLAIN LOGIN
lmtp_overquota_perm_failure: no
#
# if you want TLS, you have to generate certificates and keys
#
#tls_cert_file: /etc/postfix/cert/mailcert.pem
#tls_key_file: /etc/postfix/cert/mailkey.pem
#tls_ca_file: /etc/postfix/cert/demoCA/cacert.pem
#tls_ca_path: /etc/postfix/cert/demoCA
Jetzt startest du deinen cyrus neu.
Dann kannst du mit
testsaslauthd -u <user> -p <passwort>
Testen ob alles klappt. Als Antwort solltest du
0: OK "SUCCESS".
erhalten.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
scoopy
Newbie
Newbie
Beiträge: 24
Registriert: 15. Apr 2005, 14:35

Beitrag von scoopy »

Hatte soweit nix weiter falsch. Hab den Eintrag
geändert auf sasl_pwcheck_method: saslauthd

Die ldap-Einträge wieder raus genommen.

Und in /etc noch eine saslauthd.conf angelegt,

da folgendes eingetragen:

ldap_servers: ldap://meins/
ldap_search_base: dc=meins,dc=de
ldap_bind_dn: cn=user,dc=meins,dc=de
ldap_bind_pw: user

rccyrus restart

Und fertig. Dann ging das ganze.
Ich kann ja nicht alles wissen...
Gesperrt