Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Samba - Keine schreibrechte beim Supersurferstart

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
toe
Newbie
Newbie
Beiträge: 4
Registriert: 11. Aug 2005, 13:57

Samba - Keine schreibrechte beim Supersurferstart

Beitrag von toe »

Hallo,

habe ein seltsames Problem mit Samba,

ich hab Samba konfiguriert und mit nmbd -D & smbd -D gestartet ->
Resultat: alles läuft wunderbar kann das Share von WinXP aus sehen, und darauf schreiben.

Dann hab ich samba als Dienst beim Systemstart eingerichtet (/etc/init.d).
Jedoch hab ich komischerweise auf die Shares nach nem neustart keine schreibrechte mehr.
Wenn ich allerdings auf der Konsoloe dann "service smb restart" eingebe hab ich auch wieder schreibrechte.

Was auch komisch ist, ich hab den kompletten Printer-Teil in der /etc/samba/smb.conf auskommentiert. Wenn ich nun von Win aus auf den Linux-Rechner zugreife, sehe ich nur meine Freigaben, sag ich dann Anzeige aktualisieren sehe ich wieder "Drucker und Faxgeräte" gut das ist nicht so dramatisch aber währe trotzdem interessant zu wissen wieso ?

Währe euch Linux-Gurus wirklich dankbar für eure Unterstützung.


Linux: Fedora Core 4
Samba: 3.0.14a-2

Viele Grüße
toe
Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

Beitrag von zero0109 »

Fedora hat doch einen eigenen grafischen Editor, in dem du die Dienste auswählen kannst, die beim Systemstart gestartet werden sollen, vielleicht versuchst du es mal damit.
toe
Newbie
Newbie
Beiträge: 4
Registriert: 11. Aug 2005, 13:57

Beitrag von toe »

Das hab ich gemacht. Wie gesagt das funzt ja soweit auch.
Die Dienste fahren am anfang ja alle hoch ich hab nur keine schreibrechte auf die shares solang bis ich den Dienst nicht neu gestartet hab mit "service smb restart"
:roll:

Hab noch herausgefunden dass wenn ich auf der Linux Kiste smbstatus ausführe nach dem reboot (mit geöffneter textdatei) zeigt er mir das an:

Code: Alles auswählen

Samba version 3.0.14a-2
PID     Username      Group         Machine
-------------------------------------------------------------------
 2407   pftpuser      pureftpusers  pc-toe       (192.168.11.105)

Service      pid     machine       Connected at
-------------------------------------------------------
DATEN         2407   pc-toe        Thu Aug 11 15:35:15 2005
IPC$          2407   pc-toe        Thu Aug 11 15:35:23 2005

No locked files
gleiche prozedur nach neustart des service:

Code: Alles auswählen

Samba version 3.0.14a-2
PID     Username      Group         Machine
-------------------------------------------------------------------
 2461   pftpuser      pureftpusers  pc-toe       (192.168.11.105)

Service      pid     machine       Connected at
-------------------------------------------------------
IPC$          2461   pc-toe        Thu Aug 11 15:38:43 2005
IPC$          2461   pc-toe        Thu Aug 11 15:38:43 2005
DATEN         2461   pc-toe        Thu Aug 11 15:38:22 2005

Locked files:
Pid    DenyMode   Access      R/W        Oplock           Name
--------------------------------------------------------------
2461   DENY_NONE  0x20089     RDONLY     EXCLUSIVE+BATCH  /DATEN/UserDir01/userdir01.txt   Thu Aug 11 15:38:43 2005
da steht RDONLY kann aber trotzdem schreiben ????

vielleicht hilft das was, und was ich auch nicht herausgefunden hab was es bedeutet ist wenn ich testparam starte meldet er mir

Server role: ROLE_STANDALONE

Code: Alles auswählen

Load smb config files from /etc/samba/smb.conf
Processing section "[DATEN]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
        workgroup = BlaBlaBla
        server string = FTP-Portalserver
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431

[DATEN]
        comment = Freigegebene Daten
        path = /DATEN
        valid users = pftpuser
        read only = No
        create mask = 0770
        directory mask = 0770
Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

Beitrag von zero0109 »

Hmm, auch wenns damit vermutlich nichts zu tun hat, aber weshalb hast du eine idmap uid/gid gesetzt? Kommentier das doch einfach mal aus, soweit du keinen besonderen Grund dafür hast. Und du könntest testweise mal die create und die directory mask auf 0777 setzen (und dann natürlich eine neue Datei erstellen und damit arbeiten).
toe
Newbie
Newbie
Beiträge: 4
Registriert: 11. Aug 2005, 13:57

Beitrag von toe »

Dank erstmal für die Antworten,

aber hat leider auch nichts an dem Problem geändert,
startet der supersurfer als root oder wo ist der unterschied vom System-Service-start und dem manuellen service-start als root?

MfG toe
toe
Newbie
Newbie
Beiträge: 4
Registriert: 11. Aug 2005, 13:57

Beitrag von toe »

:D Problemlösung nahe: :idea:

Ich hab jetzt den Samba Dienst beim Systemstart entfernt und in der rc.local folgende Zeilen ergänzt:

Code: Alles auswählen

sudo nmbd -D
sudo smbd -D
jetzt hab ich Samba mit schreibrechten aber warum?????

Werden services mit anderen Rechten gestartet als bei sudo ?

kann mir da jemand näheres sagen ?

grüsse toe
Antworten