Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

DHCP Server startet nicht

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

DHCP Server startet nicht

Beitrag von Sveniboy1984 »

Moin Moin,

ich hab in meiner Suse Linux 9.3 Kiste 2 Netzwerkkarten installiert.
Beide Karten sind an 2 verschiedene Switch angeschlossen.

Ich wollte eine Netzwerkkarte zum DHCP-Server machen.
Hab unter Yast schön alles eingestellt und wenn ich auf Beenden mache und Linux alles konfiguriert dann kommt die Fehlermeldung:
"Konnte den DHCP Daemon nicht starten"

Wenn ich in der Shell "rcdhcpd start" eingebe, kommt folgendes:

Starting DHCP server Internet Systems Consortium DHCP Server V3.0.2
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
/var/lib/dhcp///etc/dhcpd.conf line 6: expecting numeric value.
subnet netmask
^
/var/lib/dhcp///etc/dhcpd.conf line 11: expecting numeric value.
subnet netmask
^
Configuration file errors encountered -- exiting

If you did not get this software from ftp.isc.org, please
get the latest from ftp.isc.org and install that before
requesting help.

If you did get this software from ftp.isc.org and have not
yet read the README, please read it before requesting help.
If you intend to request help from the dhcp-server@isc.org
mailing list, please read the section on the README about
submitting bug reports and requests for help.

Please do not under any circumstances send requests for
help directly to the authors of this software - please
send them to the appropriate mailing list as described in
the README file.

/etc/sysconfig/dhcpd:

## Path: Network/DHCP/DHCP server
## Description: DHCP server settings
## Type: string
## Default: ""
## ServiceRestart: dhcpd
#
# Interface(s) for the DHCP server to listen on.
#
# Instead of the interface name, the name of its configuration can be given.
# If the configuration file is named
# /etc/sysconfig/network/ifcfg-eth-id-00:50:fc:e4:f2:65
# then id-00:50:fc:e4:f2:65 would be suitable to identify the configuration.
#
# Examples: DHCPD_INTERFACE="eth0"
# DHCPD_INTERFACE="eth0 eth1 eth2 tr0 wlan0"
# DHCPD_INTERFACE="internal0 internal1"
# DHCPD_INTERFACE="id-00:50:fc:e4:f2:65 id-00:a0:24:cb:cc:5c wlan0"
#
DHCPD_INTERFACE="eth-id-00:05:5d:fb:5d:93"

## Type: yesno
## Default: yes
## ServiceRestart: dhcpd
#
# Shall the DHCP server dhcpd run in a chroot jail (/var/lib/dhcp)?
#
# Each time you start dhcpd with the init script, /etc/dhcpd.conf will
# be copied to /var/lib/dhcp/etc/.
#
# Some files that are important for hostname to IP address resolution
# (/etc/{hosts,host.conf,resolv.conf,localtime}, /lib/libnss_dns.so.2,
# /lib/libresolv.so.2) will also be copied to the chroot jail by the
# init script when you start it (about 100kB altogether).
#
# The pid file will be in /var/lib/dhcp/var/run/dhcpd.pid.
#
DHCPD_RUN_CHROOTED="yes"

## Type: string
## Default: ""
## ServiceRestart: dhcpd
#
# Since version 3, dhcpd.conf can contain include statements.
# If you enter the names of any include files here, _all_ conf
# files will be copied to $chroot/etc/, when dhcpd is started in the
# chroot jail. (/etc/dhcpd.conf is always copied.)
#
# For your convenience, you can also specify entire directories, like
# "/etc/dhcpd.conf.d".
#
# Example: "/etc/dhcpd.conf.shared /etc/dhcpd.conf.bootp-clients"
#
DHCPD_CONF_INCLUDE_FILES=""

## Type: string
## Default: "dhcpd"
## ServiceRestart: dhcpd
#
# Leave empty or enter "root" to let dhcpd run as root.
# Enter "dhcpd" to run dhcpd as user 'dhcpd'.
#
DHCPD_RUN_AS="dhcpd"

## Type: string
## Default: ""
## ServiceRestart: dhcpd
#
# Other arguments that you want dhcpd to be started with
# (e.g. "-p 1234" for a non-standard port to listen on)
#
DHCPD_OTHER_ARGS=""

## Type: string
## Default: ""
## ServiceRestart: dhcpd
#
# You may specify another dhcpd binary to be run.
#
# This can be employed to use /usr/sbin/dhcpd.lpf, a dhcpd binary that is
# compiled with the Linux packet filter API instead of BSD sockets.
# Only in rare cases (e.g. non-RFC compliant clients) should this be needed.
#
#
# If empty, the default applies.
#
DHCPD_BINARY=""

/etc/dhcp.conf:
#
# Sample configuration file for ISC dhcpd
#
# Make changes to this file and copy it to /etc/dhcpd.conf.sample
#

ddns-update-style none;

default-lease-time 21600;
max-lease-time 21600;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option routers 192.168.84.1;
option domain-name-servers 192.168.84.1;
option domain-name "ltsp"; # <--Fix this domain name

option root-path "192.168.84.1:/opt/ltsp/i386";

option option-128 code 128 = string;
option option-129 code 129 = text;

subnet 192.168.1.128 netmask 255.255.255.128 {
use-host-decl-names on;
option log-servers 192.168.84.1;


##
## If you want to use static IP address for your workstations, then un-comment
## the following section and modify to suit your network.
## Then, duplicate this section for each workstation that needs a static
## IP address.
##
## host ws001 { <----- Fix this hostname
## hardware ethernet 00:05:5d:fb:5d:93; <-- Fix this MAC addr
## fixed-address 192.168.84.1; <-- Fix this IP addr
## filename "/lts/vmlinuz.ltsp";
##

##
## If you want to use a dynamic pool of addresses, then un-comment the following
## lines and modify to match your network.
##
## subnet 192.168.0.0 netmask 255.255.255.0 {
## range dynamic-bootp 192.168.0.1 192.168.0.253;
## }
##

}

#
# If you need to pass parameters on the kernel command line, you can
# do it with option-129. In order for Etherboot to look at option-129,
# you MUST have option-128 set to a specific value. The value is a
# special Etherboot signature of 'e4:45:74:68:00:00'.
#
# Add these two lines to the host entry that needs kernel parameters
#
# option option-128 e4:45:74:68:00:00; # NOT a mac address
# option option-129 "NIC=ne IO=0x300";
#


Hoffe ihr könnt mir helfen :)
stka
Moderator
Moderator
Beiträge: 3351
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Beitrag von stka »

Kann es sein, dass du die Datei mit dem "vi" editiert hast, und am Ende keine RETURN gedrückt hast? Dann ist die Zeile nicht richtig abgeschlossen und der dhcpd weigert sich eventuell zu starten.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 »

Ich hab beide Datein mit joe editiert.
Enter hab ich am Ende des Textes nicht gedrückt!

ABER das Problem war ja schon vorher da, bevor ich die Datein editiert habe.
stka
Moderator
Moderator
Beiträge: 3351
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Beitrag von stka »

Irgendwie ist deine Datei komisch, die Range für die IP-Adressen fehlt, die leastime finde ich auch nicht. Hier mal meine dhcpd.conf:
  • ddns-update-style none;
    get-lease-hostnames true;
    use-host-decl-names true;
    subnet 192.168.123.0 netmask 255.255.255.0 {
    option netbios-name-servers 192.168.123.100;
    option netbios-node-type 8;
    range 192.168.123.55 192.168.123.60;
    default-lease-time 25920;
    max-lease-time 51840;
    option subnet-mask 255.255.255.0;
    option routers 192.168.123.102;
    option domain-name-servers 192.168.123.100,192.168.123.103;
    option domain-name "lokal.de";
    }
Villeicht hilft es. Auch passt die Fehlermeldung mit den Zeilennummer 6 und 11 nicht auf deine Datei :shock:
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 »

So und nochmal meine dhcpd.conf datei:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.1;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.84.1;
option routers 192.168.84.1;
ddns-update-style none;

option root-path "192.168.84.1:/opt/ltsp/i386";

subnet 192.168.84.1 netmask 255.255.255.1

{
range 192.168.84.100 192.168.84.110;
default-lease-time 25200;
max-lease-time 691200;
}

Wenn ich dann in der Shell dhcpd restart eingebe, kommt das hier:

Internet Systems Consortium DHCP Server V3.0.2
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
Address range 192.168.84.100 to 192.168.84.110 not on net 192.168.84.1/255.255.255.1!

If you did not get this software from ftp.isc.org, please
get the latest from ftp.isc.org and install that before
requesting help.

If you did get this software from ftp.isc.org and have not
yet read the README, please read it before requesting help.
If you intend to request help from the dhcp-server@isc.org
mailing list, please read the section on the README about
submitting bug reports and requests for help.

Please do not under any circumstances send requests for
help directly to the authors of this software - please
send them to the appropriate mailing list as described in
the README file


Was hat er gegen meine Address range 192.168.84.100 to 192.168.84.110 not on net 192.168.84.1/255.255.255.1 ?

Weil wenn ich den Thin-Cliente starte und er beim booten auf Netzwerk zugfreift, findet er keinen Dhcp Server :(
drathi81
Newbie
Newbie
Beiträge: 25
Registriert: 20. Jul 2004, 07:45
Wohnort: Unterschleißheim
Kontaktdaten:

Beitrag von drathi81 »

Hi,

Dein DHCP-Server meckert, weil Du ihm kein gültiges Subnet mitgegeben hast.
Was hat er gegen meine Address range 192.168.84.100 to 192.168.84.110 not on net 192.168.84.1/255.255.255.1 ?
Wieso hast Du als Subnetzmaske die 255.255.255.1 eingetragen?:?: Diese Maske ist nie und nimmer zulässig! Entweder trägst Du hier die 255.255.255.0 ein oder Du beschreibst einfach mal genauer, WAS Du erreichen möchtest. Ggf. können wir Dir dann auch damit weiterhelfen. :wink:
Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 »

Hier meine aktuelle Dhcpd.conf:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;

option root-path "192.168.84.1:/lts/2.4.26-ltsp-3/pxelinux.cfg/d

subnet 192.168.84.0 netmask 255.255.255.0 {
range 192.168.84.1 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;
}

So, ich möchte ein Ltsp Server aussetzen und dafür brauch ich ja deinen DHCP damit die Clients beim boote mit der PXE fähigen Netzwerkkarte sich die Daten holen.
Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 »

Moin Moin,

wollte euch nur bescheid sagen das der DHCP Server jetzt läuft :) :) :)

Ich hab die Firewall ausgeschaltet, da die den DHCP Server geblockt hat und im RunlevelEditor den Dhcp aktiviert und schon ging es :):)

Keine Ahnung wies es geht, aber er startet ihn jetzt und ich bin Happy :)

VIELEN DANK FÜR EURE HILFE!
Antworten