Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Probleme beim Schreiben von Windows auf Linux Freigaben

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
xadian
Newbie
Newbie
Beiträge: 49
Registriert: 7. Aug 2005, 13:44

Probleme beim Schreiben von Windows auf Linux Freigaben

Beitrag von xadian »

Hallo

Ich hab mir gestern zum ersten Mal einen Samba Server aufgebaut, um meinen Linux Rechner mit den Windows XP Rechnern hier im Netzwerk zu verbinden. Klappt auch alles, nur das Schreiben von einem Windows Rechner in einen unter Linux freigegebenen Ordner geht nicth...

[incoming]
path = /home/xadian/incoming/
read only = No
guest ok = Yes

Das is die entprechende Einstellung für den Ordner, der Schreib-freigegeben sein soll. Is da was falsch dran? Wenn nicht, waum könnte denn dann das Schreiben fehlschlagen?

Als Zweites würde ich gern wissen, wie ich einen freigegebenen Ordner mit einem Passwort sicher. Also dass jeder, der auf den Ordner zugreifen will das pw haben muss.

Und Drittens versteh ich die Geschichte mit den usern nich. Woher soll denn im Neztwerk der username kommen, den ich für einige Ordner angeben kann? Der Name des Zugreifenden Computers ist das ja nicht und ich kann unter Windows bei den Zugriffen auch keinen username angeben...
Was also soll diese Angabe (username = ...) ?

mfg
Xadian
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Da versehst du wirklich was falsch. Beim Netzlaufwerkverbinden z.B. kannst du einen Username angeben. Ansonsten versucht Windows erst mal den aktuell angemeldeten Benutzer an der Freigabe anzumelden.

Aber Grundsätzlich solltest du dir erst mal klar werden was du willst. Samba kennt verschiede Möglichkeiten Benutzer zu verwalten z.B. über die smbpasswd, im LDAP o. durch Abfrage eines Windows-Domänencontrollers. Aber dafür gibt es ganz gute Anleitungen in der SAMBA-Dokumentation.

Zu deinem Problem von oben. Wie gesagt Windows meldet den aktuellen Benutzer an der Freigabe an. Da er aber auf deinem Linux-System nicht bekannt ist, darfst du da erst mal auch nicht schreiben, sondern (aber nur wenn lesen für alle erlaubt ist) nur lesen. Du könntest das zwar mit force user umgehen, aber das war ja nicht die aufgabe.

Mach dich erst mal zur option security in der smb.conf schlau. Wenn du dann nicht weiter kommst, helfen wir dir gerne weiter.
Antworten