Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

MPPE funtioniert nicht auf VPN-Server

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

MPPE funtioniert nicht auf VPN-Server

Beitrag von rolle »

Liebe Leute!

Ich habe hier einen SuSE 9.3-Rechner stehen, dem ich einen Zugang per VPN über PPTP spendieren will. Ich habe also pptpd installiert und nach der Anleitung in /usr/share/doc/packages/pptpd/LIESMICH.SuSE die Konfiguration gebaut.
Nun habe ich aber das Problem, daß die Verschlüsselung per MPPE nicht klappt, die Option wird nicht erkannt. Fehlermeldung siehe hier im Auszug aus der /var/log/messages:
Aug 7 15:37:32 roland kernel: PPP MPPE Compression module registered
Aug 7 15:37:33 roland pptpd[10687]: MGR: Manager process started
Aug 7 15:37:42 roland pptpd[10689]: MGR: Launching /usr/sbin/pptpctrl to handle client
Aug 7 15:37:42 roland pptpd[10687]: MGR: No free connection slots or IPs - no more clients can connect!
Aug 7 15:37:42 roland pptpd[10689]: CTRL: local address = 192.168.1.1
Aug 7 15:37:42 roland pptpd[10689]: CTRL: remote address = 192.168.1.2
Aug 7 15:37:42 roland pptpd[10689]: CTRL: pppd speed = 115200
Aug 7 15:37:42 roland pptpd[10689]: CTRL: pppd options file = /etc/ppp/options.ppp0
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Client 192.168.0.2 control connection started
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Received PPTP Control Message (type: 1)
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Made a START CTRL CONN RPLY packet
Aug 7 15:37:42 roland pptpd[10689]: CTRL: I wrote 156 bytes to the client.
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Sent packet to client
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Received PPTP Control Message (type: 7)
Aug 7 15:37:42 roland pptpd[10689]: CTRL: 0 min_bps, 1525 max_bps, 32 window size
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Made a OUT CALL RPLY packet
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Starting call (launching pppd, opening GRE)
Aug 7 15:37:42 roland pptpd[10689]: CTRL: pty_fd = 5
Aug 7 15:37:42 roland pptpd[10689]: CTRL: tty_fd = 6
Aug 7 15:37:42 roland pptpd[10690]: CTRL (PPPD Launcher): Connection speed = 115200
Aug 7 15:37:42 roland pptpd[10689]: CTRL: I wrote 32 bytes to the client.
Aug 7 15:37:42 roland pptpd[10690]: CTRL (PPPD Launcher): local address = 192.168.1.1
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Sent packet to client
Aug 7 15:37:42 roland pptpd[10690]: CTRL (PPPD Launcher): remote address = 192.168.1.2
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Received PPTP Control Message (type: 15)
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Got a SET LINK INFO packet with standard ACCMs
Aug 7 15:37:42 roland pppd[10690]: In file /etc/ppp/options.ppp0: unrecognized option 'mppe-40'
Aug 7 15:37:42 roland pptpd[10689]: GRE: Bad checksum from pppd
Aug 7 15:37:42 roland pptpd[10689]: Error reading from pppd: Input/output error
Aug 7 15:37:42 roland pptpd[10689]: CTRL: GRE read or PTY write failed (gre,pty)=(6,5)
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Client 192.168.0.2 control connection finished
Aug 7 15:37:42 roland pptpd[10689]: CTRL: Exiting now
Aug 7 15:37:42 roland pptpd[10687]: MGR: Reaped child 10689
Egal, welche mppe-Option ich in der /etc/ppp/options.ppp0 aktiviere, der Fehler bleibt entsprechend und der Windowsclient (XP mit SP2) verweigert die Verbindung mit der Meldung, daß der Server die angeforderte Verschlüsselung nicht unterstütze. Eine Verbindung mit auskommentierten mppe-Optionen und ohne clientseitig zwingend vorgeschriebene Verschlüsselung klappt. Es sind keine Firewalls im Spiel. Hat jemand eine zündende Idee?[/b]
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
rm -rf /

Beitrag von rm -rf / »

soweit ich weiss, haben nur die allerneusten Kernel MPPE-Support, du musst deinen Kernel mit MPPE kompilieren, unter Debian kann man das so machen:
http://pptpclient.sourceforge.net/howto ... uild.phtml
und wenn du ein wenig ahnung von der materie hast, wirst das auch mit dieser Anleitung bei deinem SuSe hinkriegen, is einfach nur:
Kernel-Source laden, MPPE-Modul laden, Kernel konfigurieren mithilfe der aktuell benutzten config in /boot oder /proc und dem neuen mppe-patch, kompilieren, installieren, fertich! :shock: :D
stka
Moderator
Moderator
Beiträge: 3351
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Beitrag von stka »

Bei suse muss der Kernel nicht neu kompiliert werden!! Der MPPE Support ist schon mit drin. Bei debian ist er aus dem Grund nicht mit drin, da es sich bei dem Protokoll um "closed-source" handelt. Deshalb muss der Kernel bei debian und allen Distributionen die auf dem standard Kernel basieren neu kompiliert werden. Suse hat noch immer irgendwelche eigenen oder zusätzliche Komponenten in den Kernel gebracht.

Die local und remote IP sind im selben Netz, das geht bei VPN nicht. Das Quell- und Zielnetz müssen unterschiedliche IP-Netze sein.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Tip:
OpenVPN geht auch im Bridge-Mode
kann gegen mann in the middle konfiguriert werden und auch die Windows Version kann als Server und Client schmerzfrei installiert werden.

Wenn Du nicht unbedingt MicroSaft-PPTP brauchst ist OpenVPN die bessere Wahl.
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle »

OpenVPN bringt mir nichts, da ich eine Lösung bauen muß, die meine faulen und unwissenden User ohne große Konfigurationsorgie auf ihren Windowsrechnern anwenden können.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 »

Du schreibst nur "anwenden".
OpenVPN hat eine Gui für Windows mit Icon für unten rechts.
Ein Click und die Verbindung fährt hoch, ein anderer für Statusfenster.
Begründe es mit erhöhten Sicherheitsanforderungen und dem Bridge Mode.
Im BridgeMode geht auch der ganze NetBios-Kram, wenn Du willst.
Bei mir spielt der Grundlast noch eine Rollte, OpenVPN macht im Leerlauf fast keinen Trafiic.
PPTP frißt über den Tag eine Menge Traffic was sich bei 10 Benutzern und einer SDSL Leitung mit Volumentarif schon bemerkbar macht.
Antworten