Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Squid läuft nicht, wenn eth0 up ist...

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Direx
Newbie
Newbie
Beiträge: 31
Registriert: 4. Apr 2004, 09:15
Wohnort: Chemnitz
Kontaktdaten:

Squid läuft nicht, wenn eth0 up ist...

Beitrag von Direx »

Moin!

Ich habe ein Problem. Ich habe den squid von der SuSE 9.1 Pro und einen ISDN-Anschluss. Wenn ich nun den squid starte scheint alles normal zu funktionieren (ich bin schon im inet). Wenn ich nun aber noch den Befehl 'ifup eth0' eingebe (was ich brauche, um den Proxy überhaupt nutzen zu können, weil eth0 an einen Switch geht), geht nix mehr. Das heißt konkret, dass der squid einfach weiterläuft, aber er ist nicht mehr erreichbar. Erst wenn ich das Interface eth0 wieder herunterfahre, klappt wieder alles. Wenn eth0 oben ist, kann ich auch nichts mehr im Internet pingen...
Und wenn eth0 vor dem squid gestartet wurde, dann startet der squid gar nicht erst. Ihr seht, das ist ein verflixtes Problem. Mir scheint es so, als ob der squid lieber an eth0 lauscht, als an ippp0. Kann man da irgendwas dagegen machen?

Danke schon im Voraus,
mfg direx

[edit:]
Wenn eth0 up ist, kommt folgende Fehlermeldung:
ERROR

The requested URL could not be retrieved While trying to retrieve the URL: http://www.linux-club.de/posting.php?

The following error was encountered:

Connection Failed

The system returned:

(101) Network is unreachable

The remote host or network may be down. Please try the request again.


Your cache administrator is webmaster.


Generated Sun, 07 Aug 2005 08:36:30 GMT by proxy3.vlan2 (squid/2.5.STABLE5)
AMD Pro2000+, 640 MB-Ram, 240 GB HD, SuSE 9.3

Bild

Kämpft gegen die Amerikanisierung der deutschen Print-Medien!
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Kämpft gegen die Amerikanisierung der deutschen Print-Medien!
Mir kam Dein Posting recht amerikanisiert vor...

Aber mal zum Thema.
Und wenn eth0 vor dem squid gestartet wurde, dann startet der squid gar nicht erst.
Woran erkennst Du das ? Kriegst Du eine Fehlermeldung ? Was sagt 'rcsquid status' ?

Ich vermute ja daß da irgendwas mit DNS und/oder Standardgateway nicht stimmt.

Geh mal ins Internet (mit eth0 'oben') und poste dann die Ausgaben der Befehle 'ifconfig', 'route' und den Inhalt der '/etc/resolv.conf'.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Direx
Newbie
Newbie
Beiträge: 31
Registriert: 4. Apr 2004, 09:15
Wohnort: Chemnitz
Kontaktdaten:

Beitrag von Direx »

OK, nun kann ich das Problem etwas genauer eingrenzen. Es scheint nicht am squid zu liegen, weil ich gar nicht erst in Internet kann, wenn eth0 oben ist. So ein Mist. Weisst du vielleicht, woran das liegen kann?
Das Thema kann von mir aus nun auch verschoben werden, weil es ja scheinbar nicht am squid liegt...

Naja, wenn ich ifconfig eingebe, kommt folgendes:

eth0 Protokoll:Ethernet Hardware Adresse 00:A0:24:6A:xx:xx
inet Adresse:192.168.2.16 Bcast:192.168.2.255 Maske:255.255.255.0
inet6 Adresse: fe80::2a0:24ff:xxxx:xxxx/64 Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1318 errors:0 dropped:0 overruns:0 frame:0
TX packets:1423 errors:0 dropped:0 overruns:0 carrier:3
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:447728 (437.2 Kb) TX bytes:379632 (370.7 Kb)
Interrupt:11 Basisadresse:0xe800

ippp0 Protokoll:Punkt-zu-Punkt Verbindung
inet Adresse:212.144.xx.xx P-z-P:145.253.xxxx Maske:255.255.255.255
UP PUNKTZUPUNKT RUNNING NOARP DYNAMIC MTU:1500 Metric:1
RX packets:387 errors:0 dropped:0 overruns:0 frame:0
TX packets:414 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:30
RX bytes:258528 (252.4 Kb) TX bytes:74715 (72.9 Kb)

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:11217 errors:0 dropped:0 overruns:0 frame:0
TX packets:11217 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:8985290 (8.5 Mb) TX bytes:8985290 (8.5 Mb)


Und zu guter letzt:

ifdown eth0
eth0 device: 3Com Corporation 3c595 100BaseTX [Vortex]
eth0 configuration: eth-id-00:a0:24:6a:xx:xx

Warning: interface eth0 is not (yet?) active.

(Das Interface war aber oben!!!)

mfg,
direx
AMD Pro2000+, 640 MB-Ram, 240 GB HD, SuSE 9.3

Bild

Kämpft gegen die Amerikanisierung der deutschen Print-Medien!
Antworten