Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem: Inkscape öffnen

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Gesperrt
Tlaloc
Member
Member
Beiträge: 137
Registriert: 18. Mai 2005, 18:00

Problem: Inkscape öffnen

Beitrag von Tlaloc »

Hallo,
nach einer scheinbar korrekten Installation (über Apt) kann ich Inkscape nicht öffnen. Konsole gibt mir beim Versuch folgende Fehlermeldung:

"error whilie loading shared libraries /optgnome/libraries/libgnomeprintui-2-2.so.0: undefined symbol: gdk_threads_lock"

Der letzte Teil sagt mir leider gar nichts.
Hat jemand 'ne Idee?

Grüße, S.
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

Die Versionen der Bibliotheken passen nicht zusammen. Aktualisiere das Paket "libgnomeprintui" auf die neueste Version von suser-guru.
openSUSE Factory - GNOME 2.32.1
Tlaloc
Member
Member
Beiträge: 137
Registriert: 18. Mai 2005, 18:00

Beitrag von Tlaloc »

Danke für den Tipp,
aber lt. Kynaptic habe ich bereits die neueste Version dieser lib (2.11.0-5). Klappt trotzdem nicht ....
Benutzeravatar
oddikurt
Hacker
Hacker
Beiträge: 597
Registriert: 8. Mai 2005, 01:39
Wohnort: BW i.d.N.v. Pforzheim

Beitrag von oddikurt »

Hi siquame,

das Problem ist auch bei Inkscape bekannt, die schreiben da was von einer version 0.42.1 die in kürze kommen soll und das Problem behebt. :wink:

http://www.inkscape.org/
gruss Roger >>>Linuxer #389900<<<
Manage Your Packages, or They Will Manage You

© 2000 Red Hat, Inc.
Edward C. Bailey: Taking the RPM Package Manager to the Limit
Tlaloc
Member
Member
Beiträge: 137
Registriert: 18. Mai 2005, 18:00

Beitrag von Tlaloc »

@oddikurt:
Danke, aber das ist auch nicht mein Problem - ich hatte vor einiger Zeit noch Inkscape 0.41 runtergeladen.

Ich würde ja gern berichten, dass ich das schon selbst gelöst hätte: Hab mich ein wenig schlau gemacht und herausgefunden, dass 0.41 mindestens Gtk2 2.4.0 benötigt - ich hatte noch 2.2. Also Upgrade auf das aktuelle 2.7 - neue Fehlermeldung:

"error while loading shared libraries: /opt/gnome/lib/libgtk-x11-2.0.so.0: undefined symbol: g_option_context_new"

Toller Nebeneffekt: Firefox läuft jetzt auch nicht mehr, sondern liefert die gleiche Fehlermeldung. Das nennt man dann wohl verschlimmbessern ...

Grüße, S.
cozi
Member
Member
Beiträge: 172
Registriert: 19. Apr 2004, 15:31
Wohnort: Bruchsal
Kontaktdaten:

Beitrag von cozi »

Nachdem Du Deine 9.1 schon mit dem KDE hochgetunt hast, wird es natürlich etwas schwierig, neueste Programme zu installieren - wie wäre es, mal die SuSE upzudaten???

Grüße, COZi
Der Weg ist das Ziel...
Benutzeravatar
oddikurt
Hacker
Hacker
Beiträge: 597
Registriert: 8. Mai 2005, 01:39
Wohnort: BW i.d.N.v. Pforzheim

Beitrag von oddikurt »

Hi siquame,

Wenn Du Bibliotheken erneuert hast und solche Dinge, führe einmal (falls nicht aktuell schon geschehen) ein

Code: Alles auswählen

ldconfig
als root aus.
gruss Roger >>>Linuxer #389900<<<
Manage Your Packages, or They Will Manage You

© 2000 Red Hat, Inc.
Edward C. Bailey: Taking the RPM Package Manager to the Limit
Tlaloc
Member
Member
Beiträge: 137
Registriert: 18. Mai 2005, 18:00

Beitrag von Tlaloc »

"ldconfig" habe ich jetzt ausprobiert und mit Parameter - v beobachtet: Generiert alle möglichen neuen Links, aber leider nicht für die problematische "libgtk-x11". Offenbar kann man mit "ldconfig -l" so etwas auch manuell erzeugen, aber sorry - so sicher bin ich nicht auf der Kommandozeile.

SUSE aufstocken ist natürlich eine größere Aktion, und bisher war ich mit 9.1 eigentlich sehr zufrieden ... Mal sehen, wenn sich die Probleme auseiten, ist das vielleicht wirklich einfacher ...

Erstmal danke für eure Tipps, S.
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

ldconfig braucht man nicht auszuführen, wenn man Bibliotheken als RPMs installiert hat, weil die RPMs das selber tun. Tun sie es nicht, dann handelt es sich um defekte RPMs, von denen man dann lieber ganz die Finger lassen sollte.
siquame hat geschrieben:"ldconfig" habe ich jetzt ausprobiert und mit Parameter - v beobachtet: Generiert alle möglichen neuen Links, aber leider nicht für die problematische "libgtk-x11". Offenbar kann man mit "ldconfig -l" so etwas auch manuell erzeugen, aber sorry - so sicher bin ich nicht auf der Kommandozeile.
ldconfig generiert keine Links und auch das manuelle Setzen von Links bringt nichts, weil Dir keine Links fehlen, sondern die richtige Version einer Bibliothek. Fehlermeldungen über undefinierte Symbole bedeuten, dass die benötigte Bibliothek gefunden wurde und es sich dabei um die falsche Version handelt.
openSUSE Factory - GNOME 2.32.1
Tlaloc
Member
Member
Beiträge: 137
Registriert: 18. Mai 2005, 18:00

Beitrag von Tlaloc »

Aha - hab ich wohl was missverstanden. In der Manpage steht "ldconfig creates links" etc. pp. Aber ich glaub's dir unbesehen, traffic, und mir ist jetzt auch klarer, wo eigentlich das Problem liegt (in letzter Konsequenz: bei mir).

Bevor ich noch mehr Chaos produziere (sei's hier im Forum oder auf meinem System), werde ich besser dem Rat von Cozi folgen. Hab mir gerade 'ne Suse 9.3-DVD besorgt und werd' damit 'rumspielen.

Das ist längst kein Grafik-Problem mehr, und auch nur noch für mich, aber nicht für die Allgemeinheit von Interesse. Deswegen Dank an alle, die etwas beigetragen haben, aber trotzdem die Bitte
@Mod: shut down!

Grüße, und drückt mir die Daumen für das Update (Downgrade KDE auf 3.4.0 :cry: - aber was will man machen) - S.
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Ich komme Deinem Wünsch mal entgegen und schließe diesen Beitrag :)

Nach Deinem Update auf die 9.3 wird es sicherlich besser laufen.
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Gesperrt